summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEthan Kerrick2024-05-10 00:35:19 -0400
committerEthan Kerrick2024-05-10 00:35:19 -0400
commitdeb91902ec979951744a0460cab587d9ef65bf8e (patch)
tree1001b41b1d721dc9e96c776b0c0c68acb6cb2b31
parentb34e98304475a805a0703a11fce2945564beae35 (diff)
downloadaur-imgbrd-grabber-git.tar.gz
build rework, add module
-rw-r--r--.SRCINFO7
-rw-r--r--Grabber.desktop28
-rw-r--r--PKGBUILD29
3 files changed, 18 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 150a7218bf50..ab0dd8f01b54 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = imgbrd-grabber-git
pkgdesc = Very customizable imageboard/booru downloader with powerful filenaming features.
- pkgver = v7.11.2.r107.g84b6896e
+ pkgver = 7.11.2.r174.gd54bdce7
pkgrel = 1
+ epoch = 1
url = https://github.com/Bionus/imgbrd-grabber
arch = i686
arch = x86_64
- license = Apache
+ license = Apache-2.0
makedepends = git
makedepends = cmake
makedepends = qt6-tools
@@ -19,10 +20,10 @@ pkgbase = imgbrd-grabber-git
provides = imgbrd-grabber
conflicts = imgbrd-grabber
source = git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop
- source = Grabber.desktop
source = git+https://github.com/catchorg/Catch2.git
source = git+https://github.com/sakra/cotire.git
source = git+https://github.com/LaurentGomila/qt-android-cmake.git
+ source = git+https://github.com/lexbor/lexbor.git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
diff --git a/Grabber.desktop b/Grabber.desktop
deleted file mode 100644
index 87036553aa86..000000000000
--- a/Grabber.desktop
+++ /dev/null
@@ -1,28 +0,0 @@
-[Desktop Entry]
-
-# The type as listed above
-Type=Application
-
-# The version of the desktop entry specification to which this file complies
-Version=1.0
-
-# The name of the application
-Name=Grabber
-
-# A comment which can/will be used as a tooltip
-Comment=a Very customizable imageboard/booru downloader
-
-# The path to the folder in which the executable is run
-Path=/usr/bin
-
-# The executable of the application, possibly with arguments.
-Exec=Grabber
-
-# The name of the icon that will be used to display this entry
-Icon=Grabber
-
-# Describes whether this application needs to be run in a terminal or not
-Terminal=false
-
-# Describes the categories in which this entry should be shown
-Categories=Graphics;
diff --git a/PKGBUILD b/PKGBUILD
index 4244bc406d01..699b6cc5da5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
-# Maintainer: Flat <flat@imo.uto.moe>
+# Maintainer: silverhikari <kerrickethan@gmail.com>
+# Contributor: Flat <flat@imo.uto.moe>
pkgname=imgbrd-grabber-git
-pkgver=v7.11.2.r107.g84b6896e
+pkgver=7.11.2.r174.gd54bdce7
pkgrel=1
+epoch=1
pkgdesc="Very customizable imageboard/booru downloader with powerful filenaming features."
arch=('i686' 'x86_64')
url="https://github.com/Bionus/imgbrd-grabber"
-license=('Apache')
+license=('Apache-2.0')
depends=('qt6-multimedia' 'qt6-declarative' 'nodejs' 'qt6-networkauth' 'hicolor-icon-theme')
makedepends=('git' 'cmake' 'qt6-tools' 'npm')
optdepends=('openssl: used for HTTPS sources')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop' 'Grabber.desktop' 'git+https://github.com/catchorg/Catch2.git' 'git+https://github.com/sakra/cotire.git' 'git+https://github.com/LaurentGomila/qt-android-cmake.git')
+source=('git+https://github.com/Bionus/imgbrd-grabber.git#branch=develop' 'git+https://github.com/catchorg/Catch2.git' 'git+https://github.com/sakra/cotire.git' 'git+https://github.com/LaurentGomila/qt-android-cmake.git' 'git+https://github.com/lexbor/lexbor.git')
md5sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "$srcdir/${pkgname%-git}"
git submodule init
- git config submodule.catch.url "$srcdir/Catch2"
- git config submodule.qt-android-cmake.url "$srcdir/qt-android-cmake"
- git config submodule.cotire.url "$srcdir/cotire"
+ git config submodule.tests/src/vendor/catch.url "$srcdir/Catch2"
+ git config submodule.cmake/qt-android-cmake.url "$srcdir/qt-android-cmake"
+ git config submodule.cmake/cotire.url "$srcdir/cotire"
+ git config submodule.lib/vendor.lexbor.url "$srcdir/lesbor"
git -c protocol.file.allow=always submodule update
}
@@ -34,15 +37,11 @@ build() {
-DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
-DUSE_QSCINTILLA=0 \
- -DUSE_BREAKPAD=O \
+ -DUSE_BREAKPAD=0 \
-Wno-dev
- make -C build
+ cmake --build build
}
package() {
- cd "$srcdir/build"
- make DESTDIR="$pkgdir/" install
- install -Dm644 "$srcdir/${pkgname%-git}/src/gui/resources/images/icon.png" "$pkgdir/usr/share/pixmaps/Grabber.png"
- install -Dm644 "$srcdir/Grabber.desktop" "$pkgdir/usr/share/applications/Grabber.desktop"
- touch "$pkgdir/usr/share/Grabber/settings.ini"
+ DESTDIR="$pkgdir" cmake --install build
}