summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHolden Lewis2020-10-24 20:43:19 -0700
committerHolden Lewis2020-10-24 20:43:19 -0700
commitc6b01ef901ef5ccb70fcfcd4a973ed9cf829ec47 (patch)
treef0a8c4f860bfe19276c2ceb70c9f397117ea2d7a
parent0ff52be9cccb22fb46f13ef66d11e6fcf9aeef1e (diff)
downloadaur-impostor-server.tar.gz
Add impostor service and config files
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--impostor.service15
3 files changed, 27 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c653485d3cdd..758f58200c66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = impostor-server
pkgdesc = Unofficial dedicated server for Among Us.
pkgver = 1.1.0
- pkgrel = 3
+ pkgrel = 4
url = https://impostor.github.io/Impostor/
arch = x86_64
license = GPL3
@@ -14,9 +14,11 @@ pkgbase = impostor-server
source = git+https://github.com/Impostor/Impostor.git#tag=v1.1.0
source = git+https://github.com/AeonLucid/Hazel-Networking.git
source = https://dot.net/v1/dotnet-install.sh
+ source = impostor.service
sha512sums = SKIP
sha512sums = SKIP
sha512sums = ffbcb792bc25976322c18189d8884bbddd8e0fdc216a0e541b8a28baf4791001cb6cd114bb2935190df8cfe95fc909cc87b64e87d8f1f3d0a77e0fd2f4a1f43e
+ sha512sums = b1360d6aa5cd769ee7dbdb32148f7e1786acdb6a3080b67a48328252af8cc18ff3448a46f04e656993d891a578217599de96a80e96d7da57f95b107d451fdfaa
pkgname = impostor-server
diff --git a/PKGBUILD b/PKGBUILD
index ead86ccabe3e..c70e2eaa8f77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=impostor-server
pkgver=1.1.0
-pkgrel=3
+pkgrel=4
pkgdesc='Unofficial dedicated server for Among Us.'
url='https://impostor.github.io/Impostor/'
arch=('x86_64')
@@ -12,10 +12,12 @@ makedepends=('git' 'dotnet-sdk' 'lttng-ust')
options=('!strip')
source=("git+https://github.com/Impostor/Impostor.git#tag=v${pkgver}"
"git+https://github.com/AeonLucid/Hazel-Networking.git"
- "https://dot.net/v1/dotnet-install.sh")
+ "https://dot.net/v1/dotnet-install.sh"
+ "impostor.service")
sha512sums=('SKIP'
'SKIP'
- 'ffbcb792bc25976322c18189d8884bbddd8e0fdc216a0e541b8a28baf4791001cb6cd114bb2935190df8cfe95fc909cc87b64e87d8f1f3d0a77e0fd2f4a1f43e')
+ 'ffbcb792bc25976322c18189d8884bbddd8e0fdc216a0e541b8a28baf4791001cb6cd114bb2935190df8cfe95fc909cc87b64e87d8f1f3d0a77e0fd2f4a1f43e'
+ 'b1360d6aa5cd769ee7dbdb32148f7e1786acdb6a3080b67a48328252af8cc18ff3448a46f04e656993d891a578217599de96a80e96d7da57f95b107d451fdfaa')
prepare() {
chmod +x ./dotnet-install.sh
@@ -36,6 +38,10 @@ build() {
package() {
mkdir -p "${pkgdir}/usr/bin/"
+ mkdir -p "${pkgdir}/etc/impostor/"
+ mkdir -p "${pkgdir}/usr/lib/systemd/system/"
cp --verbose "${srcdir}/Impostor/build/linux-x64/Impostor.Server" "${pkgdir}/usr/bin/impostor-server"
+ cp --verbose "${srcdir}/Impostor/build/linux-x64/config.json" "${pkgdir}/etc/impostor/"
+ cp --verbose "${srcdir}/impostor.service" "${pkgdir}/usr/lib/systemd/system/"
}
diff --git a/impostor.service b/impostor.service
new file mode 100644
index 000000000000..6c0e0934266d
--- /dev/null
+++ b/impostor.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Among Us dedicated server
+After=network.target
+
+[Service]
+Type=simple
+User=impostor
+DynamicUser=yes
+ExecStart=/usr/bin/impostor-server
+BindReadOnlyPaths=/etc/impostor/:/var/lib/impostor/
+WorkingDirectory=/var/lib/impostor/
+Restart=always
+
+[Install]
+WantedBy=multi-user.target