summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTobias Leupold2023-02-02 19:03:29 +0100
committerTobias Leupold2023-02-02 19:03:29 +0100
commit0e727168af96ce89aa523e261cdc9b87be7fc77c (patch)
tree173ac8b73f2bfdb7c83ff8e95361d9a9d25b537b
downloadaur-incron-openrc.tar.gz
Initial commit: Added an OpenRC init script for incrond
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD22
-rw-r--r--incrond.confd26
-rwxr-xr-xincrond.initd26
5 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83d1016f200a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = incron-openrc
+ pkgdesc = OpenRC incron init script
+ pkgver = 20230202
+ pkgrel = 1
+ arch = any
+ groups = openrc-system
+ license = GPL2
+ depends = openrc
+ depends = incron
+ provides = init-incron
+ conflicts = init-incron
+ backup = etc/conf.d/incrond
+ source = incrond.initd
+ source = incrond.confd
+ sha256sums = 7d7319ecd3c3996b3c6e06b684d5954c23602c21c6fcc6d14a17b15a49ac3280
+ sha256sums = 74163bbb348555b2f98ea2814696763078f8ee5fd243c06e0e1ee3a12642b83d
+
+pkgname = incron-openrc
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b32f0f035cf3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg/
+src/
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..015d3e2d13f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Tobias Leupold <tl at stonemx dot de>
+pkgname=incron-openrc
+pkgver=20230202
+pkgrel=1
+pkgdesc="OpenRC incron init script"
+arch=( "any" )
+license=( "GPL2" )
+groups=( "openrc-system" )
+provides=( "init-incron" )
+depends=( "openrc" "incron" )
+conflicts=( "init-incron" )
+backup=( "etc/conf.d/incrond" )
+source=( "incrond.initd"
+ "incrond.confd" )
+sha256sums=( "7d7319ecd3c3996b3c6e06b684d5954c23602c21c6fcc6d14a17b15a49ac3280"
+ "74163bbb348555b2f98ea2814696763078f8ee5fd243c06e0e1ee3a12642b83d" )
+
+package()
+{
+ install -Dm755 "$srcdir/incrond.initd" "$pkgdir/etc/init.d/incrond"
+ install -Dm644 "$srcdir/incrond.confd" "$pkgdir/etc/conf.d/incrond"
+}
diff --git a/incrond.confd b/incrond.confd
new file mode 100644
index 000000000000..3ae3809eb0c4
--- /dev/null
+++ b/incrond.confd
@@ -0,0 +1,26 @@
+# /etc/conf.d/incrond
+
+# Configuration file
+#INCROND_CONFFILE="/etc/incron.conf"
+
+# PID file
+# When running multiple instances make sure that this value matches
+# ${lockfile_dir}/${lockfile_name}.pid set in ${INCROND_CONFFILE}.
+#INCROND_PIDFILE="/var/run/incrond.pid"
+
+# You can use this configuration option to pass additional options to the
+# start-stop-daemon, see start-stop-daemon(8) for more details.
+# Per default we wait 1000ms after we have started the service to ensure
+# that the daemon is really up and running.
+#INCROND_SSDARGS="--wait 1000"
+
+# The termination timeout (start-stop-daemon parameter "retry") ensures
+# that the service will be terminated within a given time (25 + 5 seconds
+# per default) when you are stopping the service.
+#INCROND_TERMTIMEOUT="TERM/25/KILL/5"
+
+# Options to incrond
+# See incrond(8) for more details
+# Notes:
+# * Do not specify another CONFIGFILE but use the variable above to change the location
+#INCROND_OPTS=""
diff --git a/incrond.initd b/incrond.initd
new file mode 100755
index 000000000000..6900f6b5b28f
--- /dev/null
+++ b/incrond.initd
@@ -0,0 +1,26 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+INCROND_BINARY=${INCROND_BINARY:-"/usr/sbin/incrond"}
+INCROND_CONFFILE=${INCROND_CONFFILE:-"/etc/incron.conf"}
+INCROND_PIDFILE=${INCROND_PIDFILE:-"/var/run/incrond.pid"}
+INCROND_SSDARGS=${INCROND_SSDARGS:-"--wait 1000"}
+INCROND_TERMTIMEOUT=${INCROND_TERMTIMEOUT:-"TERM/25/KILL/5"}
+INCROND_OPTS=${INCROND_OPTS:-""}
+
+command=${INCROND_BINARY}
+command_args="${INCROND_OPTS} -f \"${INCROND_CONFFILE}\""
+start_stop_daemon_args="${INCROND_SSDARGS}"
+pidfile="${INCROND_PIDFILE}"
+retry="${INCROND_TERMTIMEOUT}"
+
+required_files="${INCROND_CONFFILE}"
+
+name="incron daemon"
+description="inotify cron daemon monitors filesystem events and executes commands defined in system and user tables"
+
+depend() {
+ use clock logger
+ need localmount
+}