summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLancelot Owczarczak2023-11-15 11:11:42 +0100
committerLancelot Owczarczak2023-11-15 11:11:42 +0100
commit7ae8708a242c5f8cad97c1d943330260e70cacb7 (patch)
treed900127cabd657528f4a1c676086b87d71608f7d
downloadaur-inochi-session.tar.gz
Initial commit, v0.8.3
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16f3d379ef34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = inochi-session
+ pkgdesc = Application that allows streaming with Inochi2D puppets
+ pkgver = 0.8.3
+ pkgrel = 1
+ url = https://inochi2d.com/
+ arch = x86_64
+ license = custom
+ depends = dbus
+ depends = freetype2
+ depends = gcc-libs
+ depends = sdl2
+ depends = glibc
+ provides = cimgui.so
+ source = https://github.com/Inochi2D/inochi-session/releases/download/v0.8.3/inochi-session-linux-x86_64.zip
+ source = https://github.com/Inochi2D/inochi-session/archive/refs/tags/v0.8.3.zip
+ sha512sums = 8e89c6880b158d5c8d5df95a2451a50a950247506725d5e987dc2e9cb0af9f1b83185ac4ae39cb542a0a56d7b4968b1008203ab0a98ef0aa3e70d5d3123ea33b
+ sha512sums = 342822cf923d21a348012251809bc42f7da15c856df73de3e8baa5e63b202c6a687744a9ef5b193a363df452bddae86b2f835aaea666796a9d4bf61e6b6cd059
+
+pkgname = inochi-session
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..af7b70988513
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lancelot OWCZARCZAK <lancelot@owczarczak.fr>
+
+pkgname=inochi-session
+pkgver=0.8.3
+pkgrel=1
+pkgdesc="Application that allows streaming with Inochi2D puppets"
+arch=('x86_64')
+url='https://inochi2d.com/'
+license=('custom')
+provides=('cimgui.so')
+depends=(dbus freetype2 gcc-libs sdl2 glibc)
+source=(
+ "https://github.com/Inochi2D/inochi-session/releases/download/v$pkgver/inochi-session-linux-x86_64.zip"
+ "https://github.com/Inochi2D/inochi-session/archive/refs/tags/v0.8.3.zip"
+ )
+
+sha512sums=("8e89c6880b158d5c8d5df95a2451a50a950247506725d5e987dc2e9cb0af9f1b83185ac4ae39cb542a0a56d7b4968b1008203ab0a98ef0aa3e70d5d3123ea33b" "342822cf923d21a348012251809bc42f7da15c856df73de3e8baa5e63b202c6a687744a9ef5b193a363df452bddae86b2f835aaea666796a9d4bf61e6b6cd059")
+
+package() {
+ cd "$srcdir"
+ install -m 755 -D cimgui.so "$pkgdir/usr/bin/cimgui.so"
+ install -m 755 -D inochi-session "$pkgdir/usr/bin/inochi-session"
+ install -m 644 -D LICENSE-FreeType "$pkgdir/usr/share/licenses/inochi-session/LICENSE-FreeType"
+ install -m 644 -D LICENSE-imgui "$pkgdir/usr/share/licenses/inochi-session/LICENSE-imgui"
+ install -m 644 -D LICENSE-Lua "$pkgdir/usr/share/licenses/inochi-session/LICENSE-Lua"
+ install -m 644 -D LICENSE-Spout2 "$pkgdir/usr/share/licenses/inochi-session/LICENSE-Spout2"
+ install -m 644 -D MaterialIcons-LICENSE "$pkgdir/usr/share/licenses/inochi-session/MaterialIcons-LICENSE"
+ cd "$srcdir/$pkgname-$pkgver"
+ install -m 644 -D LICENSE "$pkgdir/usr/share/licenses/inochi-session/LICENSE"
+}