summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNate Levesque2017-01-04 20:53:08 -0500
committerNate Levesque2017-01-04 20:53:08 -0500
commitee4499c18d620f2bca935372556f8e646e83abd3 (patch)
tree6166c287c683fcd29ef09d0afc95d98c3fe1dc29
parentfe82c823d677373e3b4fa6e93395d8b99c26669a (diff)
downloadaur-ee4499c18d620f2bca935372556f8e646e83abd3.tar.gz
Update to v1.3.14
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa4c7d44b5ee..35174d05a6a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = insync
pkgdesc = An unofficial Google Drive client that runs on Linux, with support for various desktops
- pkgver = 1.3.12
- pkgrel = 3
+ pkgver = 1.3.14
+ pkgrel = 1
url = https://www.insynchq.com/downloads
arch = i686
arch = x86_64
@@ -15,10 +15,10 @@ pkgbase = insync
source = insync.service
sha256sums = cf276c1dbf1592ea63a21c2d61c75f7ad6ec3b13e87b3aaa331e9c14799f4598
sha256sums = 1432141539a6b3c5333631a2ee6696fab9bd2fe8770643bc670d95e4e96203e0
- source_i686 = http://s.insynchq.com/builds/insync_1.3.12.36116-trusty_i386.deb
- sha256sums_i686 = b0c27926de2fea42c07c92285cd96c2936e449cab37c38a354a81a94b5d9298e
- source_x86_64 = http://s.insynchq.com/builds/insync_1.3.12.36116-trusty_amd64.deb
- sha256sums_x86_64 = 750f1bfa381e1019b7320af24b43d800c95a737968ee15d4d174dd9f4ac6f5a2
+ source_i686 = http://s.insynchq.com/builds/insync_1.3.14.36131-trusty_i386.deb
+ sha256sums_i686 = ea5ce7a9cdbf0616f2629c00dcee91c0f5e2a2ecc7e9d88eb288012ab805fb59
+ source_x86_64 = http://s.insynchq.com/builds/insync_1.3.14.36131-trusty_amd64.deb
+ sha256sums_x86_64 = 2fd633d6d84e8c691d3a1c993d2eefee7bdd5dbec021d0b0cf6f24c27841eda5
pkgname = insync
diff --git a/PKGBUILD b/PKGBUILD
index 05d59ef32e95..5a71f820f899 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,9 @@
# Contributor: Zhengyu Xu <xzy3186@gmail.com>
pkgname=insync
-pkgver=1.3.12
-_pkgver=36116
-pkgrel=3
+pkgver=1.3.14
+_pkgver=36131
+pkgrel=1
pkgdesc="An unofficial Google Drive client that runs on Linux, with support for various desktops"
url="https://www.insynchq.com/downloads"
license=('custom:insync')
@@ -17,18 +17,23 @@ source_i686=("http://s.insynchq.com/builds/${pkgname}_${pkgver}.${_pkgver}-trust
source_x86_64=("http://s.insynchq.com/builds/${pkgname}_${pkgver}.${_pkgver}-trusty_amd64.deb")
sha256sums=('cf276c1dbf1592ea63a21c2d61c75f7ad6ec3b13e87b3aaa331e9c14799f4598'
'1432141539a6b3c5333631a2ee6696fab9bd2fe8770643bc670d95e4e96203e0')
-sha256sums_i686=('b0c27926de2fea42c07c92285cd96c2936e449cab37c38a354a81a94b5d9298e')
-sha256sums_x86_64=('750f1bfa381e1019b7320af24b43d800c95a737968ee15d4d174dd9f4ac6f5a2')
+sha256sums_i686=('ea5ce7a9cdbf0616f2629c00dcee91c0f5e2a2ecc7e9d88eb288012ab805fb59')
+sha256sums_x86_64=('2fd633d6d84e8c691d3a1c993d2eefee7bdd5dbec021d0b0cf6f24c27841eda5')
package() {
tar xvf data.tar.gz
cp -rp usr $pkgdir
+ # Patch files for Arch
cd $pkgdir
+ echo "==> Patching files..."
for file in $(grep -R "/usr/bin/python" . | cut -f1 -d :)
do
- sed -i "s|usr/bin/python$|usr/bin/python2|g" $file
+ grepPrefix=$(echo $file | cut -f1 -d" ")
+ [ -z $grepPrefix ] && sed -i "s|usr/bin/python$|usr/bin/python2|g" $file
done
+ # End of patching
+
mkdir -p ${pkgdir}/usr/lib/systemd/system
mkdir -p ${pkgdir}/usr/lib/systemd/user
cp ${srcdir}/insync@.service ${pkgdir}/usr/lib/systemd/system/insync@.service