summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Stukalov2019-04-23 13:44:32 +0200
committerAlexey Stukalov2019-04-23 14:12:32 +0200
commit9b0140349c702c9a3570013357b306d80c694c00 (patch)
tree9afce11a049b2ca6d8427aafb047e845ba586300
parent663a8950b2ad98d8d41c7961b53e0e913136226c (diff)
downloadaur-9b0140349c702c9a3570013357b306d80c694c00.tar.gz
add FORCE_PKGEXT command line option
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 445a0f634418..3d73f939505a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -51,15 +51,22 @@ pkgname=('intel-common-libs'
'intel-vtune-amplifier'
'intel-inspector')
-PKGEXT='.pkg.tar.lzo'
-msg "Overriding PKGEXT with PKGEXT='${PKGEXT}'"
+if [ -z "$FORCE_PKGEXT" ]; then
+ PKGEXT='.pkg.tar.lzo'
+ msg "Overriding the default PKGEXT with '${PKGEXT}' to save compression time"
+ msg "(change PKGEXT in the PKGBUILD or use FORCE_PKGEXT on the command line"
+ msg " to override PKGEXT set by the package)."
+else
+ msg "Overriding PKGEXT with FORCE_PKGEXT='${FORCE_PKGEXT}'"
+ PKGEXT=$FORCE_PKGEXT
+fi
if [ "$PKGEXT" = ".pkg.tar.xz" ]; then
plain "--------------------------------------------------------------------"
warning "This PKGBUILD may need up to 20 minutes when XZ compressor is used!"
warning " - The packaging of intel-mkl and intel-ipp is particularly slow"
- warning " - Change PKGEXT in PKGBUILD to use a faster compressor,"
- warning " e.g. .pkg.tar.lzo"
+ warning " - Change PKGEXT in PKGBUILD or define FORCE_PKGEXT on the"
+ warning " command line to use a faster compressor, e.g. .pkg.tar.lzo"
plain "--------------------------------------------------------------------"
fi