summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Stukalov2019-04-28 17:29:16 +0200
committerAlexey Stukalov2019-07-14 12:27:40 +0200
commitc20c3bcc12860d2a2c7ad4e2d84294b059138d8b (patch)
tree9233c615eba8e59a3d3b306a133ee88100efa60f
parentde7a3e1e6591aab86134ccb11b0115f8383ec8f7 (diff)
downloadaur-c20c3bcc12860d2a2c7ad4e2d84294b059138d8b.tar.gz
remove documentation more aggressively
remove documentation_$year folder from the packages
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 63d6fcf3e106..642eea265567 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -389,19 +389,19 @@ package_intel-compiler-base() {
chmod a+x loopprofileviewer.sh
rm loopprofileviewer.csh
+ msg2 "Copying man pages"
+ mv ${xe_build_dir}/opt/intel/documentation_${_year}/en/man/common/man1/*.1 ${_man_dir}
+ gzip ${_man_dir}/*.1
+
cd ${xe_build_dir}/opt/intel/${_composer_xe_dir}/linux
if $_remove_docs ; then
msg2 "Removing documentation"
rm -rf ./documentation
rm -rf ./Documentation
rm -rf ./Samples
+ rm -rf ${xe_build_dir}/opt/intel/documentation_${_year}
fi
- msg2 "Copying man pages"
- mv ${xe_build_dir}/opt/intel/documentation_${_year}/en/man/common/man1/*.1 ${_man_dir}
-
- gzip ${_man_dir}/*.1
-
msg2 "Moving package files"
mv ${xe_build_dir}/opt ${pkgdir}/
mv ${xe_build_dir}/etc ${pkgdir}/
@@ -443,6 +443,10 @@ package_intel-fortran-compiler() {
#Remove duplicate logo and .css found in intel base
rm ${xe_build_dir}/opt/intel/documentation_${_year}/en/compiler_f/ps${_year}/resources/{intel_gsp_styles.css,intel_logo.png}
+ msg2 "Copying man pages"
+ mv ${xe_build_dir}/opt/intel/documentation_${_year}/en/man/common/man1/*.1 ${_man_dir}
+ gzip ${_man_dir}/*.1
+
cd ${xe_build_dir}/opt/intel/${_composer_xe_dir}/linux
if $_remove_docs ; then
msg2 "Removing documentation"
@@ -451,11 +455,6 @@ package_intel-fortran-compiler() {
rm -rf ./Samples
fi
- msg2 "Copying man pages"
- mv ${xe_build_dir}/opt/intel/documentation_${_year}/en/man/common/man1/*.1 ${_man_dir}
-
- gzip ${_man_dir}/*.1
-
# Remove duplicate headers found in intel base
rm ./compiler/include/omp_lib.f90
rm ./compiler/include/intel64/omp_lib.mod
@@ -549,6 +548,7 @@ package_intel-mkl() {
msg2 "Removing documentation"
rm -rf ./examples
rm -rf ./benchmarks
+ rm -rf $xe_build_dir/opt/intel/documentation_${_year}
fi
if ${_remove_static_objects_mkl} ; then
@@ -596,6 +596,11 @@ package_intel-mpi() {
rm -rf ${xe_build_dir}/opt/intel/${_composer_xe_dir}/linux/mpi_2019
rm -rf ${xe_build_dir}/opt/intel/${_composer_xe_dir}/licensing/mpi_2019
+ if $_remove_docs ; then
+ msg2 "Removing documentation"
+ rm -rf ${xe_build_dir}/opt/intel/documentation_${_year}
+ fi
+
msg2 "Moving package files"
mv ${xe_build_dir}/opt ${pkgdir}
mv ${xe_build_dir}/etc ${pkgdir}