summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-11-27 16:17:56 +0000
committerDaniel Bermond2018-11-27 16:17:56 +0000
commit0f32c133817ec29a3f5d7fb33a2160fee1386c9a (patch)
tree7d0c7967fc0da95dfb94a9391dbedc79c6fb8737
parent000cb95f1e0654dfbefc74bcb3f0cd455f6d1b02 (diff)
downloadaur-intel-seapi.tar.gz
Change python version assignment method
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a71750a839c..19848465ee72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = intel-seapi
pkgdesc = Intel Single Event API (Intel SEAPI)
pkgver = 17.01.28
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/intel/IntelSEAPI/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 7b8c56d1bcfc..58cf39403c43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_srcname=IntelSEAPI
pkgname=intel-seapi
pkgver=17.01.28
-pkgrel=5
+pkgrel=6
pkgdesc='Intel Single Event API (Intel SEAPI)'
arch=('i686' 'x86_64')
url='https://github.com/intel/IntelSEAPI/'
@@ -35,15 +35,14 @@ build() {
package() {
cd "${_srcname}-${pkgver}/build_linux/${_architecture}"
- local _pythonver
-
make DESTDIR="$pkgdir" install
# library
mv "${pkgdir}/usr/bin/libIntelSEAPI${_architecture}.so" "${pkgdir}/usr/lib"
# python
- _pythonver="$(python --version | sed 's/^Python[[:space:]]//' | grep -o '^[0-9]*\.[0-9]*')"
+ local _pythonver
+ _pythonver="$(python -c 'import sys; print("%s.%s" % sys.version_info[:2])')"
mkdir -p "${pkgdir}/usr/lib/python${_pythonver}/${pkgname}"
mv "$pkgdir"/usr/runtool/* "${pkgdir}/usr/lib/python${_pythonver}/${pkgname}"