summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancisco Lopes2021-05-10 16:22:04 -0300
committerFrancisco Lopes2021-05-10 16:22:04 -0300
commitddab5269d4994299ba3080e004ebc11ab745adca (patch)
tree1248b275d0e94cf7bb4f282ac5f255b02e5cc05a
parentb28852132974c824ca2df7395ab22dc72f7c64cb (diff)
downloadaur-interception-hideaway.tar.gz
Fix due to change in GitLab asset's urls
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd1c04614b4a..feff52c7c98f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = interception-hideaway
pkgdesc = hideaway: a Interception Tools plugin to hide your mouse pointer
pkgver = 0.1.0
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/interception/linux/plugins/hideaway
arch = x86_64
license = MIT
makedepends = cmake
makedepends = gcc
depends = interception-tools
- source = interception-hideaway.tar.gz::https://gitlab.com/interception/linux/plugins/hideaway/repository/archive.tar.gz?ref=v0.1.0
- md5sums = 48ef1c714f6239fac5af2a7d30f38f56
+ source = https://gitlab.com/interception/linux/plugins/hideaway/-/archive/v0.1.0/hideaway-v0.1.0.tar.gz
+ sha256sums = 9d5b53e30522e2e046665e5fd9ffd72162d93512932cd2ac7f16d19cd5d46163
pkgname = interception-hideaway
diff --git a/PKGBUILD b/PKGBUILD
index 7e5a63b0264f..b06175db9418 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,24 @@
-# Maintainer: Francisco Lopes <francisco@oblita.com>
+# Maintainer: Francisco Lopes <francisco+interception@nosubstance.me>
pkgname=interception-hideaway
pkgver=0.1.0
-pkgrel=2
+pkgrel=3
pkgdesc='hideaway: a Interception Tools plugin to hide your mouse pointer'
arch=('x86_64')
license=('MIT')
url='https://gitlab.com/interception/linux/plugins/hideaway'
depends=('interception-tools')
makedepends=('cmake' 'gcc')
-source=("$pkgname.tar.gz::https://gitlab.com/interception/linux/plugins/hideaway/repository/archive.tar.gz?ref=v${pkgver}")
-md5sums=('48ef1c714f6239fac5af2a7d30f38f56')
+source=("https://gitlab.com/interception/linux/plugins/hideaway/-/archive/v${pkgver}/hideaway-v${pkgver}.tar.gz")
+sha256sums=('9d5b53e30522e2e046665e5fd9ffd72162d93512932cd2ac7f16d19cd5d46163')
build() {
- cd ${srcdir}/hideaway-v${pkgver}-*
+ cd ${srcdir}/hideaway-v${pkgver}
cmake -Bbuild -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release
cmake --build build
}
package() {
- cd ${srcdir}/hideaway-v${pkgver}-*/build
+ cd ${srcdir}/hideaway-v${pkgver}/build
make DESTDIR="$pkgdir/" install
}