summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleksey Filippov2016-06-05 03:57:36 +0400
committerAleksey Filippov2016-06-05 03:57:36 +0400
commitd41860e7d4a51275a5a3b67a22c97ccb5c6430ec (patch)
tree5efd487821a87a0e98c7c162cf9bb6aa0cf7a786
downloadaur-ip-wait-online.tar.gz
Added initial package.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..386f59833707
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jun 4 23:57:32 UTC 2016
+pkgbase = ip-wait-online
+ pkgdesc = Wait for interface to be online using iproute2 check
+ pkgver = 3.dfb656f
+ pkgrel = 1
+ url = https://github.com/sarum9in/ip-wait-online
+ arch = x86_64
+ arch = i686
+ license = GPL
+ makedepends = go
+ options = !strip
+ options = !emptydirs
+ source = git+https://github.com/sarum9in/ip-wait-online.git
+ sha256sums = SKIP
+
+pkgname = ip-wait-online
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee9f49b8a2ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Aleksey Filippov <sarum9in@gmail.com>
+
+pkgname=ip-wait-online
+pkgver=3.dfb656f
+pkgrel=1
+pkgdesc="Wait for interface to be online using iproute2 check"
+arch=('x86_64' 'i686')
+url="https://github.com/sarum9in/ip-wait-online"
+license=('GPL')
+makedepends=('go')
+options=('!strip' '!emptydirs')
+source=("git+https://github.com/sarum9in/ip-wait-online.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ cd "$pkgname"
+
+ go build
+}
+
+package() {
+ cd "$pkgname"
+
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "ip-wait-online@.service" "$pkgdir/usr/lib/systemd/system/ip-wait-online@.service"
+ #install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: