summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Henrie2019-10-21 10:45:12 -0600
committerAlex Henrie2019-10-21 10:45:12 -0600
commit8aaf33c844196602e147783660b30f76f4c0d61d (patch)
tree4a023f558f83f453321ae74e3b2c334e32dd4104
parent1e317698bc817ab6c728ae6dab7db0f9a78b553e (diff)
downloadaur-8aaf33c844196602e147783660b30f76f4c0d61d.tar.gz
Update to 0.9.6
Much less effort is required to package this release.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 465d9d8e2d8a..385f6fae97ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ipfs-desktop
pkgdesc = Desktop client for the InterPlanetary File System
- pkgver = 0.9.5
- pkgrel = 3
+ pkgver = 0.9.6
+ pkgrel = 1
url = https://github.com/ipfs-shipyard/ipfs-desktop
install = ipfs-desktop.install
arch = x86_64
@@ -24,8 +24,8 @@ pkgbase = ipfs-desktop
depends = libnotify
depends = libappindicator-gtk3
depends = libappindicator-sharp
- source = https://github.com/ipfs-shipyard/ipfs-desktop/archive/v0.9.5.tar.gz
- sha256sums = 1c0e1ea67e22228c46f1738665e21339aa4c105109773107817913234b7291a2
+ source = https://github.com/ipfs-shipyard/ipfs-desktop/archive/v0.9.6.tar.gz
+ sha256sums = adcf6a1ba67ee2d05121c0481ff897745774fc41ffbbf629be2099e970c58f01
pkgname = ipfs-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 250948dafddd..d717ce5fd16a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Henrie <alexhenrie24@gmail.com>
pkgname=ipfs-desktop
-pkgver=0.9.5
-pkgrel=3
+pkgver=0.9.6
+pkgrel=1
pkgdesc="Desktop client for the InterPlanetary File System"
arch=(x86_64)
url="https://github.com/ipfs-shipyard/$pkgname"
@@ -10,20 +10,17 @@ depends=(c-ares ffmpeg gtk3 http-parser libevent libvpx libxslt libxss minizip n
makedepends=(nodejs npm node-gyp)
install=$pkgname.install
source=("https://github.com/ipfs-shipyard/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=(1c0e1ea67e22228c46f1738665e21339aa4c105109773107817913234b7291a2)
+sha256sums=(adcf6a1ba67ee2d05121c0481ff897745774fc41ffbbf629be2099e970c58f01)
prepare() {
cd "$pkgname-$pkgver"
- # For the "Launch on startup" feature to work, the program must be installed
- # to a path that does not contain spaces
- sed -i 's/"productName": "IPFS Desktop"/"productName": "IPFS-Desktop"/' package.json
}
build() {
cd "$pkgname-$pkgver"
npm install
npm run-script build:babel
- npx electron-builder build --linux pacman -c.linux.icon=ipfs-desktop -c.linux.category='Network;FileTransfer;P2P' -c.linux.desktop.Name='IPFS Desktop'
+ npx electron-builder build --linux pacman
}
package() {
@@ -32,6 +29,6 @@ package() {
mv "$pkgdir/.INSTALL" "../$pkgname.install"
rm "$pkgdir/.MTREE" "$pkgdir/.PKGINFO"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- mv "$pkgdir/opt/IPFS-Desktop/LICENSE.electron.txt" "$pkgdir/usr/share/licenses/$pkgname"
- mv "$pkgdir/opt/IPFS-Desktop/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname"
+ mv "$pkgdir/opt/IPFS Desktop/LICENSE.electron.txt" "$pkgdir/usr/share/licenses/$pkgname"
+ mv "$pkgdir/opt/IPFS Desktop/LICENSES.chromium.html" "$pkgdir/usr/share/licenses/$pkgname"
}