summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author@RubenKelevra2022-02-04 21:03:18 +0100
committer@RubenKelevra2022-02-04 21:03:18 +0100
commitc78e9755e927f28ee4ab49014f0655942a97915f (patch)
tree8f91b1d29c38c09143451fffcb02f6c9251aa476
parent77f606fd89da972210dbc09c429c799859063d05 (diff)
downloadaur-c78e9755e927f28ee4ab49014f0655942a97915f.tar.gz
apply patch from @lidel to fix potential build issues
version will not be advanced, as this is only fixing issues on first installation
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8e91eca207c..adb955891e2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,9 +13,13 @@ install=$pkgname.install
source=("https://github.com/ipfs/ipfs-desktop/archive/refs/tags/v$pkgver.tar.gz")
b2sums=('d23f2c574d7d3fbe9ff4fda1836efc2b2023721cf9e2182cce9b7ce99da14a43abf1fab26b5b1e70e4377daba5e7bfaf1012c08ca6af81d2f5ff126081a47f4d')
+prepare() {
+ cd "$pkgname-$pkgver"
+ npm ci --no-audit --progress=false --cache "$srcdir/npm-cache"
+}
+
build() {
cd "$pkgname-$pkgver"
- npm install --cache "$srcdir/npm-cache"
npm run-script build
npx electron-builder build --linux pacman
}