summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2020-02-29 22:29:46 -0500
committerredfish2020-02-29 22:29:46 -0500
commit50e8d334f3ca42b795a2c501c7f5443bfd33548f (patch)
tree5e9533e73c8a19e7155733163c8b338f68c7ad1f
parentac9dc306f28c19fd0a397bca250615a9ed27fd2f (diff)
downloadaur-50e8d334f3ca42b795a2c501c7f5443bfd33548f.tar.gz
0.5.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD72
-rw-r--r--ipget_aur.patch21
3 files changed, 15 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 625e57c06462..9fd8b860eb69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ipget
pkgdesc = wget for IPFS: retrieve files over IPFS and save them locally.
- pkgver = 0.3.1
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/ipfs/ipget
arch = x86_64
@@ -11,22 +11,8 @@ pkgbase = ipget
makedepends = git
optdepends = go-ipfs: to use full potential of IPFS network
optdepends = go-pie: PIE enabled compilation (makedepend)
- source = https://github.com/ipfs/ipget/archive/v0.3.1.tar.gz
- source = ipget_aur.patch
- source = go-floodsub.tar.gz::https://github.com/libp2p/go-floodsub/archive/4e84ab6c81c4093552130a69fecfc5afe7c8dbf3.tar.gz
- source = go-libp2p-peer.tar.gz::https://github.com/libp2p/go-libp2p-peer/archive/aa0e03e559bde9d4749ad8e38595e15a6fe808fa.tar.gz
- source = go-multiaddr.tar.gz::https://github.com/multiformats/go-multiaddr/archive/123a717755e0559ec8fda308019cd24e0a37bb07.tar.gz
- source = go-multiaddr-net.tar.gz::https://github.com/multiformats/go-multiaddr-net/archive/97d80565f68c5df715e6ba59c2f6a03d1fc33aaf.tar.gz
- source = go-multipart-files.tar.gz::https://github.com/whyrusleeping/go-multipart-files/archive/3be93d9f6b618f2b8564bfb1d22f1e744eabbae2.tar.gz
- source = tar-utils.tar.gz::https://github.com/whyrusleeping/tar-utils/archive/8c6c8ba81d5c71fd69c0f48dbde4b2fb422b6dfc.tar.gz
- sha256sums = 0c557abbeadc713fb13892fed498696ec72a6bc9d067beecc80e07c13a0999e4
- sha256sums = dc7e1b74f786d1d13461635cc269a1a00acd13dbb530b07823ed82bd31bd8bd8
- sha256sums = 55766c39cbf9f41e1288df82e25919efe3bdcec236182f9fe28209ae8f1b960c
- sha256sums = 116f5f6a0e3e5694c862bfa7b3f500e22839ca043bb6622e5d202e36905c88e1
- sha256sums = dc7821f8b749e46f8bb8c08faf36e7079866ad7d0f9de711ed3dab5ad38118f4
- sha256sums = 6f4f5989fac82b8bf25a0a5efa6dc36fba7904c8746fb8679205a8f0c73dbb7e
- sha256sums = a702f4481aab593650dd5fb4dd11709c7bc536fb57f392925ed22a154ebd5b10
- sha256sums = 07373f1fa402af88ee1bcc461694a9fc96f29bd0619d54410f32e5fb783a6ff4
+ source = https://github.com/ipfs/ipget/archive/v0.5.0.tar.gz
+ sha256sums = a2a5ec2f78cfc1ce739821c6493bffe0f4adac4d283a3cb55391a4c74a5ca41a
pkgname = ipget
diff --git a/PKGBUILD b/PKGBUILD
index 881c9ddf7292..a7efbc285a21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: Gergely Imreh <imrehg@gmailcom>
+# Maintainer: redfish <redfish@galactica.pw>
+# Contributor: Gergely Imreh <imrehg@gmailcom>
# Contributor: Jakub "Kubuxu" Sztandera <kubuxu@protonmail.ch>
# vim: set expandtab ts=2 sw=2:
pkgname=ipget
-pkgver=0.3.1
+pkgver=0.5.0
pkgrel=1
pkgdesc="wget for IPFS: retrieve files over IPFS and save them locally."
arch=('x86_64')
@@ -12,78 +13,29 @@ license=('MIT')
makedepends=('go' 'gx' 'gx-go' 'git')
optdepends=('go-ipfs: to use full potential of IPFS network'
'go-pie: PIE enabled compilation (makedepend)')
-# The versions of preloaded dependencies to install a fixed version
-# while ipget is not able to pull them itself
-_ver_go_floodsub="4e84ab6c81c4093552130a69fecfc5afe7c8dbf3"
-_ver_go_libp2p_peer="aa0e03e559bde9d4749ad8e38595e15a6fe808fa"
-_ver_go_multiaddr="123a717755e0559ec8fda308019cd24e0a37bb07"
-_ver_go_multiaddr_net="97d80565f68c5df715e6ba59c2f6a03d1fc33aaf"
-_ver_go_multipart_files="3be93d9f6b618f2b8564bfb1d22f1e744eabbae2"
-_ver_tar_utils="8c6c8ba81d5c71fd69c0f48dbde4b2fb422b6dfc"
-source=("https://github.com/ipfs/ipget/archive/v${pkgver}.tar.gz"
- "ipget_aur.patch"
- "go-floodsub.tar.gz::https://github.com/libp2p/go-floodsub/archive/${_ver_go_floodsub}.tar.gz"
- "go-libp2p-peer.tar.gz::https://github.com/libp2p/go-libp2p-peer/archive/${_ver_go_libp2p_peer}.tar.gz"
- "go-multiaddr.tar.gz::https://github.com/multiformats/go-multiaddr/archive/${_ver_go_multiaddr}.tar.gz"
- "go-multiaddr-net.tar.gz::https://github.com/multiformats/go-multiaddr-net/archive/${_ver_go_multiaddr_net}.tar.gz"
- "go-multipart-files.tar.gz::https://github.com/whyrusleeping/go-multipart-files/archive/${_ver_go_multipart_files}.tar.gz"
- "tar-utils.tar.gz::https://github.com/whyrusleeping/tar-utils/archive/${_ver_tar_utils}.tar.gz")
-sha256sums=('0c557abbeadc713fb13892fed498696ec72a6bc9d067beecc80e07c13a0999e4'
- 'dc7e1b74f786d1d13461635cc269a1a00acd13dbb530b07823ed82bd31bd8bd8'
- '55766c39cbf9f41e1288df82e25919efe3bdcec236182f9fe28209ae8f1b960c'
- '116f5f6a0e3e5694c862bfa7b3f500e22839ca043bb6622e5d202e36905c88e1'
- 'dc7821f8b749e46f8bb8c08faf36e7079866ad7d0f9de711ed3dab5ad38118f4'
- '6f4f5989fac82b8bf25a0a5efa6dc36fba7904c8746fb8679205a8f0c73dbb7e'
- 'a702f4481aab593650dd5fb4dd11709c7bc536fb57f392925ed22a154ebd5b10'
- '07373f1fa402af88ee1bcc461694a9fc96f29bd0619d54410f32e5fb783a6ff4')
+source=("https://github.com/ipfs/ipget/archive/v${pkgver}.tar.gz")
prepare() {
export GOPATH="${srcdir}"
- # Patching
- #(cd "ipget-${pkgver}" ; patch -N < ../ipget_aur.patch)
-
# Link the source to the right place for go
mkdir -p "${srcdir}/src/github.com/ipfs/"
if [ ! -e "${srcdir}/src/github.com/ipfs/ipget" ]; then
ln -s "${srcdir}/ipget-${pkgver}" "${srcdir}/src/github.com/ipfs/ipget"
fi
-
- msg "Getting dependencies"
- # Workaround for missing dependencies that block build in v0.3.0
- mkdir -p "src/github.com/libp2p"
- echo "> libp2p/go-floodsub"
- ln -sf "${srcdir}/go-libp2p-pubsub-${_ver_go_floodsub}" "src/github.com/libp2p/go-floodsub"
- ln -sf "${srcdir}/go-floodsub-${_ver_go_floodsub}" "src/github.com/libp2p/go-floodsub"
- (cd src/github.com/libp2p/go-floodsub ; go get)
- echo "> libp2p/go-libp2p-peer"
- ln -sf "${srcdir}/go-libp2p-peer-${_ver_go_libp2p_peer}" "src/github.com/libp2p/go-libp2p-peer"
- (cd src/github.com/libp2p/go-libp2p-peer ; go get)
- mkdir -p "src/github.com/multiformats"
- echo "> multiformats/go-multiaddr"
- ln -sf "${srcdir}/go-multiaddr-${_ver_go_multiaddr}" "src/github.com/multiformats/go-multiaddr"
- (cd src/github.com/multiformats/go-multiaddr ; go get)
- echo "> multiformats/go-multiaddr-net"
- ln -sf "${srcdir}/go-multiaddr-net-${_ver_go_multiaddr_net}" "src/github.com/multiformats/go-multiaddr-net"
- (cd src/github.com/multiformats/go-multiaddr-net ; go get)
- mkdir -p "src/github.com/whyrusleeping"
- echo "> whyrusleeping/go-multipart-files"
- ln -sf "${srcdir}/go-multipart-files-${_ver_go_multipart_files}" "src/github.com/whyrusleeping/go-multipart-files"
- (cd src/github.com/whyrusleeping/go-multipart-files; go get)
- echo "> whyrusleeping/tar-utils"
- ln -sf "${srcdir}/tar-utils-${_ver_tar_utils}" "src/github.com/whyrusleeping/tar-utils"
- (cd src/github.com/whyrusleeping/tar-utils ; go get)
-
- # Getting all the other dependencies, that the code knows about anyways
- cd "${srcdir}/src/github.com/ipfs/ipget"
- gx --verbose install --global
}
build() {
- cd "${srcdir}/src/github.com/ipfs/ipget" || exit
+ cd "${srcdir}/src/github.com/ipfs/ipget"
go build
+
+ # For some reason file creation mode in Go lacks write permission,
+ # which breaks package re-builds (even with -C)
+ chmod -R o+w "${srcdir}"
}
package() {
- install -D "${srcdir}/ipget-${pkgver}/ipget" "${pkgdir}/usr/bin/ipget"
+ install -D "${srcdir}/${pkgname}-${pkgver}/ipget" "${pkgdir}/usr/bin/ipget"
}
+
+sha256sums=('a2a5ec2f78cfc1ce739821c6493bffe0f4adac4d283a3cb55391a4c74a5ca41a')
diff --git a/ipget_aur.patch b/ipget_aur.patch
deleted file mode 100644
index 286b9629e58a..000000000000
--- a/ipget_aur.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- package.json.old 2018-05-31 11:52:57.430372431 +0100
-+++ package.json 2018-05-31 11:53:06.873322906 +0100
-@@ -16,6 +16,6 @@
- "language": "go",
- "license": "",
- "name": "ipget",
-- "version": "0.2.4"
-+ "version": "0.3.0"
- }
-
---- main.go.old 2018-05-31 11:53:44.025189769 +0100
-+++ main.go 2018-05-31 11:53:58.917952385 +0100
-@@ -16,7 +16,7 @@
- app := cli.NewApp()
- app.Name = "ipget"
- app.Usage = "Retrieve and save IPFS objects."
-- app.Version = "0.2.0"
-+ app.Version = "0.3.0"
- app.Flags = []cli.Flag{
- cli.StringFlag{
- Name: "output,o",