summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBarfin2020-10-07 16:14:53 +0330
committerBarfin2020-10-07 16:14:53 +0330
commit42fa1ac15868bcf3e1da580ee999a75c19d62bf7 (patch)
treee806e9d3a421f4fc7507b35ed9e631e3dd10fe31
parenta5f526f15be3c8f21f7655275cd6f64cc9db128f (diff)
downloadaur-ipwebcam.tar.gz
upstream update
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
2 files changed, 17 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d68cc52dc10..e17f5fab7d4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = ipwebcam
pkgdesc = Simple shell script for using IP Webcam as a V4L2 webcam / sound source
- pkgver = 20200624
- pkgrel = 3
+ pkgver = 20200820
+ pkgrel = 1
url = https://github.com/bluezio/ipwebcam-gst
arch = any
license = unknown
depends = v4l2loopback-dkms
depends = adb
- source = https://raw.githubusercontent.com/bluezio/ipwebcam-gst/master/prepare-videochat.sh
- md5sums = 5efb2cdde2e336641e188c197534c375
+ source = https://raw.githubusercontent.com/bluezio/ipwebcam-gst/master/install-videochat.sh
+ source = https://raw.githubusercontent.com/bluezio/ipwebcam-gst/master/run-videochat.sh
+ md5sums = 1fe3690f1648688fb2d03a657f1f5e11
+ md5sums = 01f1efec6fc268d4a757a349005007cc
pkgname = ipwebcam
diff --git a/PKGBUILD b/PKGBUILD
index a983788f11c2..dbcdf400dc07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,21 @@
# Maintainer: barfin
pkgname=ipwebcam
-pkgver=20200624
-pkgrel=3
-pkgdesc="Simple shell script for using IP Webcam as a V4L2 webcam / sound source "
+pkgver=20200820
+pkgrel=1
+pkgdesc="Simple shell script for using IP Webcam as a V4L2 webcam / sound source"
arch=("any")
url="https://github.com/bluezio/ipwebcam-gst"
license=('unknown')
depends=("v4l2loopback-dkms" "adb")
-source=("https://raw.githubusercontent.com/bluezio/ipwebcam-gst/master/prepare-videochat.sh")
-md5sums=('5efb2cdde2e336641e188c197534c375')
+source=("https://raw.githubusercontent.com/bluezio/ipwebcam-gst/master/install-videochat.sh"
+ "https://raw.githubusercontent.com/bluezio/ipwebcam-gst/master/run-videochat.sh")
+md5sums=('1fe3690f1648688fb2d03a657f1f5e11'
+ '01f1efec6fc268d4a757a349005007cc')
package() {
- install -Dm755 "${srcdir}/prepare-videochat.sh" "${pkgdir}/opt/ipwebcam/ipwebcam"
+ install -Dm755 "${srcdir}/install-videochat.sh" "${pkgdir}/opt/ipwebcam/install-ipwebcam"
+ install -Dm755 "${srcdir}/run-videochat.sh" "${pkgdir}/opt/ipwebcam/run-ipwebcam"
mkdir -p "${pkgdir}/usr/bin/"
- ln -s "/opt/ipwebcam/ipwebcam" "${pkgdir}/usr/bin/ipwebcam"
-
+ ln -s "/opt/ipwebcam/install-ipwebcam" "${pkgdir}/usr/bin/install-ipwebcam"
+ ln -s "/opt/ipwebcam/run-ipwebcam" "${pkgdir}/usr/bin/run-ipwebcam"
}