summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter Hofmann2012-10-06 13:26:01 +0200
committerPeter Hofmann2012-10-06 13:30:31 +0200
commit4f965bad5568394a6c24b05c7f3482bf4236aee8 (patch)
treefc917aff914ec7cf27a18d197e0aafe10031c72c
parent0e579e87fed6852bfc28082f042718e9a2535e14 (diff)
downloadaur-4f965bad5568394a6c24b05c7f3482bf4236aee8.tar.gz
iscan-plugin-gt-s600: Fixed namcap complaints.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd9cae0597cc..8d2eff463c36 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,7 @@ pkgbase = iscan-plugin-gt-s600
install = gt-s600.install
arch = i686
arch = x86_64
- license = GPL
- license = LGPL
- license = EAPL
+ license = custom:AVASYS
makedepends = rpmextract
depends = iscan
source = http://linux.avasys.jp/drivers/iscan-plugins/iscan-plugin-gt-s600/2.1.2/iscan-plugin-gt-s600-2.1.2-1.i386.rpm
diff --git a/PKGBUILD b/PKGBUILD
index 955e8e721e3f..bc6049c86fe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
-# Contributor: Vain
+# Maintainer: Vain <aurmaint1 on host: uninformativ dot de>
# Based on PKGBUILD for iscan-plugin-gt-x770.
if [ "$CARCH" = "x86_64" ]
then
- march="x86_64"
+ _arch=$CARCH
md5sums=('9e36fd80b1f8ffa3f658b6a025d5e186')
else
- march="i386"
+ _arch=i386
md5sums=('0a3a83dbbb2630c5e9453cc78983ab81')
fi
@@ -16,19 +16,23 @@ pkgrel=2
pkgdesc="iscan plugin for Epson Perfection V10."
arch=('i686' 'x86_64')
url="http://www.avasys.jp/lx-bin2/linux_e/spc/DL2.do"
-license=('GPL' 'LGPL' 'EAPL')
+license=('custom:AVASYS')
depends=('iscan')
makedepends=('rpmextract')
install=gt-s600.install
-source=(http://linux.avasys.jp/drivers/iscan-plugins/$pkgname/${pkgver%_*}/$pkgname-${pkgver//_/-}.$march.rpm)
+source=(http://linux.avasys.jp/drivers/iscan-plugins/$pkgname/${pkgver%_*}/$pkgname-${pkgver//_/-}.$_arch.rpm)
build() {
- cd "$startdir"
- rpmextract.sh "$pkgname-${pkgver//_/-}.$march.rpm"
+ cd "$srcdir"
+ rpmextract.sh "$pkgname-${pkgver//_/-}.$_arch.rpm"
mv usr "$pkgdir"
if [ "$CARCH" = "x86_64" ]
then
mv "$pkgdir"/usr/lib{64,}
fi
+
+ install -m 644 -D \
+ "$pkgdir"/usr/share/doc/iscan-plugin-gt-s600-2.1.2/AVASYSPL.en.txt \
+ "$pkgdir"/usr/share/licenses/"$pkgname"/COPYING
}