summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorŁukasz Mariański2023-08-08 12:18:52 +0200
committerŁukasz Mariański2023-08-08 12:19:21 +0200
commit32c31ba6e869babfb19078501fd8f50263955bfe (patch)
treea997be23095f43d3b790f29a9c60fb3867ff0230
parent22dc7a481c24bc7a61fee4605cff7e3de9299a07 (diff)
downloadaur-itch-bin.tar.gz
Update
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
-rw-r--r--itch.patch60
-rw-r--r--itch.sh2
4 files changed, 27 insertions, 95 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 010e845dc6d4..7f34f3db07c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = itch-bin
pkgdesc = The best way to play your itch.io games
- pkgver = 25.5.1
- pkgrel = 5
+ pkgver = 26.0.2
+ pkgrel = 1
url = https://github.com/itchio/itch
install = itch.install
arch = any
license = MIT
- makedepends = unzip
- depends = electron11-bin
+ depends = electron22
depends = libnotify
depends = nss
depends = libxss
@@ -15,17 +14,14 @@ pkgbase = itch-bin
optdepends = firejail: Application sandbox
provides = itch
conflicts = itch
- noextract = itch-25.5.1.zip
- noextract = itch-25.5.1-src.tar.gz
- source = itch-25.5.1.zip::https://broth.itch.ovh/itch/linux-amd64/25.5.1/archive/default
- source = itch-25.5.1-src.tar.gz::https://github.com/itchio/itch/archive/v25.5.1.tar.gz
+ noextract = itch-26.0.2-src.tar.gz
+ source = itch-26.0.2.zip::https://broth.itch.ovh/kitch/linux-amd64/26.0.2/archive/default
+ source = itch-26.0.2-src.tar.gz::https://github.com/itchio/itch/archive/refs/tags/v26.0.2-canary.tar.gz
source = itch.sh
source = io.itch.itch.desktop
- source = itch.patch
- sha256sums = fdd916c79beb90c19c7ee404e11398e5f2f5c7c402ae68910b4f70e6918071ed
- sha256sums = 0a7094bff90992e3788fd9f9df43a4a3c9233bfcf0f5da037e59af6b365a3249
- sha256sums = bcea2b621731bca9e7b5f3bd1fd5af5aabaaf51803b6d32e89fbb28609d36b7e
+ sha256sums = 04ab534f42e21892d3e978e9ad1ab704a8b00d41a82205aed6ad31e492fe422f
+ sha256sums = aaf25e5400a77be2034fe4409d4cc76be6ab36dce7cd9ad9814e1c0eb779daf6
+ sha256sums = c02249d9d15f57e74aef6f2e1fd26837a6f5950af4a63fb5810c759880bfa58e
sha256sums = 9c5a5fcbd03e6d2e5dd15b39f4c1f93a57ab341ef947d287acef47386044ecd1
- sha256sums = 8262cbfc13289dd49f944466d33f83b860cfe7a2610d78b2c44c0b51abd30fc4
pkgname = itch-bin
diff --git a/PKGBUILD b/PKGBUILD
index 64481e46c1d6..36cf4e0cbc0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,42 @@
# Maintainer: Łukasz Mariański <lmarianski at protonmail dot com>
+_electron=electron22
pkgname=itch-bin
_pkgname="${pkgname%-bin}"
-pkgver=25.5.1
-pkgrel=5
+_pkgver=26.0.2-canary
+pkgver=26.0.2
+pkgrel=1
pkgdesc="The best way to play your itch.io games"
arch=('any')
url="https://github.com/itchio/itch"
license=('MIT')
-depends=('electron11-bin' 'libnotify' 'nss' 'libxss' 'gtk3')
-makedepends=('unzip')
+depends=("$_electron" 'libnotify' 'nss' 'libxss' 'gtk3')
+#makedepends=('unzip')
optdepends=('firejail: Application sandbox')
provides=($_pkgname)
conflicts=($_pkgname)
install=$_pkgname.install
source=(
- "$_pkgname-$pkgver.zip::https://broth.itch.ovh/$_pkgname/linux-amd64/$pkgver/archive/default"
- "$_pkgname-$pkgver-src.tar.gz::https://github.com/itchio/itch/archive/v$pkgver.tar.gz"
+ "$_pkgname-$pkgver.zip::https://broth.itch.ovh/k$_pkgname/linux-amd64/$pkgver/archive/default"
+ "$_pkgname-$pkgver-src.tar.gz::https://github.com/itchio/itch/archive/refs/tags/v$_pkgver.tar.gz"
"$_pkgname.sh"
"io.itch.$_pkgname.desktop"
- "$_pkgname.patch"
)
-sha256sums=('fdd916c79beb90c19c7ee404e11398e5f2f5c7c402ae68910b4f70e6918071ed'
- '0a7094bff90992e3788fd9f9df43a4a3c9233bfcf0f5da037e59af6b365a3249'
- 'bcea2b621731bca9e7b5f3bd1fd5af5aabaaf51803b6d32e89fbb28609d36b7e'
- '9c5a5fcbd03e6d2e5dd15b39f4c1f93a57ab341ef947d287acef47386044ecd1'
- '8262cbfc13289dd49f944466d33f83b860cfe7a2610d78b2c44c0b51abd30fc4')
-noextract=("$_pkgname-$pkgver.zip" "$_pkgname-$pkgver-src.tar.gz")
+sha256sums=('04ab534f42e21892d3e978e9ad1ab704a8b00d41a82205aed6ad31e492fe422f'
+ 'aaf25e5400a77be2034fe4409d4cc76be6ab36dce7cd9ad9814e1c0eb779daf6'
+ 'c02249d9d15f57e74aef6f2e1fd26837a6f5950af4a63fb5810c759880bfa58e'
+ '9c5a5fcbd03e6d2e5dd15b39f4c1f93a57ab341ef947d287acef47386044ecd1')
+noextract=("$_pkgname-$pkgver-src.tar.gz")
prepare() {
- unzip -o -qq "$_pkgname-$pkgver.zip" -d "$_pkgname-$pkgver"
+# unzip -o -qq "$_pkgname-$pkgver.zip" -d "$_pkgname-$pkgver"
mkdir -p "$srcdir/icons/"
- tar --wildcards -zxf "$_pkgname-$pkgver-src.tar.gz" "$_pkgname-$pkgver/release/images/itch-icons/icon*.png"
-
- cd "$_pkgname-$pkgver"
-
- patch -p1 -i "$srcdir/$_pkgname.patch"
+ tar --wildcards -zxf "$_pkgname-$pkgver-src.tar.gz" "$_pkgname-$_pkgver/release/images/itch-icons/icon*.png"
}
package() {
- cd "$_pkgname-$pkgver"
+ cd "$srcdir"
install -d "$pkgdir/usr/share/$_pkgname/"
cp -r resources/app/** "$pkgdir/usr/share/$_pkgname/"
@@ -51,7 +47,7 @@ package() {
install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
install -Dm644 LICENSES.chromium.html -t "$pkgdir/usr/share/licenses/$pkgname/"
- for icon in release/images/itch-icons/icon*.png
+ for icon in "$srcdir/$_pkgname-$_pkgver/release/images/itch-icons/icon"*.png
do
iconsize="${icon#release/images/itch-icons/icon}"
iconsize="${iconsize%.png}"
diff --git a/itch.patch b/itch.patch
deleted file mode 100644
index 9d5d986323d1..000000000000
--- a/itch.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- a/resources/app/dist/main/main.bundle.js 2022-03-07 18:24:14.543518719 -0500
-+++ b/resources/app/dist/main/main.bundle.js 2022-03-07 18:36:09.803727617 -0500
-@@ -37530,7 +37530,7 @@
- return;
- }
- withWebContents(store, wind, tab, async (wc) => {
-- const webUrl = wc.history[wc.currentIndex];
-+ const webUrl = "";
- if (webUrl !== url) {
- logger.debug(`WebContents has\n--> ${webUrl}\ntab evolved to\n--> ${url}\nlet's load`);
- loadURL(wc, url);
-@@ -37622,12 +37622,12 @@
- }));
- };
- let printWebContentsHistory = (previousIndex) => {
-- if (wc.history.length === 0) {
-+ if (0 === 0) {
- logger.debug(`(The webcontents history are empty for some reason)`);
- }
- else {
- logger.debug("WebContents history:");
-- for (let i = 0; i < wc.history.length; i++) {
-+ for (let i = 0; i < 0; i++) {
- let prevMark = i === previousIndex ? "<" : " ";
- let pendMark = i === wc.pendingIndex ? "P" : " ";
- let currMark = i === wc.currentIndex ? ">" : " ";
-@@ -37654,7 +37654,7 @@
- ) => {
- if (wc.currentIndex < 0) {
- // We get those spurious events after a "clear history & loadURL()"
-- // at this point `wc.history.length` is 0 anyway, so it's not like we
-+ // at this point `0` is 0 anyway, so it's not like we
- // can figure out much. They're followed by a meaningful event shortly after.
- logger.debug(`Ignoring commit with negative currentIndex`);
- return;
-@@ -37662,7 +37662,7 @@
- let { previousIndex, previousHistorySize } = previousState;
- previousState = {
- previousIndex: wc.currentIndex,
-- previousHistorySize: wc.history.length,
-+ previousHistorySize: 0,
- };
- const space = common_helpers_space__WEBPACK_IMPORTED_MODULE_2__[/* Space */ "a"].fromStore(store, wind, tab);
- const stateHistory = space.history();
-@@ -37700,7 +37700,7 @@
- });
- }
- let offset = wc.currentIndex - previousIndex;
-- let sizeOffset = wc.history.length - previousHistorySize;
-+ let sizeOffset = 0 - previousHistorySize;
- if (sizeOffset === 1) {
- logger.debug(`History grew one, offset is ${offset}`);
- if (stateURL === url) {
-@@ -47618,4 +47618,4 @@
-
- /***/ })
- /******/ ]);
--//# sourceMappingURL=main.bundle.js.map
-\ No newline at end of file
-+//# sourceMappingURL=main.bundle.js.map
diff --git a/itch.sh b/itch.sh
index f27246f86763..ee13b1e244d5 100644
--- a/itch.sh
+++ b/itch.sh
@@ -4,4 +4,4 @@ DIR="$HOME/.config/itch/prereqs/firejail-amd64"
mkdir -p "$DIR"
ln -sf /usr/bin/firejail "$DIR/firejail"
-exec electron11 /usr/share/itch "$@" \ No newline at end of file
+exec electron22 /usr/share/itch "$@"