summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiří Klimeš2019-06-14 13:16:44 +0200
committerJiří Klimeš2019-06-14 14:06:52 +0200
commita55fa7a046afcd06c30c19f13493f01e5051f1f1 (patch)
treeed9edc69022e206530e1477a8815034248d35d9a
parentb9eefe9fedce2ed8cdc14e429f56cc54cb6625ca (diff)
downloadaur-a55fa7a046afcd06c30c19f13493f01e5051f1f1.tar.gz
Enable building for Linux kernels 5.x
Adds a temporary patch for tecmake.mak. The patch will be removed when it is fixed upstream.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--tecmake-fix-Linux5-build.patch76
3 files changed, 87 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7e707d15f23..8b037d2ee1ca 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = iup
pkgdesc = C cross platform GUI toolkit
pkgver = 3.26
- pkgrel = 1
+ pkgrel = 2
url = https://www.tecgraf.puc-rio.br/iup/
arch = x86_64
license = MIT
@@ -19,8 +19,10 @@ pkgbase = iup
makedepends = lua52-cd
source = https://downloads.sourceforge.net/project/iup/3.26/Docs%20and%20Sources/iup-3.26_Sources.tar.gz
source = https://downloads.sourceforge.net/project/iup/3.26/Docs%20and%20Sources/iup-3.26_Docs.pdf
+ source = tecmake-fix-Linux5-build.patch
md5sums = 446668073d9a87c57f4e5d682b8663f4
md5sums = 78341ce38463a168a2a14f59c58808f5
+ md5sums = 057b075a25ff818e8f928a85a739398c
pkgname = iup
pkgdesc = C cross platform GUI toolkit
diff --git a/PKGBUILD b/PKGBUILD
index c18afb46afa7..f310082a2882 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgbase=iup
pkgname=('iup' 'lua-iup' 'lua51-iup' 'lua52-iup')
pkgver=3.26
-pkgrel=1
+pkgrel=2
pkgdesc="C cross platform GUI toolkit"
arch=('x86_64')
url="https://www.tecgraf.puc-rio.br/iup/"
@@ -28,10 +28,12 @@ makedepends=('lsb-release'
source=(
"https://downloads.sourceforge.net/project/iup/${pkgver}/Docs%20and%20Sources/iup-${pkgver}_Sources.tar.gz"
"https://downloads.sourceforge.net/project/iup/${pkgver}/Docs%20and%20Sources/iup-${pkgver}_Docs.pdf"
+ "tecmake-fix-Linux5-build.patch"
)
md5sums=('446668073d9a87c57f4e5d682b8663f4'
- '78341ce38463a168a2a14f59c58808f5')
+ '78341ce38463a168a2a14f59c58808f5'
+ '057b075a25ff818e8f928a85a739398c')
prepare() {
# Link iupview statically
@@ -44,6 +46,10 @@ prepare() {
# Add RUN_PATH variable to be able to set DT_RUNPATH
sed 's/$(ECHO)$(LINKER)/& $(RUN_PATH)/' -i "$srcdir"/iup/tecmake.mak
sed 's/$(ECHO)$(LD)/& $(RUN_PATH)/' -i "$srcdir"/iup/tecmake.mak
+
+ # patch for building for kernel 5.x
+ # temporary - until it is fixed in upstream
+ patch -p0 < "$srcdir"/tecmake-fix-Linux5-build.patch
}
_lua_iup_build_helper() {
diff --git a/tecmake-fix-Linux5-build.patch b/tecmake-fix-Linux5-build.patch
new file mode 100644
index 000000000000..d15dd02dd381
--- /dev/null
+++ b/tecmake-fix-Linux5-build.patch
@@ -0,0 +1,76 @@
+--- iup/tecmake.mak 2019-06-14 12:29:33.336492042 +0200
++++ iup/tecmake.mak.new 2019-06-14 12:27:56.818718486 +0200
+@@ -299,12 +299,12 @@
+
+ ifdef GTK_DEFAULT
+ ifndef USE_GTK2
+- ifneq ($(findstring Linux4, $(TEC_UNAME)), )
+- USE_GTK3 = Yes
+- endif
+- ifneq ($(findstring Linux31, $(TEC_UNAME)), )
+- USE_GTK3 = Yes
++ ifneq ($(findstring Linux, $(TEC_UNAME)), )
++ ifeq ($(shell expr $(TEC_SYSVERSION)$(TEC_SYSMINOR) \>= 31), 1)
++ USE_GTK3 = Yes
++ endif
+ endif
++
+ ifneq ($(findstring cygw, $(TEC_UNAME)), )
+ USE_GTK3 = Yes
+ endif
+@@ -1169,15 +1169,16 @@
+ LDIR += $(CD_LIB)
+ endif
+
+- ifneq ($(findstring Linux26g4, $(TEC_UNAME)), )
+- LIBS += fontconfig
+- endif
+- ifneq ($(findstring Linux3, $(TEC_UNAME)), )
+- LIBS += fontconfig
+- endif
+- ifneq ($(findstring Linux4, $(TEC_UNAME)), )
+- LIBS += fontconfig
++ ifneq ($(findstring Linux, $(TEC_UNAME)), )
++ ifeq ($(shell expr $(TEC_SYSVERSION) \>= 3), 1)
++ LIBS += fontconfig
++ else
++ ifneq ($(findstring Linux26g4, $(TEC_UNAME)), )
++ LIBS += fontconfig
++ endif
++ endif
+ endif
++
+ ifneq ($(findstring cygw, $(TEC_UNAME)), )
+ LIBS += fontconfig
+ endif
+@@ -1213,18 +1214,20 @@
+ endif
+
+ ifdef LINK_WEBKIT
+- ifneq ($(findstring Linux4, $(TEC_UNAME)), )
+- LIBS += webkitgtk-3.0
+- else
+- ifneq ($(findstring Linux3, $(TEC_UNAME)), )
+- ifdef USE_GTK3
+- LIBS += webkitgtk-3.0
+- else
+- LIBS += webkitgtk-1.0
++ ifneq ($(findstring Linux, $(TEC_UNAME)), )
++ ifeq ($(shell expr $(TEC_SYSVERSION) \>= 4), 1)
++ LIBS += webkitgtk-3.0
++ else
++ ifneq ($(findstring Linux3, $(TEC_UNAME)), )
++ ifdef USE_GTK3
++ LIBS += webkitgtk-3.0
++ else
++ LIBS += webkitgtk-1.0
++ endif
+ endif
+- else
+- LIBS += webkit-1.0
+ endif
++ else
++ LIBS += webkit-1.0
+ endif
+ endif
+