summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordefname2023-01-21 11:15:22 +0100
committerdefname2023-01-21 11:15:22 +0100
commite1b06d104e0a1b6ee0a52534c00cc1288b0ba0bd (patch)
tree9c0dfb1534a60095698cf249382b971f09cdeb10
downloadaur-iwdrofimenu-git.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
-rw-r--r--iwdrofimenu.install41
3 files changed, 96 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c300b2b8f576
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = iwdrofimenu-git
+ pkgdesc = A rofi script providing a minimalistic wifi network chooser for iwd
+ pkgver = r35.bd271f2
+ pkgrel = 1
+ url = https://github.com/defname/rofi-iwd-wifi-menu
+ install = iwdrofimenu.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-pexpect
+ depends = python>=3.10
+ depends = iwd>=2
+ depends = rofi>=1.7
+ depends = util-linux>=2.38
+ provides = iwdrofimenu
+ conflicts = iwdrofimenu
+ source = iwdrofimenu::git+https://github.com/defname/rofi-iwd-wifi-menu
+ md5sums = SKIP
+
+pkgname = iwdrofimenu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5db3b47a6cc5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: defname
+pkgname=iwdrofimenu-git
+_pkgname=iwdrofimenu
+pkgver=r35.bd271f2
+pkgrel=1
+pkgdesc="A rofi script providing a minimalistic wifi network chooser for iwd"
+arch=("any")
+url="https://github.com/defname/rofi-iwd-wifi-menu"
+license=('GPL3')
+depends=("python-pexpect" "python>=3.10" "iwd>=2" "rofi>=1.7" "util-linux>=2.38")
+makedepends=("git")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+install=iwdrofimenu.install
+changelog=
+source=("${_pkgname}::git+https://github.com/defname/rofi-iwd-wifi-menu")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd ${_pkgname}
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd ${_pkgname}
+ install -d $pkgdir/usr/bin
+ PREFIX=$pkgdir/usr make install
+ rm $pkgdir/usr/bin/iwdrofimenu
+ ln -s /usr/share/$_pkgname/iwdrofimenu.py $pkgdir/usr/bin/iwdrofimenu
+}
diff --git a/iwdrofimenu.install b/iwdrofimenu.install
new file mode 100644
index 000000000000..b03655f52821
--- /dev/null
+++ b/iwdrofimenu.install
@@ -0,0 +1,41 @@
+# This is a default template for a post-install scriptlet.
+# Uncomment only required functions and remove any functions
+# you don't need (and this header).
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ echo "Installation of $1 completed."
+ echo "To use iwdrofimenu run it as a rofi script, for example with"
+ echo " rofi -show \"WIFI\" -modi \"WIFI:iwdrofimenu\""
+ echo ""
+ echo "Run"
+ echo " iwdrofimenu --help"
+ echo "for more information"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}