summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2014-08-04 16:42:35 +0200
committerCarsten Teibes2014-08-04 16:42:35 +0200
commitec539862fbe5b7a67a08e1a5f785c8dbfc875bf4 (patch)
tree928d0e74b4db7ac4883849aaad15fe33d967483f
downloadaur-iyfct.tar.gz
[add] iyfct 1.02
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
-rw-r--r--iyfct.sh3
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2932a1fd4a22
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = iyfct
+ pkgdesc = In Your Face City Trains - survive as long as you can
+ pkgver = 1.02
+ pkgrel = 1
+ url = http://simonlarsen.github.io/2011/05/29/in-your-face-city-trains.html
+ arch = any
+ license = CCPL:by
+ license = GPL3
+ depends = love
+ source = https://github.com/SimonLarsen/iyfct/releases/download/v1.02/iyfct-1.02.love
+ source = iyfct.sh
+ sha256sums = 37c6288ad8e7c5a7974bd481c61a14a87d6cf8399a93bc4f9a352d89292961a4
+ sha256sums = 89a21553f5a47f1a5d43a32eafb4261e5fc169292319214d68d9748f25f08e28
+
+pkgname = iyfct
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32ac470a1164
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+
+pkgname=iyfct
+pkgver=1.02
+pkgrel=1
+pkgdesc="In Your Face City Trains - survive as long as you can"
+arch=('any')
+url="http://simonlarsen.github.io/2011/05/29/in-your-face-city-trains.html"
+license=('CCPL:by' 'GPL3')
+depends=('love')
+source=("https://github.com/SimonLarsen/iyfct/releases/download/v$pkgver/iyfct-$pkgver.love"
+ "iyfct.sh")
+sha256sums=('37c6288ad8e7c5a7974bd481c61a14a87d6cf8399a93bc4f9a352d89292961a4'
+ '89a21553f5a47f1a5d43a32eafb4261e5fc169292319214d68d9748f25f08e28')
+
+prepare() {
+ # extract license + readme
+ bsdtar xf iyfct-$pkgver.love README.textile LICENCE
+}
+
+package() {
+ # copy love package
+ install -Dm644 iyfct-$pkgver.love "$pkgdir"/usr/share/iyfct/iyfct.love
+ # launcher
+ install -Dm755 iyfct.sh "$pkgdir"/usr/bin/iyfct
+ # readme + license
+ install -Dm644 README.textile "$pkgdir"/usr/share/doc/iyfct/README.textile
+ install -Dm644 LICENCE "$pkgdir"/usr/share/licenses/$pkgname/LICENCE
+}
diff --git a/iyfct.sh b/iyfct.sh
new file mode 100644
index 000000000000..b23ba85704ff
--- /dev/null
+++ b/iyfct.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+exec love /usr/share/iyfct/iyfct.love "$@"