summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Revelant2023-09-23 18:22:20 +0200
committerNicola Revelant2023-09-23 18:22:20 +0200
commit01dfc84dcf0061318c44dcd8ab93b6338fa559b8 (patch)
tree1238554aac55d220898c51862836482e85cc313a
parenta52c4123c61c82493beb57068d55e2ff473d347a (diff)
downloadaur-j4-dmenu-desktop-git.tar.gz
Install documentation and fix build script
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD33
2 files changed, 21 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 979ab424b8c5..65111171e0cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = j4-dmenu-desktop-git
pkgdesc = A rewrite of i3-dmenu-desktop, which is much faster
- pkgver = 2.18.r11.g7a64862
- pkgrel = 4
+ pkgver = 2.18.r99.g7e3fd04
+ pkgrel = 1
url = https://github.com/enkore/j4-dmenu-desktop
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index b62504329c2a..5bf5746d593f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: mrdotx <klassiker@gmx.de>
+# Maintainer: Nicola Revelant <nicolarevelant@outlook.com>
+# Contributor: mrdotx <klassiker@gmx.de>
# Contributor: shulhan <ms@kilabit.info>
# Contributor: Bill Kolokithas <kolokithas.b@gmail.com>
+
_pkgname=j4-dmenu-desktop
pkgname=j4-dmenu-desktop-git
-pkgver=2.18.r11.g7a64862
-pkgrel=4
+pkgver=2.18.r99.g7e3fd04
+pkgrel=1
pkgdesc='A rewrite of i3-dmenu-desktop, which is much faster'
arch=('i686' 'x86_64')
url='https://github.com/enkore/j4-dmenu-desktop'
license=('GPL3')
makedepends=(
- 'git'
- 'cmake')
+ 'git'
+ 'cmake')
optdepends=(
- 'dmenu: the default backend'
- 'bemenu: an alternative backend'
+ 'dmenu: the default backend'
+ 'bemenu: an alternative backend'
)
provides=('j4-dmenu-desktop')
conflicts=('j4-dmenu-desktop')
@@ -22,17 +24,20 @@ source=('git+https://github.com/enkore/j4-dmenu-desktop.git')
md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
- git describe --long | sed -r 's/^r//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd "$_pkgname"
+ git describe --long | sed -r 's/^r//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname"
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DNO_TESTS=1 .
- make
+ cd "$_pkgname"
+ cmake -B build -DCMAKE_INSTALL_PREFIX=/usr -DWITH_TESTS=0 -DCMAKE_BUILD_TYPE=Release
+ cmake --build build
}
package() {
- cd "$_pkgname"
- make DESTDIR="$pkgdir"/ install
+ cd "$_pkgname"
+ cmake --install build --prefix="$pkgdir/usr"
+ gzip < "$_pkgname.1" > "build/$_pkgname.1.gz"
+ install -Dm0644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
+ install -Dm0644 "build/$_pkgname.1.gz" -t "$pkgdir/usr/share/man/man1"
}