summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMasanori Ogino2022-07-14 12:48:00 +0900
committerMasanori Ogino2022-07-14 12:48:00 +0900
commitfd1fa82c5758cbeee3ae2142cab05171b7dde4de (patch)
tree2b93df440c5526f8c52e969aa2b0b403f2e99f9f
parentdfcec2dec4e3ea96074fb96ea7fb888f46c91a34 (diff)
downloadaur-jacal.tar.gz
Update to 1c7
Signed-off-by: Masanori Ogino <masanori.ogino@gmail.com>
-rw-r--r--.SRCINFO15
-rw-r--r--Makefile.patch15
-rw-r--r--PKGBUILD20
-rw-r--r--fix-makefile.patch30
4 files changed, 48 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2bc68ebddcd9..ff3b98e3226f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
-# Generated by mksrcinfo v8
-# Fri Mar 23 21:49:04 UTC 2018
pkgbase = jacal
pkgdesc = A symbolic mathematics system written in Scheme.
- pkgver = 1c4
- pkgrel = 3
+ pkgver = 1c7
+ pkgrel = 1
url = http://people.csail.mit.edu/jaffer/JACAL.html
arch = any
- license = LGPL
+ license = GPL3
depends = scm
depends = slib
options = !makeflags
- source = http://groups.csail.mit.edu/mac/ftpdir/scm/jacal-1c4.zip
- md5sums = 58e03bd4292a02744728e6f68f48bb41
+ source = http://groups.csail.mit.edu/mac/ftpdir/scm/jacal-1c7.zip
+ source = fix-makefile.patch
+ sha256sums = bf93157ffc4251b7da99f50815161060a180a61f0f25d4ec5dc2b41953d74519
+ sha256sums = 4d210ad4c43b08d016e69c17609c0c2cf860fee41d4a90b6e377c83031732572
pkgname = jacal
-
diff --git a/Makefile.patch b/Makefile.patch
deleted file mode 100644
index 13d4b660df40..000000000000
--- a/Makefile.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -Naur jacal.orig/Makefile jacal.new/Makefile
---- jacal.orig/Makefile 2018-03-23 20:48:41.653359697 +0100
-+++ jacal.new/Makefile 2018-03-23 20:50:17.185350568 +0100
-@@ -195,9 +195,9 @@
- $(INSTALL_DATA) go-scm $(DESTDIR)$(jacallibdir)go.scm
- rm go-scm
- echo '#! /bin/sh' > jacal-script
-- grep -h ^SCHEME_LIBRARY_PATH= `which slib`>> jacal-script
-+ echo SCHEME_LIBRARY_PATH=/usr/share/slib/ >> jacal-script
- echo export SCHEME_LIBRARY_PATH >> jacal-script
-- echo JACALDIR=$(DESTDIR)$(jacallibdir) >> jacal-script
-+ echo JACALDIR=/usr/lib/jacal/ >> jacal-script
- echo VERSION=$(VERSION) >> jacal-script
- cat $< >> jacal-script
- $(INSTALL_PROGRAM) jacal-script $(DESTDIR)$(bindir)jacal
diff --git a/PKGBUILD b/PKGBUILD
index fb9b1aa3447f..032f5f2908c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,26 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=jacal
-pkgver=1c4
-pkgrel=3
+pkgver=1c7
+pkgrel=1
pkgdesc="A symbolic mathematics system written in Scheme."
url="http://people.csail.mit.edu/jaffer/JACAL.html"
arch=('any')
-license=('LGPL')
+license=('GPL3')
depends=('scm' 'slib')
-source=(http://groups.csail.mit.edu/mac/ftpdir/scm/$pkgname-$pkgver.zip)
-md5sums=('58e03bd4292a02744728e6f68f48bb41')
+source=(http://groups.csail.mit.edu/mac/ftpdir/scm/$pkgname-$pkgver.zip
+ fix-makefile.patch)
+sha256sums=('bf93157ffc4251b7da99f50815161060a180a61f0f25d4ec5dc2b41953d74519'
+ '4d210ad4c43b08d016e69c17609c0c2cf860fee41d4a90b6e377c83031732572')
options=('!makeflags')
build() {
- export SCHEME_LIBRARY_PATH=/usr/lib/slib/
+ export SCHEME_LIBRARY_PATH=/usr/share/slib/
cd $srcdir/$pkgname
- ./configure --prefix=/usr --exec-prefix=/usr
+ patch --forward --strip=1 --input="${srcdir}/fix-makefile.patch"
+
+ sh ./configure --prefix=/usr --exec-prefix=/usr
sed -i 's/jacal-$(VERSION).info/jacal.info/g;' Makefile
make -k
@@ -27,6 +31,4 @@ package() {
cd $srcdir/$pkgname
make DESTDIR=$pkgdir install
rmdir $pkgdir/usr/share/doc/$pkgname
- sed -i '4d' $pkgdir/usr/bin/jacal
}
-
diff --git a/fix-makefile.patch b/fix-makefile.patch
new file mode 100644
index 000000000000..5ac29985ca45
--- /dev/null
+++ b/fix-makefile.patch
@@ -0,0 +1,30 @@
+--- jacal.orig/Makefile 2022-07-14 11:58:29.649924664 +0900
++++ jacal/Makefile 2022-07-14 12:39:23.292683511 +0900
+@@ -25,7 +25,7 @@
+ INSTALL = install
+ INSTALL_PROGRAM = ${INSTALL}
+ INSTALL_DATA = ${INSTALL} -m 644
+-INSTALL_INFO = ginstall-info
++INSTALL_INFO = ${INSTALL}
+
+ CHPAT = $(HOME)/bin/chpat
+ MAKEDEV = $(MAKE) -f $(HOME)/makefile.dev
+@@ -195,12 +195,12 @@
+ echo "(math)" >> go-scm
+ $(INSTALL_DATA) go-scm $(DESTDIR)$(jacallibdir)go.scm
+ rm go-scm
+- echo '#! /bin/sh' > jacal-script
+- grep -h ^SCHEME_LIBRARY_PATH= `which slib`>> jacal-script
+- echo export SCHEME_LIBRARY_PATH >> jacal-script
+- echo JACALDIR=$(DESTDIR)$(jacallibdir) >> jacal-script
+- echo VERSION=$(VERSION) >> jacal-script
+- cat $< >> jacal-script
++ echo '#! /bin/sh' > jacal-script
++ echo SCHEME_LIBRARY_PATH=$(SCHEME_LIBRARY_PATH) >> jacal-script
++ echo export SCHEME_LIBRARY_PATH >> jacal-script
++ echo JACALDIR=$(jacallibdir) >> jacal-script
++ echo VERSION=$(VERSION) >> jacal-script
++ cat $< >> jacal-script
+ $(INSTALL_PROGRAM) jacal-script $(DESTDIR)$(bindir)jacal
+ rm jacal-script
+