summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Anderson2015-06-20 09:13:10 -0700
committerEric Anderson2015-06-20 09:13:10 -0700
commitf636c1637868e0f0b306eb3ed20f49cb023bb53b (patch)
tree216eb2e80c234e40e41007ec5f0a8e6103611f04
downloadaur-jamestown-gtp.tar.gz
Initial import
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
3 files changed, 58 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..6e1f9c205034
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = jamestown-gtp
+ pkgdesc = Gunpower, Treason, & Plot: DLC for a neo-classical top-down shooter (DLC sold separately)
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://www.finalformgames.com/jamestown/
+ arch = any
+ license = custom
+ depends = jamestown>=1.0.2
+ source = hib://JamestownLinux_1_0_2_GTP_1409159048.zip
+ md5sums = 4488a432df220b448cd858ca9fa06618
+
+pkgname = jamestown-gtp
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e1f9c205034
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = jamestown-gtp
+ pkgdesc = Gunpower, Treason, & Plot: DLC for a neo-classical top-down shooter (DLC sold separately)
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = http://www.finalformgames.com/jamestown/
+ arch = any
+ license = custom
+ depends = jamestown>=1.0.2
+ source = hib://JamestownLinux_1_0_2_GTP_1409159048.zip
+ md5sums = 4488a432df220b448cd858ca9fa06618
+
+pkgname = jamestown-gtp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e73bf8eadfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Eric Anderson <ejona86@gmail.com>
+
+pkgname=jamestown-gtp
+pkgver=1.0.2
+_pkgver=${pkgver//./_}
+pkgrel=1
+pkgdesc='Gunpower, Treason, & Plot: DLC for a neo-classical top-down shooter (DLC sold separately)'
+arch=('any')
+url='http://www.finalformgames.com/jamestown/'
+license=('custom')
+depends=('jamestown>=1.0.2')
+source=("hib://JamestownLinux_${_pkgver}_GTP_1409159048.zip")
+md5sums=('4488a432df220b448cd858ca9fa06618')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+build() {
+ cd "${srcdir}"
+
+ mkdir -p "${pkgname}-${pkgver}"
+ bsdtar -x -C "${pkgname}-${pkgver}" -f "JamestownGTPInstaller_${_pkgver}-bin"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ cd data
+ find Archives -type f -exec \
+ install -Dm644 {} "${pkgdir}/opt/jamestown/{}" \;
+
+ install -Dm644 Jamestown_GTPEULA.txt \
+ "${pkgdir}/usr/share/licenses/${pkgname}/Jamestown_GTPEULA.txt "
+}