summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcobalt2020-08-16 05:14:49 +0300
committercobalt2020-08-16 05:14:49 +0300
commit1a34bb307feb79a3eb27b5c6d7c66f0c09a26518 (patch)
treeb8fd662dbe24b3221fcc4655aeecc190bfc0a542
downloadaur-jamin.tar.gz
Initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD29
-rw-r--r--jamin.install13
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..606fa33e3363
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = jamin
+ pkgdesc = A JACK Audio Connection Kit Audio Mastering interface
+ pkgver = 0.98.9
+ pkgrel = 1
+ url = http://jamin.sourceforge.net/
+ install = jamin.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = perl-xml-parser
+ makedepends = ladspa
+ makedepends = intltool
+ depends = jack
+ depends = libxml2
+ depends = gtk3
+ depends = swh-plugins
+ depends = fftw
+ depends = liblo
+ provides = jamin
+ conflicts = jamin-gtk2
+ conflicts = jamin-cvs
+ options = !libtool
+ source = jamin-code::git+https://git.code.sf.net/p/jamin/code
+ md5sums = SKIP
+
+pkgname = jamin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29d29c99849b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: cobalt <jpt@mail.ru>
+pkgname=jamin
+pkgver=0.98.9
+pkgrel=1
+pkgdesc="A JACK Audio Connection Kit Audio Mastering interface"
+arch=('i686' 'x86_64')
+url="http://jamin.sourceforge.net/"
+license=('GPL')
+depends=('jack' 'libxml2' 'gtk3' 'swh-plugins' 'fftw' 'liblo')
+makedepends=('perl-xml-parser' 'ladspa' 'intltool')
+conflicts=('jamin-gtk2' 'jamin-cvs')
+provides=('jamin')
+options=('!libtool')
+install=${pkgname}.install
+source=('jamin-code::git+https://git.code.sf.net/p/jamin/code')
+md5sums=('SKIP')
+
+build() {
+ LDFLAGS="-ldl"
+ CFLAGS="-Wno-deprecated-declarations -Wno-pointer-sign -Wno-cpp -Wno-unused-but-set-variable -Wno-incompatible-pointer-types -Wno-unused-variable -fcommon"
+ cd ${srcdir}/jamin-code
+ ./autogen.sh --prefix=/usr --libdir=/usr/lib
+ make
+}
+
+package() {
+ cd ${srcdir}/jamin-code
+ make DESTDIR=${pkgdir} install
+}
diff --git a/jamin.install b/jamin.install
new file mode 100644
index 000000000000..d2e62232b416
--- /dev/null
+++ b/jamin.install
@@ -0,0 +1,13 @@
+post_install() {
+ /usr/bin/update-mime-database usr/share/mime
+}
+
+pre_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+
+# vim:set ts=2 sw=2 et: