summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAinola2015-06-08 11:50:16 -0600
committerAinola2015-06-08 11:50:16 -0600
commit26ca03217ad113dbc62904bd24c7ef8342234e55 (patch)
tree81bd51855ca425e1f3b9e67307a72131ed51a9c3
downloadaur-jazzpunk-hib.tar.gz
initial
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD46
-rw-r--r--jazzpunk-hib.desktop10
-rw-r--r--jazzpunk-hib.pngbin0 -> 32121 bytes
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a672fdac5a09
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = jazzpunk-hib
+ pkgdesc = Jazzpunk is an adventure comedy game and poorly made word processor (Humble Bundle Version).
+ pkgver = July6_2014
+ pkgrel = 2
+ url = http://jazzpunk.net/
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ depends = glu
+ depends = libxext
+ depends = libxcursor
+ source = hib://Jazzpunk-July6-2014-Linux.zip
+ source = jazzpunk-hib.png
+ source = jazzpunk-hib.desktop
+ sha256sums = 9e6f29d87295292cf60a0173b09ccc5a5c429ec084fe2f0c7ab7732851fdf3b7
+ sha256sums = c2ddb1cff681814ab56aa88cf5b64664c277fd3a9b452573c3401a08c019ffe1
+ sha256sums = 8f42bfbb22dfaded91a47416edae581d4b7ff3d17b77262243248ad2dd6220fc
+
+pkgname = jazzpunk-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aeb6248e3b7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: ainola <opp310@alh.rqh> (ROT13)
+
+pkgname=jazzpunk-hib
+pkgver=July6_2014
+pkgrel=2
+pkgdesc="Jazzpunk is an adventure comedy game and poorly made word processor (Humble Bundle Version)."
+arch=('i686' 'x86_64')
+url="http://jazzpunk.net/"
+license=('custom: commercial')
+depends=('glu' 'libxext' 'libxcursor')
+source=("hib://Jazzpunk-${pkgver/_/-}-Linux.zip"
+ "${pkgname}.png"
+ "${pkgname}.desktop")
+sha256sums=("9e6f29d87295292cf60a0173b09ccc5a5c429ec084fe2f0c7ab7732851fdf3b7"
+ "c2ddb1cff681814ab56aa88cf5b64664c277fd3a9b452573c3401a08c019ffe1"
+ "8f42bfbb22dfaded91a47416edae581d4b7ff3d17b77262243248ad2dd6220fc")
+[ "$CARCH" == "x86_64" ] && _arch="x86_64" || _arch="x86"
+# Prevent compressing final package
+PKGEXT='.pkg.tar'
+
+# You need to download the Humble Bundle file manually or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, hib-dlagent (https://aur.archlinux.org/packages/hib-dlagent/)
+# can be used to download files. Add something like this in your makepkg.conf
+# (you need to tweak the options to your needs):
+# DLAGENTS+=('hib::/usr/bin/hib-dlagent -k $KEY -u $USER -p $PASS -o %o %u')
+#
+# The following is just a fallback to the above to notify the user:
+DLAGENTS+=("hib::/usr/bin/echo %u - This is is not a real URL, you need to download the humble bundle file manually to \"$PWD\" or setup a hib:// DLAGENT. Read this PKGBUILD for more information.")
+
+package() {
+ # Launcher and Data
+ install -Dm755 "${srcdir}/Jazzpunk.${_arch}" "${pkgdir}/opt/${pkgname}/Jazzpunk.${_arch}"
+ mv "${srcdir}/Jazzpunk_Data" "${pkgdir}/opt/${pkgname}/"
+ find "${pkgdir}/opt/${pkgname}/Jazzpunk_Data" -type d -exec chmod 755 {} \;
+ find "${pkgdir}/opt/${pkgname}/Jazzpunk_Data" -type f -exec chmod 644 {} \;
+
+ # Install Binaries/Launchers
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/${pkgname}/Jazzpunk.${_arch}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # Desktop Integration
+ install -Dm644 "${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/jazzpunk-hib.desktop b/jazzpunk-hib.desktop
new file mode 100644
index 000000000000..6c81214b5de9
--- /dev/null
+++ b/jazzpunk-hib.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Jazzpunk
+Comment=Play Jazzpunk
+Exec=jazzpunk-hib
+Icon=jazzpunk-hib
+Type=Application
+Terminal=false
+StartupNotify=true
+Categories=Game;AudioVideo;
+Encoding=UTF-8
diff --git a/jazzpunk-hib.png b/jazzpunk-hib.png
new file mode 100644
index 000000000000..43850c8a820e
--- /dev/null
+++ b/jazzpunk-hib.png
Binary files differ