summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-08-18 10:02:35 -0600
committerMark Wagie2021-08-18 10:02:35 -0600
commitd31efdc251e1bd293513e5feed840343f084433a (patch)
tree3cab4c645a0500d3053b7341613b19d0881a8863
parentf28cc10351c93f9462eeb1832e02b302bba95b32 (diff)
downloadaur-jdsp4linux-gui-git.tar.gz
adjust pkgver()
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD26
3 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5d63630e6a3b..fe7e4b8f1202 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = jdsp4linux-gui-git
pkgdesc = User Interface for JamesDSP on Linux
- pkgver = 1.1.r2.3abfc92
- pkgrel = 2
+ pkgver = 1.1.r5.gc03eecb
+ pkgrel = 1
url = https://github.com/ThePBone/JDSP4Linux-GUI
arch = x86_64
license = GPL3
@@ -17,4 +17,3 @@ pkgbase = jdsp4linux-gui-git
sha256sums = fa8ed0bee321c7fed6d2368d0bdf6fd12a3318e324bbda50ec6dbe7e3b784794
pkgname = jdsp4linux-gui-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..49a76b6cced1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!jdsp4linux-gui.desktop
diff --git a/PKGBUILD b/PKGBUILD
index f732a8b475d3..ea9d56a3fc09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=jdsp4linux-gui-git
-pkgver=1.1.r2.3abfc92
-pkgrel=2
+pkgver=1.1.r5.gc03eecb
+pkgrel=1
pkgdesc="User Interface for JamesDSP on Linux"
arch=('x86_64')
url="https://github.com/ThePBone/JDSP4Linux-GUI"
@@ -16,21 +16,21 @@ sha256sums=('SKIP'
'fa8ed0bee321c7fed6d2368d0bdf6fd12a3318e324bbda50ec6dbe7e3b784794')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/${pkgname%-git}"
- qmake
- make PREFIX=/usr
+ cd "$srcdir/${pkgname%-git}"
+ qmake
+ make PREFIX=/usr
}
package() {
- cd "$srcdir/${pkgname%-git}"
- install -Dm755 jdsp-gui -t "$pkgdir/usr/bin"
- install -Dm644 "$srcdir/${pkgname%-git}.desktop" -t \
- "$pkgdir/usr/share/applications"
- install -Dm644 icons/icon.png \
- "$pkgdir/usr/share/pixmaps/jdsp-gui.png"
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 jdsp-gui -t "$pkgdir/usr/bin"
+ install -Dm644 "$srcdir/${pkgname%-git}.desktop" -t \
+ "$pkgdir/usr/share/applications"
+ install -Dm644 icons/icon.png \
+ "$pkgdir/usr/share/pixmaps/jdsp-gui.png"
}