summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Batalesi2024-03-12 12:13:36 +0100
committerAntonio Batalesi2024-03-12 12:13:36 +0100
commitfa9ae1bb8756ba7d6ed22de0edf4ea6ea014680b (patch)
treeb4dc3553cf69ab00a31f7f7d1239ed37431bf441
parente7ae5c9468616941c3e08a39c0b700e38bb17087 (diff)
downloadaur-jive.tar.gz
dependencies, license
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD10
3 files changed, 14 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de0188f70f02..8ecc1199258f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = jive
pkgdesc = A standalone JAVA application designed to browse and edit the static TANGO database
pkgver = 7.41
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/tango-controls/Jive
arch = any
- license = GPL3
- makedepends = jre17-openjdk
+ license = GPL-3.0-or-later
makedepends = maven
- depends = jre17-openjdk
+ makedepends = jre17-openjdk
+ depends = java-runtime=17
depends = sh
+ depends = hicolor-icon-theme
source = https://gitlab.com/tango-controls/jive/-/archive/7.41/jive-7.41.tar.gz
source = launcher
source = jive.desktop
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e7126cb3d891
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src
+pkg
+*.tar.gz
+*.tar.zst \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 136e4bac2fa9..c1307bfcbd42 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@ _name="Jive"
pkgname=${_name,,}
pkgver=7.41
_jarfile="${_name}-${pkgver}-jar-with-dependencies.jar"
-pkgrel=1
+pkgrel=2
pkgdesc="A standalone JAVA application designed to browse and edit the static TANGO database"
arch=("any")
url="https://gitlab.com/tango-controls/${_name}"
-license=("GPL3")
-depends=(jre17-openjdk sh)
-makedepends=(jre17-openjdk maven)
+license=("GPL-3.0-or-later")
+depends=(java-runtime=17 sh hicolor-icon-theme)
+makedepends=(maven jre17-openjdk)
source=(
https://gitlab.com/tango-controls/${pkgname}/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz
launcher
@@ -36,7 +36,7 @@ build() {
package() {
install -D -m755 ${srcdir}/${pkgname}-${pkgver}/target/${_jarfile} ${pkgdir}/usr/share/java/${pkgname}/${_jarfile}
- install -D -m755 ${srcdir}/jive.desktop ${pkgdir}/usr/share/applications/jive.desktop
install -D -m755 ${srcdir}/launcher ${pkgdir}/usr/bin/${pkgname}
+ install -D -m755 ${srcdir}/jive.desktop ${pkgdir}/usr/share/applications/jive.desktop
install -D -m755 ${srcdir}/${pkgname}-${pkgver}/src/main/resources/jive/jive.png ${pkgdir}/usr/share/icons/hicolor/48x48/apps/jive.png
}