summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Szymański2015-09-07 18:54:51 +0200
committerMichał Szymański2015-09-07 18:54:51 +0200
commit168f24a2d07bff9d9b79f946b4c9dc3971e6b8df (patch)
tree0154f7ce32c62d0943d06728bd50898e23d72b6f
downloadaur-jokosher.tar.gz
jokosher 0.11.5
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD37
-rw-r--r--jokosher.install13
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c091a4eef93
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = jokosher
+ pkgdesc = A simple and easy-to-use Open Source multi-track editor
+ pkgver = 0.11.5
+ pkgrel = 3
+ url = http://jokosher.org
+ install = jokosher.install
+ arch = any
+ license = GPL
+ makedepends = python2-distribute
+ depends = gstreamer0.10-python
+ depends = gnonlin
+ depends = dbus-python
+ depends = libcanberra
+ depends = gstreamer0.10-base-plugins
+ depends = gstreamer0.10-base>=0.10.12
+ depends = pygtk
+ depends = gstreamer0.10-good
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = pyxdg
+ source = http://launchpad.net/jokosher/trunk/0.11.5/+download/jokosher-0.11.5.tar.gz
+ md5sums = 941b1fac0a93e2963afc192545caf320
+
+pkgname = jokosher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3aa773183df3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Michał Szymański <smiszym at gmail dot com>
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+# Contributor: Bjorn Lindeijer <bjorn lindeijer nl>
+# Contributor: William Rea <sillywilly@gmail.com>
+
+pkgname=jokosher
+pkgver=0.11.5
+pkgrel=3
+pkgdesc="A simple and easy-to-use Open Source multi-track editor"
+arch=('any')
+url="http://jokosher.org"
+license=('GPL')
+install="$pkgname.install"
+depends=('gstreamer0.10-python' 'gnonlin' 'dbus-python' 'libcanberra'
+ 'gstreamer0.10-base-plugins' 'gstreamer0.10-base>=0.10.12' 'pygtk'
+ 'gstreamer0.10-good' 'desktop-file-utils' 'hicolor-icon-theme' 'pyxdg')
+makedepends=('python2-distribute')
+source=("http://launchpad.net/$pkgname/trunk/$pkgver/+download/$pkgname-$pkgver.tar.gz")
+md5sums=('941b1fac0a93e2963afc192545caf320')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ python2 setup.py install --skip-build --root=$pkgdir
+
+ # python2 fix
+ sed -i 's|bin/python|&2|' `find "$pkgdir" -name "*.py"`
+}
+
+# vim:set ts=4 sw=4 et:
diff --git a/jokosher.install b/jokosher.install
new file mode 100644
index 000000000000..a7a86bcc0c5f
--- /dev/null
+++ b/jokosher.install
@@ -0,0 +1,13 @@
+post_install () {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-mime-database usr/share/mime > /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}