summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-09-05 12:36:16 -0400
committerJames An2016-09-05 12:36:16 -0400
commit6f5a687d0d0de13b4cb7c8d4975d4b3ba4ae3080 (patch)
tree6225369534560b9dacd393f33c30a32dc63e5ce5
downloadaur-jsonix-schema-compiler.tar.gz
Initial commit with working package.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore30
-rw-r--r--PKGBUILD23
-rw-r--r--jsonix-schema-compiler.sh2
4 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bfa68111b49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = jsonix-schema-compiler
+ pkgdesc = Compiles XML Schemas into XML<->JSON mappings for Jsonix.
+ pkgver = 2.3.9
+ pkgrel = 1
+ url = https://github.com/highsource/jsonix-schema-compiler
+ arch = any
+ license = BSD
+ depends = java-runtime
+ noextract = jsonix-schema-compiler-full-2.3.9.jar
+ source = https://github.com/highsource/jsonix-schema-compiler/releases/download/2.3.9/jsonix-schema-compiler-full-2.3.9.jar
+ source = https://github.com/highsource/jsonix-schema-compiler/raw/2.3.9/LICENSE
+ source = jsonix-schema-compiler.sh
+ md5sums = d39494df9c0626c53eea7d18dd040af7
+ md5sums = 5ce6a47a9e9e030bba86c43efec26316
+ md5sums = 4b2a4cc81046d1f816e34d9887e23e35
+
+pkgname = jsonix-schema-compiler
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..264f2f776ad4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,30 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+LICENSE*
+*.jar
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1839d490073f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=jsonix-schema-compiler
+pkgver=2.3.9
+pkgrel=1
+pkgdesc="Compiles XML Schemas into XML<->JSON mappings for Jsonix."
+arch=('any')
+url="https://github.com/highsource/$pkgname"
+license=('BSD')
+depends=('java-runtime')
+source=("$url/releases/download/$pkgver/$pkgname-full-$pkgver.jar"
+ "$url/raw/$pkgver/LICENSE"
+ "$pkgname.sh")
+noextract=("${source[0]##*/}")
+md5sums=('d39494df9c0626c53eea7d18dd040af7'
+ '5ce6a47a9e9e030bba86c43efec26316'
+ '4b2a4cc81046d1f816e34d9887e23e35')
+
+package() {
+ install -D -m644 "$pkgname-full-$pkgver.jar" "$pkgdir/usr/share/java/$pkgname/$pkgname-full-$pkgver.jar"
+ install -D -m755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+}
diff --git a/jsonix-schema-compiler.sh b/jsonix-schema-compiler.sh
new file mode 100644
index 000000000000..a36522a3f436
--- /dev/null
+++ b/jsonix-schema-compiler.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/java -jar '/usr/share/java/jsonix-schema-compiler/jsonix-schema-compiler-full-2.3.9.jar' "$@"