summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2020-06-22 01:39:43 +1000
committerBrenton Horne2020-06-22 01:39:43 +1000
commitfedd6983a0643473ef3aca56a3832d0489c2988d (patch)
treec556513d82cff34e83fb335f91fd480e541fc4ea
parente7fa70fd8ac6b33ba88c08ea16c6c7d468320037 (diff)
downloadaur-fedd6983a0643473ef3aca56a3832d0489c2988d.tar.gz
Upd confl, +deps, fx lic inst loc, + maint info
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 11 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 346685ed8ea6..55310d2ff62d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,10 +5,15 @@ pkgbase = julia-beta-bin
url = https://julialang.org/
arch = x86_64
license = MIT
+ depends = gmp
+ depends = suitesparse
+ depends = hicolor-icon-theme
+ depends = libssh2
provides = julia-beta
conflicts = julia
conflicts = julia-bin
conflicts = julia-git
+ conflicts = julia-nightly-bin
options = !strip
source = https://julialang-s3.julialang.org/bin/linux/x64/1.5/julia-1.5.0-beta1-linux-x86_64.tar.gz
sha256sums = 7a81c386de7b0e8f291bfbe77cbb8e1679a03d974db2093806c78a2067b97ed9
diff --git a/PKGBUILD b/PKGBUILD
index 1fd8446a3db8..ee82f168ac5f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,5 @@
+# Maintainer: Brenton Horne <brentonhorne77 at gmail dot com>
+
pkgname=julia-beta-bin
_pkgver=1.5.0-beta1
pkgver=$(echo $_pkgver | sed 's/-/./g')
@@ -5,7 +7,8 @@ pkgrel=1
arch=('x86_64')
pkgdesc='High-level, high-performance, dynamic programming language - official binaries'
provides=(julia-beta)
-conflicts=(julia julia-bin julia-git)
+conflicts=(julia julia-bin julia-git julia-nightly-bin)
+depends=('gmp' 'suitesparse' 'hicolor-icon-theme' 'libssh2')
url='https://julialang.org/'
license=('MIT')
source=("https://julialang-s3.julialang.org/bin/linux/x64/${pkgver:0:3}/julia-${_pkgver}-linux-x86_64.tar.gz")
@@ -14,10 +17,10 @@ options=(!strip)
package() {
cd $srcdir/julia-${_pkgver}
- mkdir -p ${pkgdir}/usr/share/licenses/julia
+ mkdir -p ${pkgdir}/usr/share/licenses/${pkgname}
cp -r {bin,etc,include,lib,share} ${pkgdir}/usr/
install -Dm644 LICENSE.md \
- ${pkgdir}/usr/share/licenses/julia/LICENSE.md
+ ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md
}
# vim: ts=2 sw=2 et: