summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2019-05-22 23:57:43 +0200
committerNarrat2019-05-22 23:57:43 +0200
commit13d45c83e21c1644d8807ad34709af6d42a55401 (patch)
tree8799c3f5909ce08439068ba6cb15ac8fd0d997dd
parent2e6c25adcc4d6e883367f908803dc421b9df64a9 (diff)
downloadaur-13d45c83e21c1644d8807ad34709af6d42a55401.tar.gz
Julia: Adjust patches for 1.3.0 DEV
-rw-r--r--.SRCINFO8
-rw-r--r--Make.user1
-rw-r--r--PKGBUILD12
-rw-r--r--cblas.patch6
-rw-r--r--julia-makefile.patch15
5 files changed, 24 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72517b431123..efbcf5c1e447 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = julia-git
pkgdesc = High-level, high-performance, dynamic programming language
- pkgver = 1.1.0.DEV.r43604.g36d0116774
+ pkgver = 1.3.0.DEV.r44719.gefd794e199
pkgrel = 1
url = https://julialang.org
arch = x86_64
@@ -29,9 +29,9 @@ pkgbase = julia-git
source = julia-makefile.patch
source = cblas.patch
sha256sums = SKIP
- sha256sums = 89c7b3234cf87d132345b6c0194dae756836059d3793cc8a97cc6366203a6ae7
- sha256sums = 29b68ecdaf91770585609f54e5559e571d6b57a6312a3e8335caa7d647a2d2ca
- sha256sums = 5c346bf8ed9a5763cf3bf6478158297107f16bbc07052b43920f778f0018b77a
+ sha256sums = 21f97b3441097e71db59e2205f644466d829bbd0b73a34bc8b857b4390cf8ffc
+ sha256sums = 030b37d711a08567e7f9c5f0626dec7aed02c83373b5ec666d519897b50218ea
+ sha256sums = 5eb9280c6b91c9be15a52de7dc5f05e69a5edbfe1c5d1f62497470a1aa0d1fa8
pkgname = julia-git
depends = cblas
diff --git a/Make.user b/Make.user
index d1b83a45d774..ea39240e6ce3 100644
--- a/Make.user
+++ b/Make.user
@@ -9,6 +9,7 @@ USE_SYSTEM_LIBM:=0
USE_SYSTEM_OPENLIBM:=1
USE_SYSTEM_DSFMT:=0
USE_SYSTEM_BLAS:=1
+USE_SYSTEM_CBLAS:=1
USE_SYSTEM_LAPACK:=1
USE_SYSTEM_GMP:=1
USE_SYSTEM_MPFR:=0
diff --git a/PKGBUILD b/PKGBUILD
index dfcc8c86ca50..a2b143f733ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgbase=julia
pkgbase=${_pkgbase}-git
pkgname=('julia-git' 'julia-git-docs')
-pkgver=1.1.0.DEV.r43604.g36d0116774
+pkgver=1.3.0.DEV.r44719.gefd794e199
pkgrel=1
pkgdesc='High-level, high-performance, dynamic programming language'
arch=('x86_64')
@@ -22,9 +22,9 @@ source=(git://github.com/JuliaLang/julia.git#branch=master
julia-makefile.patch
cblas.patch)
sha256sums=('SKIP'
- '89c7b3234cf87d132345b6c0194dae756836059d3793cc8a97cc6366203a6ae7'
- '29b68ecdaf91770585609f54e5559e571d6b57a6312a3e8335caa7d647a2d2ca'
- '5c346bf8ed9a5763cf3bf6478158297107f16bbc07052b43920f778f0018b77a')
+ '21f97b3441097e71db59e2205f644466d829bbd0b73a34bc8b857b4390cf8ffc'
+ '030b37d711a08567e7f9c5f0626dec7aed02c83373b5ec666d519897b50218ea'
+ '5eb9280c6b91c9be15a52de7dc5f05e69a5edbfe1c5d1f62497470a1aa0d1fa8')
pkgver() {
@@ -41,10 +41,10 @@ prepare() {
git submodule init
git submodule update
- # Move the Make.user in place
+ msg2 'Configuring the build...'
cp -v $srcdir/Make.user .
- # make 'make install' really just install
+ msg2 'Patching make install...'
patch -p0 -i ../julia-makefile.patch
# add and use option to build with system cblas
diff --git a/cblas.patch b/cblas.patch
index e742507ff3c5..c0cf0607a307 100644
--- a/cblas.patch
+++ b/cblas.patch
@@ -3,7 +3,7 @@ Author: Eli Schwartz <eschwartz@archlinux.org>
Date: Fri Oct 5 15:52:17 2018 +0000
Use a dedicated cblas library, that may or may not be in fact the blas one.
-
+
Openblas can be built with statically compiled convenience copies of
cblas, but if not, then the system libcblas.so should be used.
@@ -90,7 +90,7 @@ index fee8c9e74d..8c76d1acbf 100644
const liblapack = Base.liblapack_name
import LinearAlgebra
-@@ -102,6 +103,16 @@ else
+@@ -103,6 +103,16 @@ else
end
end
@@ -104,7 +104,7 @@ index fee8c9e74d..8c76d1acbf 100644
+ end
+end
+
- openblas_get_config() = strip(unsafe_string(ccall((@blasfunc(openblas_get_config), Base.libblas_name), Ptr{UInt8}, () )))
+ openblas_get_config() = strip(unsafe_string(ccall((@blasfunc(openblas_get_config), libblas), Ptr{UInt8}, () )))
"""
@@ -301,7 +312,7 @@ for (fname, elty) in ((:cblas_zdotc_sub,:ComplexF64),
diff --git a/julia-makefile.patch b/julia-makefile.patch
index 0618b96803e3..da263d2777a1 100644
--- a/julia-makefile.patch
+++ b/julia-makefile.patch
@@ -1,14 +1,19 @@
---- Makefile.orig 2017-10-28 17:06:53.003582943 +0000
-+++ Makefile 2017-10-28 17:07:27.690408154 +0000
-@@ -316,8 +316,9 @@
- $(build_depsbindir)/stringreplace $$(strings -t x - $1 | grep '$2' | awk '{print $$1;}') '$3' 255 "$(call cygpath_w,$1)"
- endef
+--- Makefile.orig
++++ Makefile
+@@ -269,12 +269,9 @@
+ endif
+
-install: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html
+-ifeq ($(BUNDLE_DEBUG_LIBS),1)
- @$(MAKE) $(QUIET_MAKE) all
+-else
+- @$(MAKE) $(QUIET_MAKE) release
+-endif
+docsindex: $(build_depsbindir)/stringreplace $(BUILDROOT)/doc/_build/html/en/index.html
+
+install:
@for subdir in $(bindir) $(datarootdir)/julia/stdlib/$(VERSDIR) $(docdir) $(man1dir) $(includedir)/julia $(libdir) $(private_libdir) $(sysconfdir); do \
mkdir -p $(DESTDIR)$$subdir; \
done
+