summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2016-08-12 13:31:21 +0200
committerNarrat2016-08-12 14:02:36 +0200
commitc7873cc949d5734e56c18832e6fcdb2d43ded539 (patch)
tree236204cdda40613c4644eac7cec2ed97246c76c1
parentc5860f1a2df504660403507587322b93215497ba (diff)
downloadaur-c7873cc949d5734e56c18832e6fcdb2d43ded539.tar.gz
Julia: Some new deps
Currently the build were failing, because some new deps got included, and the default was used: Don't use the system ones. Building the new deps required cmake as a makedep. The new deps are: * curl: a dep of pacman, which is a base package, so satisfied * libssh2: Already satisfied due to curl and libgit2 * mbedtls: A new dep Another build failure that occured was because of missing deps. Apparantly the depends lines from the package functions aren't checked, so the vast makedepends is needed (And I really thought it changed, but well.. Dunno why I thought that)
-rw-r--r--.SRCINFO24
-rw-r--r--Make.user3
-rw-r--r--PKGBUILD5
3 files changed, 27 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef9092c68b9b..b3b1bfa0ad3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun May 15 16:54:32 UTC 2016
+# Fri Aug 12 12:02:35 UTC 2016
pkgbase = julia-git
pkgdesc = High-level, high-performance, dynamic programming language
- pkgver = 0.5.0.dev.r31095.gd4328ba
+ pkgver = 0.6.0.dev.r33111.g5838a12
pkgrel = 1
url = http://julialang.org
arch = i686
@@ -10,11 +10,28 @@ pkgbase = julia-git
license = MIT
makedepends = gcc-fortran
makedepends = git
+ makedepends = arpack
+ makedepends = fftw
+ makedepends = gmp
+ makedepends = libgit2
+ makedepends = libunwind
+ makedepends = llvm
+ makedepends = mbedtls
+ makedepends = mpfr
+ makedepends = openlibm
+ makedepends = openspecfun
+ makedepends = pcre2
+ makedepends = suitesparse
+ makedepends = patchelf
+ makedepends = hicolor-icon-theme
+ makedepends = xdg-utils
+ makedepends = desktop-file-utils
+ makedepends = gtk-update-icon-cache
options = !emptydirs
source = git://github.com/JuliaLang/julia.git#branch=master
source = Make.user
md5sums = SKIP
- md5sums = e6ed32e3fa745f640489e6f19ab5c7e8
+ md5sums = 521b7fea33a99adc534eefa04c33578d
pkgname = julia-git
depends = arpack
@@ -23,6 +40,7 @@ pkgname = julia-git
depends = libgit2
depends = libunwind
depends = llvm
+ depends = mbedtls
depends = mpfr
depends = openlibm
depends = openspecfun
diff --git a/Make.user b/Make.user
index 6c42a3f7e413..8ea2ccf0e41f 100644
--- a/Make.user
+++ b/Make.user
@@ -15,6 +15,9 @@ USE_SYSTEM_ARPACK:=1
USE_SYSTEM_SUITESPARSE:=1
USE_SYSTEM_LIBUV:=0
USE_SYSTEM_UTF8PROC:=0
+USE_SYSTEM_MBEDTLS:=1
+USE_SYSTEM_LIBSSH2:=1
+USE_SYSTEM_CURL:=1
USE_SYSTEM_LIBGIT2:=1
USE_SYSTEM_PATCHELF:=1
USE_INTEL_MKL:=0
diff --git a/PKGBUILD b/PKGBUILD
index e3fc3f44256d..13d61b1ddda8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,14 @@
_pkgbase=julia
pkgbase=${_pkgbase}-git
pkgname=('julia-git' 'julia-git-docs')
-pkgver=0.5.0.dev.r31095.gd4328ba
+pkgver=0.6.0.dev.r33111.g5838a12
pkgrel=1
pkgdesc='High-level, high-performance, dynamic programming language'
arch=('i686' 'x86_64')
url="http://julialang.org"
license=('MIT')
makedepends=('gcc-fortran' 'git')
+makedepends+=('arpack' 'fftw' 'gmp' 'libgit2' 'libunwind' 'llvm' 'mbedtls' 'mpfr' 'openlibm' 'openspecfun' 'pcre2' 'suitesparse' 'patchelf' 'hicolor-icon-theme' 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'utf8proc' (AUR) 'intel-mkl' (AUR)
# Needed if building the documentation
#makedepends+=('juliadoc-git' 'texlive-langcjk' 'texlive-latexextra')
options=('!emptydirs')
@@ -58,7 +59,7 @@ build() {
package_julia-git() {
backup=('etc/ld.so.conf.d/julia.conf' 'etc/julia/juliarc.jl')
- depends=('arpack' 'fftw' 'gmp' 'libgit2' 'libunwind' 'llvm' 'mpfr' 'openlibm' 'openspecfun' 'pcre2' 'suitesparse' 'patchelf' 'hicolor-icon-theme' 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'utf8proc' (AUR) 'intel-mkl' (AUR)
+ depends=('arpack' 'fftw' 'gmp' 'libgit2' 'libunwind' 'llvm' 'mbedtls' 'mpfr' 'openlibm' 'openspecfun' 'pcre2' 'suitesparse' 'patchelf' 'hicolor-icon-theme' 'xdg-utils' 'desktop-file-utils' 'gtk-update-icon-cache') # 'utf8proc' (AUR) 'intel-mkl' (AUR)
optdepends=('gnuplot: If using the Gaston Package from julia')
provides=('julia')
conflicts=('julia')