summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCan Celasun2015-06-08 13:35:15 +0300
committerCan Celasun2015-06-08 13:35:15 +0300
commit60561b52b95da4bbc4b76401cf2070d3c50bf6fc (patch)
tree6ceae271ef648480358ada97e661d9134d032deb
downloadaur-60561b52b95da4bbc4b76401cf2070d3c50bf6fc.tar.gz
Initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD39
-rw-r--r--dischan_JunipersKnot.desktop9
-rw-r--r--junipersknot2
-rw-r--r--junipersknot.pngbin0 -> 80298 bytes
-rw-r--r--python2.patch9
6 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7ee35d23c683
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = junipersknot
+ pkgdesc = A short kinetic novel crafted in a month by Dischan, Juniper's Knot is a story told from dual perspectives: that of a demon and a boy.
+ pkgver = 1.0
+ pkgrel = 4
+ url = http://junipersknot.dischan.org/
+ arch = any
+ license = custom
+ depends = renpy
+ options = !strip
+ source = JunipersKnot_en_1.0_lin.tar.bz2::https://dischan.org/store/download.php?fileID=14
+ source = dischan_JunipersKnot.desktop
+ source = python2.patch
+ source = junipersknot
+ source = junipersknot.png
+ md5sums = 3318de6e4c5952271961d757bdd5fddf
+ md5sums = 672677a075b4ed04f4a3ca71f6c33808
+ md5sums = d00783636657a37728c48b8ce295cc93
+ md5sums = 6b294591761f99d780a8e4d64848aba2
+ md5sums = 4c498a2152c46fbe993711eaeb91f48e
+
+pkgname = junipersknot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b377c2aff926
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: D. Can Celasun <dcelasun[at]gmail[dot]com>
+# Contributor: AlexanderR <alexander r at gmx com>
+
+pkgname=junipersknot
+pkgver=1.0
+pkgrel=4
+pkgdesc="A short kinetic novel crafted in a month by Dischan, Juniper's Knot is a story told from dual perspectives: that of a demon and a boy."
+arch=('any')
+url="http://junipersknot.dischan.org/"
+license=('custom')
+depends=('renpy')
+options=(!strip)
+source=("JunipersKnot_en_1.0_lin.tar.bz2::https://dischan.org/store/download.php?fileID=14"
+ dischan_JunipersKnot.desktop
+ python2.patch
+ junipersknot
+ junipersknot.png)
+md5sums=('3318de6e4c5952271961d757bdd5fddf'
+ '672677a075b4ed04f4a3ca71f6c33808'
+ 'd00783636657a37728c48b8ce295cc93'
+ '6b294591761f99d780a8e4d64848aba2'
+ '4c498a2152c46fbe993711eaeb91f48e')
+
+build() {
+ cd "$srcdir/Juniper's Knot-linux-x86"
+ patch -Np1 -i "$srcdir/python2.patch"
+}
+
+package() {
+ cd "$srcdir/Juniper's Knot-linux-x86"
+ install -d "$pkgdir/usr/share/doc/$pkgname"
+ install -m644 README.txt SOUNDCREDITS.txt "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm755 "$srcdir"/${pkgname} "$pkgdir/usr/bin/${pkgname}"
+ install -Dm644 "Juniper's Knot.py" "$pkgdir/usr/share/$pkgname/Juniper's Knot.py"
+ install -Dm644 DISCHANLICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/DISCHANLICENSE.txt"
+ install -Dm644 "$srcdir/junipersknot.png" "$pkgdir/usr/share/pixmaps/junipersknot.png"
+ install -Dm644 "$srcdir/dischan_JunipersKnot.desktop" "$pkgdir/usr/share/applications/dischan_JunipersKnot.desktop"
+ cp -r game/* "$pkgdir/usr/share/$pkgname"
+}
diff --git a/dischan_JunipersKnot.desktop b/dischan_JunipersKnot.desktop
new file mode 100644
index 000000000000..dc7e80e5cc6f
--- /dev/null
+++ b/dischan_JunipersKnot.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1
+Name=Juniper's Knot
+Comment=A short kinetic novel crafted in a month by Dischan, Juniper's Knot is a story told from dual perspectives: that of a demon and a boy.
+Icon=junipersknot
+Exec=/usr/bin/junipersknot
+Terminal=false
+Categories=Application;Game;
diff --git a/junipersknot b/junipersknot
new file mode 100644
index 000000000000..c8f73af8859f
--- /dev/null
+++ b/junipersknot
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec env RENPY_BASE=${RENPY_BASE:-/usr/share/renpy/} python2 -OO "/usr/share/junipersknot/Juniper's Knot.py" /usr/share/junipersknot "$@"
diff --git a/junipersknot.png b/junipersknot.png
new file mode 100644
index 000000000000..323a37426483
--- /dev/null
+++ b/junipersknot.png
Binary files differ
diff --git a/python2.patch b/python2.patch
new file mode 100644
index 000000000000..4c9dd5e719bf
--- /dev/null
+++ b/python2.patch
@@ -0,0 +1,9 @@
+diff -daur Juniper's Knot-linux-x86.orig/Juniper's Knot.py Juniper's Knot-linux-x86/Juniper's Knot.py
+--- Juniper's Knot-linux-x86.orig/Juniper's Knot.py 2012-11-04 23:49:20.813299813 +1100
++++ Juniper's Knot-linux-x86/Juniper's Knot.py 2012-11-04 23:49:44.653170548 +1100
+@@ -1,4 +1,4 @@
+-#!/usr/bin/env python
++#!/usr/bin/env python2
+ #@PydevCodeAnalysisIgnore
+ # Copyright 2004-2012 Tom Rothamel <pytom@bishoujo.us>
+ #