summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2023-07-12 23:51:51 +0100
committergetzze2023-07-12 23:51:51 +0100
commitcc1d8f06a91f47bea0899bad514e09353174a0fb (patch)
treec5a9977da81689090ce6b189ea98986df6193d77
parent3b36cecfa4e509f27eb859f63acb64b150f14a45 (diff)
downloadaur-jupyter_contrib_nbextensions.tar.gz
bump 0.7.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD67
2 files changed, 43 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c7c86e1b67b9..5496af4c652a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = jupyter_contrib_nbextensions
pkgdesc = A collection of Jupyter nbextensions
- pkgver = 0.5.1
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/ipython-contrib/jupyter_contrib_nbextensions
install = jupyter_contrib_nbextensions.install
@@ -15,18 +15,16 @@ pkgbase = jupyter_contrib_nbextensions
depends = python-psutil
depends = jupyter-notebook
depends = jupyter-nbconvert
- depends = jupyter_contrib_core>=0.3.3
- depends = jupyter_nbextensions_configurator>=0.4.0
- depends = jupyter_highlight_selected_word>=0.1.0
- depends = jupyter_latex_envs>=1.4.0
+ depends = jupyter_contrib_core
+ depends = jupyter_nbextensions_configurator
+ depends = jupyter_highlight_selected_word
conflicts = jupyter-nbextensions
conflicts = python-jupyter-nbextensions
replaces = jupyter-nbextensions-git
replaces = jupyter-nbextensions
- noextract = jupyter_contrib_nbextensions-0.5.1-py2.py3-none-any.whl
- source = jupyter_contrib_nbextensions-0.5.1-py2.py3-none-any.whl::https://files.pythonhosted.org/packages/py2.py3/j/jupyter_contrib_nbextensions/jupyter_contrib_nbextensions-0.5.1-py2.py3-none-any.whl
+ source = jupyter_contrib_nbextensions-0.7.0.tar.gz::https://pypi.io/packages/source/j/jupyter_contrib_nbextensions/jupyter_contrib_nbextensions-0.7.0.tar.gz
source = jupyter_contrib_nbextensions.install
- sha256sums = 2c071f0aa208c569666f656bdc0f66906ca493cf9f06f46db6350db11030ff40
+ sha256sums = 06e33f005885eb92f89cbe82711e921278201298d08ab0d886d1ba09e8c3e9ca
sha256sums = d141d36609422748b0b22b6c432f223bfc92d72359bbccaf709690f7de313e35
pkgname = jupyter_contrib_nbextensions
diff --git a/PKGBUILD b/PKGBUILD
index 3170b619d545..54a08c8ebed4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
+# Maintainer: getzze <getzze [at] @gmail [dot] com>
# Maintainer: Maziar Saleh Ziabari <helasraizam@gmail.com>
# Contributor: Philipp A. <flying-sheep@web.de>
+
pkgname=jupyter_contrib_nbextensions
-pkgver=0.5.1
+pkgver=0.7.0
pkgrel=1
pkgdesc='A collection of Jupyter nbextensions'
arch=(any)
@@ -16,39 +18,44 @@ depends=(
python-psutil
jupyter-notebook
jupyter-nbconvert
- 'jupyter_contrib_core>=0.3.3'
- 'jupyter_nbextensions_configurator>=0.4.0'
- 'jupyter_highlight_selected_word>=0.1.0'
- 'jupyter_latex_envs>=1.4.0'
+ jupyter_contrib_core
+ jupyter_nbextensions_configurator
+ jupyter_highlight_selected_word
)
makedepends=(python-pip mariadb jq)
-_wheel="$pkgname-$pkgver-py2.py3-none-any.whl"
-source=("$_wheel::https://files.pythonhosted.org/packages/py2.py3/${pkgname::1}/$pkgname/$_wheel" "$pkgname.install")
-sha256sums=('2c071f0aa208c569666f656bdc0f66906ca493cf9f06f46db6350db11030ff40'
+_file="$pkgname-$pkgver.tar.gz"
+source=("$_file::https://pypi.io/packages/source/${pkgname::1}/$pkgname/$_file"
+ "$pkgname.install")
+sha256sums=('06e33f005885eb92f89cbe82711e921278201298d08ab0d886d1ba09e8c3e9ca'
'd141d36609422748b0b22b6c432f223bfc92d72359bbccaf709690f7de313e35')
-noextract=("$_wheel")
install="$pkgname.install"
package() {
- local _python3="$(readlink /usr/bin/python3)"
- local _site_packages="$pkgdir/usr/lib/$_python3/site-packages"
-
- msg2 'installing python package'
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
-
- msg2 'installing extensions'
- #--user uses JUPYTER_CONFIG_DIR
- env \
- PATH="$pkgdir/usr/bin:$PATH" \
- PYTHONPATH="$_site_packages:$PYTHONPATH" \
- JUPYTER_DATA_DIR="$pkgdir/usr/share/jupyter" \
- JUPYTER_CONFIG_DIR="$pkgdir/etc/jupyter" \
- jupyter contrib nbextension install --user
-
- #--fixed-strings --recursive --files-with-matches
- for file in $(grep -Frl "$pkgdir" "$pkgdir/etc"); do
- replace "$pkgdir/" '' -- $file
- done
-
- rm "$pkgdir/etc/jupyter/jupyter_notebook_config.json"
+ local _python3="$(readlink /usr/bin/python3)"
+ local _site_packages="${pkgdi}r/usr/lib/$_python3/site-packages"
+
+ msg2 'installing python package'
+ pip install \
+ --compile --no-deps \
+ --ignore-installed --no-warn-script-location \
+ --root="$pkgdir" "$_file"
+
+ msg2 'installing extensions'
+ #--user uses JUPYTER_CONFIG_DIR
+ env \
+ PATH="$pkgdir/usr/bin:$PATH" \
+ PYTHONPATH="$_site_packages:$PYTHONPATH" \
+ JUPYTER_DATA_DIR="$pkgdir/usr/share/jupyter" \
+ JUPYTER_CONFIG_DIR="$pkgdir/etc/jupyter" \
+ jupyter contrib nbextension install --user
+
+ #--fixed-strings --recursive --files-with-matches
+ for file in $(grep -Frl "$pkgdir" "$pkgdir/etc"); do
+ replace "$pkgdir/" '' -- $file
+ done
+
+ rm "$pkgdir/etc/jupyter/jupyter_notebook_config.json"
+
+ # clean pycache
+ find ${pkgdir} -regex '^.*\(__pycache__\|\.py[co]\)$' -delete
}