summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjp19952020-02-10 13:13:09 +0200
committerjp19952020-02-10 13:13:09 +0200
commit2325bdaf0e0cb9bc693753de68bbbf96be9af1b4 (patch)
treeea7fe7e173764d4988098272775048895740add5
downloadaur-2325bdaf0e0cb9bc693753de68bbbf96be9af1b4.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77aaafecec36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = kappa-launcher
+ pkgdesc = Twitch launcher using rofi
+ pkgver = r35.8e6c834
+ pkgrel = 1
+ url = https://github.com/jp1995/kappa-launcher
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = rofi
+ depends = jq
+ depends = streamlink
+ optdepends = chatterino: chat client
+ optdepends = chatty: alternative chat client
+ optdepends = xdg-utils: browser function
+ source = git://github.com/jp1995/kappa-launcher.git
+ sha1sums = SKIP
+
+pkgname = kappa-launcher
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d5ad36ab6305
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+ # Maintainer: poncho
+pkgname=kappa-launcher
+pkgver=r35.8e6c834
+pkgrel=1
+pkgdesc="Twitch launcher using rofi"
+arch=('any')
+url="https://github.com/jp1995/kappa-launcher"
+license=('MIT')
+provides=($_pkgname)
+conflicts=($_pkgname)
+depends=(
+ 'rofi'
+ 'jq'
+ 'streamlink'
+ )
+optdepends=(
+ 'chatterino: chat client'
+ 'chatty: alternative chat client'
+ 'xdg-utils: browser function'
+)
+makedepends=('git')
+source=("git://github.com/jp1995/kappa-launcher.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/$pkgname
+ install -d $pkgdir/usr/bin
+ install -m755 kpl $pkgdir/usr/bin
+}