summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon2021-04-25 16:23:56 +0200
committerLeon2021-04-25 16:23:56 +0200
commitcd2b552476eed49364a9d45ed4842b47754f5e18 (patch)
treefa9dfc322070f5d52be206c62b3acdbc878650c6
parente993e729a8fa942ecf5b970f0d1372faf10d3daa (diff)
downloadaur-cd2b552476eed49364a9d45ed4842b47754f5e18.tar.gz
Update to 5.x - Change to Electron 11
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rwxr-xr-xinstall.sh1
3 files changed, 12 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97344b069099..de9a56054fde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = karaokemugen-git
pkgdesc = Karaoke playlist manager/player app used in parties or events.
- pkgver = 4.1.10.r1080.g414ec54e8
+ pkgver = 5.0.33.r1.g3c91037ef
pkgrel = 1
url = https://mugen.karaokes.moe/
install = karaokemugen.install
- arch = any
+ arch = x86_64
license = MIT
makedepends = git
makedepends = npm
@@ -15,7 +15,7 @@ pkgbase = karaokemugen-git
depends = mpv
depends = ffmpeg
depends = postgresql
- depends = electron
+ depends = electron11
optdepends = sudo: for using karaokemugen-install script
provides = karaokemugen
conflicts = karaokemugen
@@ -29,7 +29,7 @@ pkgbase = karaokemugen-git
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 412f93c38e0d79eb2d98cce3afd2a194
+ md5sums = e505996fcb8200002be4df3021666d85
md5sums = 0d0d432f35c56a962f9d386f391c6036
md5sums = 5e9a33a42fef7572b7e0fa504c586f32
md5sums = 10561eed906a5efeed427f90501b4f49
diff --git a/PKGBUILD b/PKGBUILD
index 9eb53233ce71..48bcf6e177a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: leonekmi <usingarchbtw@leonekmi.fr>
pkgname=karaokemugen-git
-pkgver=4.1.10.r1080.g414ec54e8
+pkgver=5.0.33.r1.g3c91037ef
pkgrel=1
pkgdesc="Karaoke playlist manager/player app used in parties or events."
-arch=('any')
+arch=('x86_64')
url="https://mugen.karaokes.moe/"
license=('MIT')
groups=()
-depends=('mpv' 'ffmpeg' 'postgresql' 'electron') # Warning : to be replaced with electron11 when Electron 12 will be pushed to [community]
+depends=('mpv' 'ffmpeg' 'postgresql' 'electron11')
makedepends=('git' 'npm' 'typescript' 'yarn' 'nodejs>=12' 'python2')
optdepends=('sudo: for using karaokemugen-install script')
provides=("${pkgname%-git}")
@@ -27,7 +27,7 @@ noextract=()
md5sums=('SKIP'
'SKIP'
'SKIP'
- '412f93c38e0d79eb2d98cce3afd2a194'
+ 'e505996fcb8200002be4df3021666d85'
'0d0d432f35c56a962f9d386f391c6036'
'5e9a33a42fef7572b7e0fa504c586f32'
'10561eed906a5efeed427f90501b4f49')
@@ -57,16 +57,15 @@ build() {
export XDG_CACHE_HOME="$srcdir/$pkgname-cache"
export npm_config_devdir="$srcdir/$pkgname-npm-dev"
export npm_config_cache="$srcdir/$pkgname-npm-cache"
- yarn global add electron-builder
- yarn install
+ yarn install --ignore-scripts --frozen-scripts
+ yarn add --dev electron-builder
yarn installkmfrontend
# Build and package with electron-builder
export NODE_ENV='production'
- electronDist=$(dirname $(realpath $(which electron)))
electronVer=$(electron --version | tail -c +2)
yarn build
yarn buildkmfrontend
- "$(yarn global dir)/node_modules/.bin/electron-builder" --linux --x64 -c.electronDist=$electronDist -c.electronVersion=$electronVer --dir
+ yarn electron-builder --linux --x64 -c.electronDist=/usr/lib/electron11 -c.electronVersion=$electronVer --dir
}
package() {
@@ -75,8 +74,6 @@ package() {
# Application itself
install -dm755 "$pkgdir/usr/lib/${pkgname%-git}"
cp -dr --no-preserve=ownership packages/linux-unpacked/resources/* "$pkgdir/usr/lib/${pkgname%-git}/"
- install -dm 755 "$pkgdir/usr/lib/${pkgname%-git}/asar"
- mv "$pkgdir/usr/lib/${pkgname%-git}/app.asar" "$pkgdir/usr/lib/${pkgname%-git}/asar"
chmod -R 755 "$pkgdir/usr/lib/${pkgname%-git}/"
# License
diff --git a/install.sh b/install.sh
index f0266b28d7e0..2309b5acac04 100755
--- a/install.sh
+++ b/install.sh
@@ -53,6 +53,7 @@ setup_postgres() {
sudo -u postgres -g postgres -H -- psql -c "CREATE DATABASE karaokemugen_app ENCODING 'UTF8';"
sudo -u postgres -g postgres -H -- psql -c "CREATE USER karaokemugen_app WITH ENCRYPTED PASSWORD 'musubi'; GRANT ALL PRIVILEGES ON DATABASE karaokemugen_app TO karaokemugen_app;"
sudo -u postgres -g postgres -H -- psql -d karaokemugen_app -c "CREATE EXTENSION unaccent;"
+ sudo -u postgres -g postgres -H -- psql -d karaokemugen_app -c "CREATE EXTENSION pgcrypto;"
echo -e "${_COL_GREEN_}karaokemugen_app database created!"
}