summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon2021-03-28 12:32:42 +0200
committerLeon2021-03-28 12:32:42 +0200
commite993e729a8fa942ecf5b970f0d1372faf10d3daa (patch)
tree89409c7396e3c54fdb3ebdc853c995b6f04599ef
parentee66198dd753a44317ecbfec81cf90909195d606 (diff)
downloadaur-e993e729a8fa942ecf5b970f0d1372faf10d3daa.tar.gz
Update to 5.x
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
-rwxr-xr-xinstall.sh23
3 files changed, 17 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3ae8d103291..97344b069099 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = karaokemugen-git
pkgdesc = Karaoke playlist manager/player app used in parties or events.
- pkgver = 3.2.2.r1.g029d4a0f
- pkgrel = 2
+ pkgver = 4.1.10.r1080.g414ec54e8
+ pkgrel = 1
url = https://mugen.karaokes.moe/
install = karaokemugen.install
arch = any
@@ -21,13 +21,15 @@ pkgbase = karaokemugen-git
conflicts = karaokemugen
source = karaokemugen::git+https://lab.shelter.moe/karaokemugen/karaokemugen-app.git
source = karaokemugen-lib::git+https://lab.shelter.moe/karaokemugen/lib.git
+ source = karaokemugen-avatars::git+https://lab.shelter.moe/karaokemugen/medias/guest-avatars.git
source = install.sh
source = run.sh
source = icon256.png
source = karaokemugen.desktop
md5sums = SKIP
md5sums = SKIP
- md5sums = 4ad5390b139dc5b5e78e6eef8411e90b
+ md5sums = SKIP
+ md5sums = 412f93c38e0d79eb2d98cce3afd2a194
md5sums = 0d0d432f35c56a962f9d386f391c6036
md5sums = 5e9a33a42fef7572b7e0fa504c586f32
md5sums = 10561eed906a5efeed427f90501b4f49
diff --git a/PKGBUILD b/PKGBUILD
index 77075c388f42..9eb53233ce71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: leonekmi <usingarchbtw@leonekmi.fr>
pkgname=karaokemugen-git
-pkgver=3.2.2.r1.g029d4a0f
-pkgrel=2
+pkgver=4.1.10.r1080.g414ec54e8
+pkgrel=1
pkgdesc="Karaoke playlist manager/player app used in parties or events."
arch=('any')
url="https://mugen.karaokes.moe/"
license=('MIT')
groups=()
-depends=('mpv' 'ffmpeg' 'postgresql' 'electron') # Warning : to be replaced with electron8 when Electron 9 will be pushed to [community]
+depends=('mpv' 'ffmpeg' 'postgresql' 'electron') # Warning : to be replaced with electron11 when Electron 12 will be pushed to [community]
makedepends=('git' 'npm' 'typescript' 'yarn' 'nodejs>=12' 'python2')
optdepends=('sudo: for using karaokemugen-install script')
provides=("${pkgname%-git}")
@@ -18,6 +18,7 @@ options=()
install=${pkgname%-git}.install
source=('karaokemugen::git+https://lab.shelter.moe/karaokemugen/karaokemugen-app.git'
'karaokemugen-lib::git+https://lab.shelter.moe/karaokemugen/lib.git'
+ 'karaokemugen-avatars::git+https://lab.shelter.moe/karaokemugen/medias/guest-avatars.git'
'install.sh'
'run.sh'
'icon256.png'
@@ -25,7 +26,8 @@ source=('karaokemugen::git+https://lab.shelter.moe/karaokemugen/karaokemugen-app
noextract=()
md5sums=('SKIP'
'SKIP'
- '4ad5390b139dc5b5e78e6eef8411e90b'
+ 'SKIP'
+ '412f93c38e0d79eb2d98cce3afd2a194'
'0d0d432f35c56a962f9d386f391c6036'
'5e9a33a42fef7572b7e0fa504c586f32'
'10561eed906a5efeed427f90501b4f49')
@@ -43,6 +45,7 @@ prepare() {
cd "$srcdir/${pkgname%-git}"
git submodule init
git config submodule.src/lib.url $srcdir/${pkgname%-git}-lib
+ git config submodule.assets/guestAvatars.url $srcdir/${pkgname%-git}-avatars
git submodule update
}
@@ -56,15 +59,13 @@ build() {
export npm_config_cache="$srcdir/$pkgname-npm-cache"
yarn global add electron-builder
yarn install
- yarn installFrontend
- yarn installSystemPanel
+ yarn installkmfrontend
# Build and package with electron-builder
export NODE_ENV='production'
electronDist=$(dirname $(realpath $(which electron)))
electronVer=$(electron --version | tail -c +2)
yarn build
- yarn buildFrontend
- yarn buildSystemPanel
+ yarn buildkmfrontend
"$(yarn global dir)/node_modules/.bin/electron-builder" --linux --x64 -c.electronDist=$electronDist -c.electronVersion=$electronVer --dir
}
diff --git a/install.sh b/install.sh
index 03dd52470cd1..f0266b28d7e0 100755
--- a/install.sh
+++ b/install.sh
@@ -27,10 +27,10 @@ check_postgres() {
}
check_mugen() {
- if [ -f "/opt/karaokemugen/karaokemugen" ]; then
- echo -e "${_COL_GREEN_}Karaoke Mugen is installed in /opt/karaokemugen."
+ if [ -f "/usr/lib/karaokemugen/asar/app.asar" ]; then
+ echo -e "${_COL_GREEN_}Karaoke Mugen is installed in /usr/lib/karaokemugen."
else
- echo -e "${_COL_BRED_}Karaoke Mugen is not installed in /opt/karaokemugen. Exiting."
+ echo -e "${_COL_BRED_}Karaoke Mugen is not installed in /usr/lib/karaokemugen. Exiting."
exit 1
fi
}
@@ -68,23 +68,6 @@ if [[ $(which tput > /dev/null 2>&1 && tput -T "${TERM}" colors || echo -n '0')
_BEGIN_="${_COL_BRED_}-> ${_COL_BBLUE_}"
fi
-while getopts ":g" opt; do
- case ${opt} in
- g )
- #target=$OPTARG
- echo -e "${_COL_YELLOW_}You may have to enter your sudo password"
- add_user_to_group
- echo -e "${_BEGIN_}Done! You need to restart your session to apply these changes."
- exit 0
- ;;
- \? )
- echo "Invalid option: $OPTARG" 1>&2
- exit 1
- ;;
- esac
-done
-shift $((OPTIND -1))
-
echo -e "${_BEGIN_}Welcome to the Karaoke Mugen installer!"
echo -e "${_COL_YELLOW_}⚠️ You may have to enter your sudo password a couple times during this installation."
echo -e "${_COL_YELLOW_}This script may not work if you tweaked your PostgreSQL configuration."