summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNafis2022-07-06 16:33:21 +0600
committerNafis2022-07-06 16:33:21 +0600
commitca3afdc5422236e3a8f8d23b758d6cff2d7a6968 (patch)
tree307cd02f832c2ba4d7b9c79b955ea0d3e276573b
parent958cc18b0f99d49ae960e5b65116ac4a17010eb5 (diff)
downloadaur-ca3afdc5422236e3a8f8d23b758d6cff2d7a6968.tar.gz
Update to 22.04.2
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Defuse-root-block.patch28
-rw-r--r--PKGBUILD10
3 files changed, 27 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90ec8f949de5..3417889fc9b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = kate-root
- pkgver = 21.12.1
+ pkgver = 22.04.2
pkgrel = 1
arch = x86_64
arch = i686
@@ -15,15 +15,15 @@ pkgbase = kate-root
makedepends = ktexteditor
makedepends = kactivities
makedepends = kuserfeedback
- source = https://download.kde.org/stable/release-service/21.12.1/src/kate-21.12.1.tar.xz
- source = https://download.kde.org/stable/release-service/21.12.1/src/kate-21.12.1.tar.xz.sig
+ source = https://download.kde.org/stable/release-service/22.04.2/src/kate-22.04.2.tar.xz
+ source = https://download.kde.org/stable/release-service/22.04.2/src/kate-22.04.2.tar.xz.sig
source = 0001-Defuse-root-block.patch
validpgpkeys = CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7
validpgpkeys = F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87
validpgpkeys = D81C0CB38EB725EF6691C385BB463350D6EF31EF
- sha256sums = 7e48ccfdb58a41252566b5d6f263db16d6c88af60e2a15aef305bc0fa305a011
+ sha256sums = 7cfec8b6391d89914aa73ead3902fdafab92f73368e0e26743cd4aab1ef117de
sha256sums = SKIP
- sha256sums = 6d61580de90efa53eb52077353097d66fb823965c0a70176a47bf5524603aa57
+ sha256sums = 7ab717cd37161ba790a72e3871281a1268e6ce07e7900825738b5d690de96f77
pkgname = kwrite-root
pkgdesc = Text Editor, patched to be able to run as root
@@ -51,5 +51,7 @@ pkgname = kate-root
optdepends = texlab: LaTeX LSP support
optdepends = rust: Rust LSP support
optdepends = git: git-blame plugin
+ optdepends = markdownpart: Markdown preview
+ optdepends = svgpart: SVG preview
provides = kate
conflicts = kate
diff --git a/0001-Defuse-root-block.patch b/0001-Defuse-root-block.patch
index 7d57d02c86f4..8a65b66064bd 100644
--- a/0001-Defuse-root-block.patch
+++ b/0001-Defuse-root-block.patch
@@ -16,7 +16,7 @@ Index: kate/main.cpp
===================================================================
--- a/kate/main.cpp 2018-12-25 09:49:15.867478873 +0100
+++ b/kate/main.cpp 2018-12-25 09:49:19.231424088 +0100
-@@ -46,21 +46,10 @@
+@@ -47,21 +47,10 @@
int main(int argc, char **argv)
{
#if !defined(Q_OS_WIN) && !defined(Q_OS_HAIKU)
@@ -24,15 +24,15 @@ Index: kate/main.cpp
+ // Allow running Kate as root, but with a warning
if (getuid() == 0) {
- if (!qEnvironmentVariableIsEmpty("SUDO_USER")) {
-- std::cout << "Executing Kate with sudo is not possible due to unfixable security vulnerabilities. "
-- "It is also not necessary; simply use Kate normally, and you will be prompted for "
-- "elevated privileges when saving documents if needed."
+- std::cout << "Running Kate with sudo can cause bugs and expose you to security vulnerabilities. "
+- "Instead use Kate normally and you will be prompted for elevated privileges when "
+- "saving documents if needed."
- << std::endl;
- return EXIT_FAILURE;
- } else if (!qEnvironmentVariableIsEmpty("KDESU_USER")) {
-- std::cout << "Executing Kate with kdesu is not possible due to unfixable security vulnerabilities. "
-- "It is also not necessary; simply use Kate normally, and you will be prompted for "
-- "elevated privileges when saving documents if needed."
+- std::cout << "Running Kate with kdesu can cause bugs and expose you to security vulnerabilities. "
+- "Instead use Kate normally and you will be prompted for elevated privileges when "
+- "saving documents if needed."
- << std::endl;
- return EXIT_FAILURE;
- }
@@ -45,7 +45,7 @@ Index: kwrite/main.cpp
===================================================================
--- a/kwrite/main.cpp 2018-12-25 09:49:19.231424088 +0100
+++ b/kwrite/main.cpp 2018-12-25 09:50:32.302253532 +0100
-@@ -38,21 +38,10 @@
+@@ -39,21 +39,10 @@
extern "C" Q_DECL_EXPORT int main(int argc, char **argv)
{
#if !defined(Q_OS_WIN) && !defined(Q_OS_HAIKU)
@@ -53,15 +53,15 @@ Index: kwrite/main.cpp
+ // Allow running KWrite as root, but with a warning
if (getuid() == 0) {
- if (!qEnvironmentVariableIsEmpty("SUDO_USER")) {
-- std::cout << "Executing KWrite with sudo is not possible due to unfixable security vulnerabilities. "
-- "It is also not necessary; simply use KWrite normally, and you will be prompted for "
-- "elevated privileges when saving documents if needed."
+- std::cout << "Running KWrite with sudo can cause bugs and expose you to security vulnerabilities. "
+- "Instead use KWrite normally and you will be prompted for elevated privileges when "
+- "saving documents if needed."
- << std::endl;
- return EXIT_FAILURE;
- } else if (!qEnvironmentVariableIsEmpty("KDESU_USER")) {
-- std::cout << "Executing KWrite with kdesu is not possible due to unfixable security vulnerabilities. "
-- "It is also not necessary; simply use KWrite normally, and you will be prompted for "
-- "elevated privileges when saving documents if needed."
+- std::cout << "Running KWrite with kdesu can cause bugs and expose you to security vulnerabilities. "
+- "Instead use KWrite normally and you will be prompted for elevated privileges when "
+- "saving documents if needed."
- << std::endl;
- return EXIT_FAILURE;
- }
diff --git a/PKGBUILD b/PKGBUILD
index 2504e47999e2..a985fbc6fc81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,16 +7,16 @@
pkgbase=kate-root
_pkgbase=kate
pkgname=(kwrite-root kate-root)
-pkgver=21.12.1
+pkgver=22.04.2
pkgrel=1
arch=(x86_64 i686 armv7h)
license=(GPL LGPL FDL)
makedepends=(extra-cmake-modules kdoctools plasma-framework knewstuff kitemmodels ktexteditor kactivities kuserfeedback)
source=(https://download.kde.org/stable/release-service/$pkgver/src/$_pkgbase-$pkgver.tar.xz{,.sig}
0001-Defuse-root-block.patch)
-sha256sums=('7e48ccfdb58a41252566b5d6f263db16d6c88af60e2a15aef305bc0fa305a011'
+sha256sums=('7cfec8b6391d89914aa73ead3902fdafab92f73368e0e26743cd4aab1ef117de'
'SKIP'
- '6d61580de90efa53eb52077353097d66fb823965c0a70176a47bf5524603aa57')
+ '7ab717cd37161ba790a72e3871281a1268e6ce07e7900825738b5d690de96f77')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
@@ -60,7 +60,9 @@ package_kate-root() {
'python-lsp-server: Python LSP support'
'texlab: LaTeX LSP support'
'rust: Rust LSP support'
- 'git: git-blame plugin')
+ 'git: git-blame plugin'
+ 'markdownpart: Markdown preview'
+ 'svgpart: SVG preview')
provides=('kate')
conflicts=('kate')