summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornasenatmer2015-06-08 18:42:47 +0200
committernasenatmer2015-06-08 18:42:47 +0200
commit8a151655528b7bea5fcb54297c9efa44f3926100 (patch)
treeb4836d20fd8715e9e43c74e75b7a700a893b84cd
downloadaur-kbd-bone.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--kbd-bone.install13
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..099cb16e62bb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kbd-bone
+ pkgdesc = bone terminal keyboard layout
+ pkgver = 1
+ pkgrel = 2
+ url = https://wiki.neo-layout.org/wiki/Bone
+ install = kbd-bone.install
+ arch = any
+ license = CC-BY-SA
+ depends = kbd
+ source = http://home.arcor.de/hellwoofa/bone.map
+ md5sums = 4bce50a9b30dd4e1296aee1784bd7c0c
+
+pkgname = kbd-bone
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c935b7ff966
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jakob H. (nasenatmer at posteo dot de)
+# adapted from Alexander Preisinger (maintainer of kbd-neo AUR package)
+
+pkgname=kbd-bone
+pkgver=1
+pkgrel=2
+pkgdesc="bone terminal keyboard layout"
+arch=('any')
+url="https://wiki.neo-layout.org/wiki/Bone"
+license=('CC-BY-SA')
+depends=('kbd')
+install=$pkgname.install
+source=(http://home.arcor.de/hellwoofa/bone.map)
+md5sums=('4bce50a9b30dd4e1296aee1784bd7c0c')
+
+build() {
+ cd $srcdir
+ gzip -f bone.map
+}
+
+package() {
+ cd $srcdir
+ install -m 664 -D bone.map.gz $pkgdir/usr/share/kbd/keymaps/i386/qwertz/bone.map.gz
+}
diff --git a/kbd-bone.install b/kbd-bone.install
new file mode 100644
index 000000000000..000b80953c45
--- /dev/null
+++ b/kbd-bone.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "In order to use bone in virtual console temporarily, type 'loadkeys bone'."
+
+ echo "In order to set bone as default layout in virtual console, type
+ 'localectl set-keymap --no-convert bone'or edit '/etc/vconsole.conf'
+ directly."
+
+ echo "For more information, please consult the wiki: 'https://wiki.archlinux.org/index.php/Keyboard_configuration_in_console'"
+}
+
+post_upgrade() {
+ post_install $1
+}