summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzan2020-07-23 03:10:20 -0400
committerzan2020-07-23 03:10:20 -0400
commit2fd4983b56c2c1952e931f7c332a7d46da4028d4 (patch)
treeca2eae599760026dd3d74f0a8542755d60ac88e4
parent25c5e3c813e7d2deb6aa1d8662cbcda4031a27ad (diff)
downloadaur-kcm-tablet-git.tar.gz
cmake doesn't need to be git now
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD32
2 files changed, 16 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a24a50f6e35..05ba5fa8faa4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = kcm-tablet-git
pkgdesc = KDE Control Module to manage pen tablets managed by libinput on X or Wayland.
- pkgver = r65.0cc9e4e
+ pkgver = r69.72eea10
pkgrel = 1
url = https://gitlab.com/zanny/kcm-tablet
arch = x86_64
license = GPL3
- makedepends = cmake-git
makedepends = extra-cmake-modules
depends = kdeclarative
depends = kirigami2
optdepends = qt5-x11extras: X11 support
- optdepends = xorg-xinput: X11 support
+ optdepends = xf86-input-libinput: X11 support
source = git+https://gitlab.com/zanny/kcm-tablet.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4cb7aa249fa0..3316e6856977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,30 @@
-# Maintainer: Zan <zan@cock.li>
+# Maintainer: Zan <zan@420blaze.it>
pkgname=kcm-tablet-git
-pkgver=r65.0cc9e4e
+_name=${pkgname%-git}
+pkgver=r69.72eea10
pkgrel=1
pkgdesc='KDE Control Module to manage pen tablets managed by libinput on X or Wayland.'
-arch=('x86_64')
+arch=(x86_64)
url='https://gitlab.com/zanny/kcm-tablet'
-license=('GPL3')
-depends=('kdeclarative' 'kirigami2')
-optdepends=('qt5-x11extras: X11 support' 'xorg-xinput: X11 support')
-makedepends=('cmake-git' 'extra-cmake-modules')
-source=("git+https://gitlab.com/zanny/kcm-tablet.git")
+license=(GPL3)
+depends=(kdeclarative kirigami2)
+optdepends=('qt5-x11extras: X11 support'
+ 'xf86-input-libinput: X11 support')
+makedepends=(extra-cmake-modules)
+source=("git+https://gitlab.com/zanny/$_name.git")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
+ cd $_name
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- mkdir -p build
-}
-
build() {
- cd build
- cmake "../${pkgname%-git}"
- make
+ cmake -B build -S $_name
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --install build
}