summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgeraldwuhoo2023-05-01 17:08:45 -0700
committergeraldwuhoo2023-05-01 17:08:45 -0700
commit4f5c2adbc6f006541d853b9e88487f2227fed1da (patch)
treeb29984c14de3e388ce7409ec01175c858de9d6c5
downloadaur-kcp-bin.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ca67e739449
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = kcp-bin
+ pkgdesc = Kubernetes-like control plane for workloads on many clusters
+ pkgver = 0.11.0
+ pkgrel = 1
+ url = https://github.com/kcp-dev/kcp
+ arch = x86_64
+ license = Apache
+ provides = kcp
+ provides = kubectl-kcp
+ provides = kubectl-workspace
+ provides = kubectl-workspaces
+ provides = kubectl-ws
+ source = kcp-0.11.0-linux-amd64.tar.gz::https://github.com/kcp-dev/kcp/releases/download/v0.11.0/kcp_0.11.0_linux_amd64.tar.gz
+ source = kubectl-kcp-plugin-0.11.0-linux-amd64.tar.gz::https://github.com/kcp-dev/kcp/releases/download/v0.11.0/kubectl-kcp-plugin_0.11.0_linux_amd64.tar.gz
+ sha256sums = 8744f863232b1ea202598e286cd061fad81b181798fb1e6612b46df5b6423524
+ sha256sums = adb2a035015af424a3e2ff9a848a2812354de87a532259947dd77fe49eba2dfe
+
+pkgname = kcp-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c94c9475694
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Gerald Wu <gerald at geraldwu dot com>
+
+pkgname=kcp-bin
+pkgver=0.11.0
+pkgrel=1
+pkgdesc='Kubernetes-like control plane for workloads on many clusters'
+arch=('x86_64')
+url='https://github.com/kcp-dev/kcp'
+license=('Apache')
+source=("kcp-$pkgver-linux-amd64.tar.gz::${url}/releases/download/v${pkgver}/kcp_${pkgver}_linux_amd64.tar.gz"
+ "kubectl-kcp-plugin-$pkgver-linux-amd64.tar.gz::${url}/releases/download/v${pkgver}/kubectl-kcp-plugin_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('8744f863232b1ea202598e286cd061fad81b181798fb1e6612b46df5b6423524'
+ 'adb2a035015af424a3e2ff9a848a2812354de87a532259947dd77fe49eba2dfe')
+provides=('kcp' 'kubectl-kcp' 'kubectl-workspace' 'kubectl-workspaces' 'kubectl-ws')
+
+package() {
+ install -Dm755 "bin/kcp" "$pkgdir/usr/bin/kcp"
+ install -Dm755 "bin/kubectl-kcp" "$pkgdir/usr/bin/kubectl-kcp"
+ install -Dm755 "bin/kubectl-workspace" "$pkgdir/usr/bin/kubectl-workspace"
+ install -Dm755 "bin/kubectl-workspaces" "$pkgdir/usr/bin/kubectl-workspaces"
+ install -Dm755 "bin/kubectl-ws" "$pkgdir/usr/bin/kubectl-ws"
+}
+