summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimone Gaiarin2016-09-07 13:05:48 +0200
committerSimone Gaiarin2016-09-07 13:05:48 +0200
commitf9d860893c6d6749b18a79234523337e62367cba (patch)
tree8fc7956e0b39f9b93257667395a4a2c716400aeb
downloadaur-kdeedu-ktouch-patched.tar.gz
Initial release
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD42
-rw-r--r--nox11.patch17
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd0199df69fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = kdeedu-ktouch-patched
+ pkgdesc = Touch Typing Tutor - Patched to fix bugs #350336, #346248 and #367891, #364011 (disable layout autodetect)
+ pkgver = 16.08.0
+ pkgrel = 1
+ url = http://kde.org/applications/education/ktouch/
+ arch = i686
+ arch = x86_64
+ groups = kde-applications
+ groups = kdeedu
+ license = GPL
+ license = LGPL
+ license = FDL
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = mesa
+ depends = kdebase-runtime
+ depends = kqtquickcharts
+ depends = libxkbfile
+ conflicts = kdeedu-ktouch
+ source = http://download.kde.org/stable/applications/16.08.0/src/ktouch-16.08.0.tar.xz
+ source = fix-lag.patch::https://bugsfiles.kde.org/attachment.cgi?id=93186
+ source = nox11.patch
+ sha1sums = af8c32c33c9e3a5cf017d76497e94514a40d4f65
+ sha1sums = d066e0ee7d0dc95c63afe9469bf6a0a975bf18d2
+ sha1sums = ace197b951d64afa71c3bd8d815e5d1f970a44bc
+
+pkgname = kdeedu-ktouch-patched
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a726c459327
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# $Id$
+# Maintainer: Simone Gaiarin <simgunz@gmail.com>
+# Contributor: Simone Gaiarin <simgunz@gmail.com>
+
+pkgname=kdeedu-ktouch-patched
+pkgver=16.08.0
+pkgrel=1
+pkgdesc="Touch Typing Tutor - Patched to fix bugs #350336, #346248 and #367891, #364011 (disable layout autodetect)"
+url="http://kde.org/applications/education/ktouch/"
+arch=('i686' 'x86_64')
+license=('GPL' 'LGPL' 'FDL')
+groups=('kde-applications' 'kdeedu')
+depends=('kdebase-runtime' 'kqtquickcharts' 'libxkbfile')
+makedepends=('cmake' 'automoc4' 'mesa')
+conflicts=('kdeedu-ktouch')
+source=("http://download.kde.org/stable/applications/${pkgver}/src/ktouch-${pkgver}.tar.xz"
+ 'fix-lag.patch::https://bugsfiles.kde.org/attachment.cgi?id=93186'
+ 'nox11.patch')
+sha1sums=('af8c32c33c9e3a5cf017d76497e94514a40d4f65'
+ 'd066e0ee7d0dc95c63afe9469bf6a0a975bf18d2'
+ 'ace197b951d64afa71c3bd8d815e5d1f970a44bc')
+
+prepare() {
+ mkdir -p build
+ cd ktouch-${pkgver}
+ patch -p1 -i ../fix-lag.patch
+ patch -p0 -i ../nox11.patch
+}
+
+build() {
+ cd build
+ cmake ../ktouch-${pkgver} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DKDE4_BUILD_TESTS=OFF \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}
diff --git a/nox11.patch b/nox11.patch
new file mode 100644
index 000000000000..b9245a63dfc5
--- /dev/null
+++ b/nox11.patch
@@ -0,0 +1,17 @@
+--- src/CMakeLists.txt 2016-09-07 10:54:28.551205779 +0200
++++ src/CMakeLists.txt 2016-09-07 10:54:41.631520079 +0200
+@@ -98,13 +98,7 @@
+ customlessoneditorwidget.cpp
+ )
+
+-if (X11_Xkbfile_FOUND)
+- add_definitions(-DKTOUCH_BUILD_WITH_X11)
+- include_directories(${X11_Xkbfile_INCLUDE_PATH})
+- set(ktouch_SRCS ${ktouch_SRCS} x11_helper.cpp)
+-else (X11_Xkbfile_FOUND)
+- set(ktouch_SRCS ${ktouch_SRCS} keyboardlayoutmenu.cpp)
+-endif (X11_Xkbfile_FOUND)
++set(ktouch_SRCS ${ktouch_SRCS} keyboardlayoutmenu.cpp)
+
+ kde4_add_kcfg_files(ktouch_SRCS preferences.kcfgc )
+