summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoão Figueiredo2023-05-14 21:21:41 +0100
committerJoão Figueiredo2023-05-14 21:21:41 +0100
commit83b370155d546a06bcbb9fe1e26bdd61a6278cc5 (patch)
tree85c0a84e099840e2e39ea53c6d322e28e491c6bc
parent47039b2fcbeb966782101e42b7b71f153a720b7f (diff)
downloadaur-83b370155d546a06bcbb9fe1e26bdd61a6278cc5.tar.gz
Move to Qt6
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD7
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27b9649fe907..a23e64d1a6f8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = kdisplay-git
pkgdesc = App and daemon for display managing by the KWinFT project (kscreen fork)
- pkgver = 5.23.80_r1456.gc03ddcb
+ pkgver = 5.27.80_r1542.gd243e46
pkgrel = 1
url = https://gitlab.com/kwinft/kdisplay
arch = x86_64
license = LGPL
makedepends = git
makedepends = disman-git
- makedepends = extra-cmake-modules
- makedepends = kcmutils
- depends = kcmutils
- depends = kdeclarative
- depends = kirigami2
- depends = ki18n
- depends = plasma-framework
- depends = qt5-graphicaleffects
- depends = qt5-sensors
+ makedepends = extra-cmake-modules-git
+ makedepends = kcmutils-git
+ depends = kcmutils-git
+ depends = kdeclarative-git
+ depends = kirigami2-git
+ depends = ki18n-git
+ depends = plasma-framework-git
+ depends = qt6-sensors
provides = kdisplay
conflicts = kdisplay
source = git+https://gitlab.com/kwinft/kdisplay.git
diff --git a/PKGBUILD b/PKGBUILD
index 72e6f6630e67..e88ec60ca1b9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,14 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=kdisplay-git
-pkgver=5.23.80_r1456.gc03ddcb
+pkgver=5.27.80_r1542.gd243e46
pkgrel=1
pkgdesc="App and daemon for display managing by the KWinFT project (kscreen fork)"
arch=($CARCH)
url="https://gitlab.com/kwinft/kdisplay"
license=(LGPL)
-depends=(kcmutils kdeclarative kirigami2 ki18n plasma-framework qt5-graphicaleffects qt5-sensors)
-makedepends=(git disman-git extra-cmake-modules kcmutils)
+depends=(kcmutils-git kdeclarative-git kirigami2-git ki18n-git plasma-framework-git qt6-sensors)
+makedepends=(git disman-git extra-cmake-modules-git kcmutils-git)
provides=(${pkgname%-git})
conflicts=(${pkgname%-git})
source=("git+https://gitlab.com/kwinft/kdisplay.git")
@@ -25,6 +25,7 @@ pkgver() {
build() {
cmake -B build -S ${pkgname%-git} \
+ -DQT_MAJOR_VERSION=6 \
-DBUILD_TESTING=OFF
cmake --build build
}