aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Rader2023-09-14 12:04:05 -0400
committerDavid Rader2023-09-14 12:04:05 -0400
commit2ed2afea58cdb1107e0d984c6f59b7a2b8b642bf (patch)
tree05d21cd08ca0d054a87326d0f09bccdd95823df9
parentf0705f523a36a36bab4c42f4552405828e6ff7fe (diff)
downloadaur-keepalived-openrc.tar.gz
added Update info and post_upgrade notice
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--README.md24
-rw-r--r--keepalived.install10
4 files changed, 31 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 28a650cf2d6a..5c8a34f8699f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = keepalived-openrc
pkgdesc = keepalived bundled as an openrc based service
pkgver = 2.2.8
- pkgrel = 3
+ pkgrel = 4
url = https://gitlab.com/drad/keepalived
install = keepalived.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index aa585adff863..6aceff44b091 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=keepalived-openrc
_pkgname=keepalived
pkgver="2.2.8"
-pkgrel="3"
+pkgrel="4"
pkgdesc="keepalived bundled as an openrc based service"
arch=("x86_64")
url='https://gitlab.com/drad/keepalived'
diff --git a/README.md b/README.md
index dcc91d88bef7..0926bf632391 100644
--- a/README.md
+++ b/README.md
@@ -13,11 +13,11 @@ pacman -S gcc openssl libnl net-snmp git
```
2. create a build directory and set it up to be owned by the nobody user
```
-mkdir ~/.aur
-chgrp nobody ~/.aur
-chmod g+ws ~/.aur
-setfacl -m u::rwx,g::rwx ~/.aur
-setfacl -d --set u::rwx,g::rwx,o::- ~/.aur
+mkdir /home/build
+chgrp nobody /home/build
+chmod g+ws /home/build
+setfacl -m u::rwx,g::rwx /home/build
+setfacl -d --set u::rwx,g::rwx,o::- /home/build
```
3. Now you can clone and build:
```
@@ -40,6 +40,20 @@ makepkg -sirc
```
+### Update
+
+1. Update & Build
+```
+cd /home/build/keepalived \
+ && git pull \
+ && sudo -u nobody makepkg -c \
+ && ls -lh keepalived*.zst
+```
+2. Install:
+```
+pacman -U keepalived-openrc-{version-arch}.pkg.tar.zst
+```
+
### Remove
Remove with: `pacman -R keepalived-openrc`
diff --git a/keepalived.install b/keepalived.install
index d4befcb83f8b..26a2b686a11d 100644
--- a/keepalived.install
+++ b/keepalived.install
@@ -31,3 +31,13 @@ The init.d script has not been registered nor started.
┗━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━┛
EOF
}
+post_upgrade() {
+cat << EOF
+
+keepalived has been upgraded, do not forget to restart the service
+
+ To restart the service:
+ rc-service keepalived restart
+
+EOF
+}