summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGerad Munsch2015-07-11 23:03:56 -0500
committerGerad Munsch2015-07-11 23:03:56 -0500
commit1015a41696c77cd75fdc0ad171494c174dac5bad (patch)
treeb9d8730c24b5b9a7a0f4ddababbc1d76d76ec2d5
downloadaur-keepass-plugin-keeotp-beta.tar.gz
* keepass-plugin-keeotp-beta: new package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..76da894315d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = keepass-plugin-keeotp-beta
+ pkgdesc = KeePass plugin that generates TOTPs from secrets stored in the KeePass database (ie: Google Authenticator, other RFC 6238 compliant TOTP implementations) (Beta version)
+ pkgver = 1.3.7
+ pkgrel = 1
+ url = https://bitbucket.org/devinmartin/keeotp/wiki/Home
+ arch = any
+ license = MIT
+ depends = keepass
+ provides = keepass-plugin-keeotp
+ conflicts = keepass-plugin-keeotp
+ source = https://bitbucket.org/devinmartin/keeotp/downloads/KeeOtp-1.3.7-Beta.zip
+ sha512sums = 08d84aefb397b2795698317ae7f6fddd006e40cf78a155955f2dc184bef765469671ca7df385f409c85e862803e6b80ce6cb899cdbf5730334c08f4e83bd2a63
+
+pkgname = keepass-plugin-keeotp-beta
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a3aa2478ad7e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Gerad Munsch <gmunsch@unforgivendevelopment.com>
+
+_pkgname=keeotp
+_pkgname2=KeeOtp
+pkgname=keepass-plugin-keeotp-beta
+pkgver=1.3.7
+pkgrel=1
+pkgdesc="KeePass plugin that generates TOTPs from secrets stored in the KeePass database (ie: Google Authenticator, other RFC 6238 compliant TOTP implementations) (Beta version)"
+license=('MIT')
+depends=('keepass')
+provides=('keepass-plugin-keeotp')
+conflicts=('keepass-plugin-keeotp')
+arch=('any')
+url="https://bitbucket.org/devinmartin/keeotp/wiki/Home"
+source=("https://bitbucket.org/devinmartin/keeotp/downloads/${_pkgname2}-${pkgver}-Beta.zip")
+sha512sums=('08d84aefb397b2795698317ae7f6fddd006e40cf78a155955f2dc184bef765469671ca7df385f409c85e862803e6b80ce6cb899cdbf5730334c08f4e83bd2a63')
+
+
+package() {
+ install -Dm644 "${srcdir}"/${_pkgname2}.plgx "${pkgdir}"/usr/share/keepass/plugins/${_pkgname2}.plgx
+ install -Dm644 "${srcdir}"/README.txt "${pkgdir}"/usr/share/keepass/plugins/${_pkgname2}-README.txt
+ install -Dm644 "${srcdir}"/LICENSE.txt "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.txt
+}