summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkvaps2016-07-04 23:53:37 +0300
committerkvaps2016-07-04 23:54:02 +0300
commitfd0fc3c1635df7ee01cb2e09d8b84b4a9a37ed24 (patch)
treec8b78be68f102642cef577253f6adf17a867fbe2
downloadaur-fd0fc3c1635df7ee01cb2e09d8b84b4a9a37ed24.tar.gz
add: wine and dotnetfx install
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD84
-rw-r--r--keepass11
-rw-r--r--keepass-wine.install14
-rw-r--r--keepass.123
-rw-r--r--keepass.desktop12
-rw-r--r--keepass.xml7
7 files changed, 187 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c719a2d49865
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = keepass-wine
+ pkgdesc = A easy-to-use password manager for Windows, Linux, Mac OS X and mobile devices.
+ pkgver = 2.34
+ pkgrel = 1
+ url = http://keepass.info/
+ install = keepass-wine.install
+ arch = any
+ license = GPL
+ makedepends = icoutils
+ makedepends = mono
+ depends = wine
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = shared-mime-info
+ depends = gtk-update-icon-cache
+ optdepends = xdotool: if you want to use auto-type
+ optdepends = xsel: clipboard operations
+ provides = keepass
+ source = http://downloads.sourceforge.net/keepass/KeePass-2.34-Source.zip
+ source = http://keepass.info/integrity/v2/KeePass-2.34-Source.zip.asc
+ source = http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe
+ source = keepass
+ source = keepass.1
+ source = keepass.desktop
+ source = keepass.xml
+ validpgpkeys = C2DAB36D996021CF18B8D4F4158DFACCBE64B2C1
+ sha256sums = e3f184e4deddd1aa5ee2b52e2373c772d3f3975e5eddb2fd729eb27b437011aa
+ sha256sums = SKIP
+ sha256sums = 46693d9b74d12454d117cc61ff2e9481cabb100b4d74eb5367d3cf88b89a0e71
+ sha256sums = a44456b7da55432867bcdfdda051a5b25601616a943fdc1dd1be30bd562f7ffb
+ sha256sums = a5fff678466443c0c8256c4771128c86103da47b6a2c49351d9941191b65dd6f
+ sha256sums = 1d5420e8babce5f4bbb3c68bdffe3bc0d3c3be25ad689138cd02fa14edd89140
+ sha256sums = 3d017c17a8788166c644e2460ba3596fd503f300342561921201fe5f69e5d194
+
+pkgname = keepass-wine
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2609a6c96344
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,84 @@
+# $Id$
+# Maintainer: kvaps <kvapss@gmail.com>
+
+pkgname=keepass-wine
+pkgver=2.34
+pkgrel=1
+pkgdesc='A easy-to-use password manager for Windows, Linux, Mac OS X and mobile devices.'
+arch=('any')
+url='http://keepass.info/'
+license=('GPL')
+depends=('wine' 'desktop-file-utils' 'xdg-utils' 'shared-mime-info' 'gtk-update-icon-cache')
+provides=('keepass')
+makedepends=('icoutils' 'mono')
+optdepends=('xdotool: if you want to use auto-type'
+ 'xsel: clipboard operations')
+install="$pkgname.install"
+source=("http://downloads.sourceforge.net/keepass/KeePass-$pkgver-Source.zip"
+ "http://keepass.info/integrity/v2/KeePass-$pkgver-Source.zip.asc"
+ "http://download.lenovo.com/ibmdl/pub/pc/pccbbs/thinkvantage_en/dotnetfx.exe"
+ 'keepass'
+ 'keepass.1'
+ 'keepass.desktop'
+ 'keepass.xml')
+
+sha256sums=('e3f184e4deddd1aa5ee2b52e2373c772d3f3975e5eddb2fd729eb27b437011aa'
+ 'SKIP'
+ '46693d9b74d12454d117cc61ff2e9481cabb100b4d74eb5367d3cf88b89a0e71'
+ 'a44456b7da55432867bcdfdda051a5b25601616a943fdc1dd1be30bd562f7ffb'
+ 'a5fff678466443c0c8256c4771128c86103da47b6a2c49351d9941191b65dd6f'
+ '1d5420e8babce5f4bbb3c68bdffe3bc0d3c3be25ad689138cd02fa14edd89140'
+ '3d017c17a8788166c644e2460ba3596fd503f300342561921201fe5f69e5d194')
+validpgpkeys=('C2DAB36D996021CF18B8D4F4158DFACCBE64B2C1')
+
+prepare() {
+ # "Convert" to mono 4.0
+ sed -i '1s/ 10.00/ 11.00/' KeePass.sln
+ find . -name "*.csproj" -exec sed -i '1s/"3.5"/"4.0"/' {} +
+
+ # Extract icons
+ icotool -x KeePass/KeePass.ico
+
+ pushd Build &>/dev/null
+ LANG=en_US.UTF-8 bash PrepMonoDev.sh
+ popd &>/dev/null
+}
+
+build() {
+ export WINEPREFIX=`pwd`/wine
+ export WINEARCH=win32
+ wine dotnetfx.exe /q:a /c:”install.exe /q”
+ #wine 'C:\windows\Microsoft.NET\Framework\v2.0.50727\MSBuild.exe' KeePass.sln /property:Configuration=Release
+ xbuild /target:KeePass /property:Configuration=Release
+ cp Ext/KeePass.exe.config Build/KeePass/Release/
+}
+
+package() {
+ install -dm755 "$pkgdir"/usr/bin
+ install -dm755 "$pkgdir"/usr/share/keepass/XSL
+ install -dm755 "$pkgdir"/usr/share/keepass/wine
+
+ install -Dm755 keepass "$pkgdir"/usr/bin/keepass
+ install -Dm755 Build/KeePass/Release/KeePass.exe "$pkgdir"/usr/share/keepass/KeePass.exe
+ install -Dm755 Ext/KeePass.config.xml "$pkgdir"/usr/share/keepass/KeePass.config.xml
+ install -Dm755 Ext/KeePass.exe.config "$pkgdir"/usr/share/keepass/KeePass.exe.config
+
+ install -m644 Ext/XSL/* "$pkgdir"/usr/share/keepass/XSL
+
+ install -Dm644 keepass.1 "$pkgdir"/usr/share/man/man1/keepass.1
+
+ cp -dr --no-preserve=ownership wine "$pkgdir"/usr/share/keepass/
+
+ # Proper installation of .desktop file
+ desktop-file-install -m 644 --dir "$pkgdir"/usr/share/applications/ keepass.desktop
+
+ # Install icons
+ for size in 16 32 48 256; do
+ install -Dm644 \
+ KeePass_*_${size}x${size}x32.png \
+ "$pkgdir"/usr/share/icons/hicolor/${size}x${size}/apps/keepass.png
+ done
+
+ # Needed for postinst with xdg-utils
+ install -Dm644 keepass.xml "$pkgdir"/usr/share/mime/packages/keepass.xml
+}
diff --git a/keepass b/keepass
new file mode 100644
index 000000000000..49063895b4f3
--- /dev/null
+++ b/keepass
@@ -0,0 +1,11 @@
+#!/bin/sh
+export WINEPREFIX="$HOME/.keepass/wine"
+export WINEARCH=win32
+export WINEDEBUG=-all
+
+if [ ! -d "$WINEPREFIX" ] ; then
+ mkdir -p "$WINEPREFIX"
+ cp -r "/usr/share/keepass/wine/*" "$WINEPREFIX"
+fi
+
+wine "/usr/share/keepass/KeePass.exe" "`winepath -w "$@"`"
diff --git a/keepass-wine.install b/keepass-wine.install
new file mode 100644
index 000000000000..8a562e60f49d
--- /dev/null
+++ b/keepass-wine.install
@@ -0,0 +1,14 @@
+post_remove() {
+ rm -f usr/share/keepass/KeePass.exe.so
+ rmdir --ignore-fail-on-non-empty usr/share/keepass/Plugins usr/share/keepass &> /dev/null
+}
+
+post_install() {
+ post_remove
+ mono --aot -O=all usr/share/keepass/KeePass.exe &> /dev/null
+ mkdir -p usr/share/keepass/Plugins
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/keepass.1 b/keepass.1
new file mode 100644
index 000000000000..7f4cb01672ac
--- /dev/null
+++ b/keepass.1
@@ -0,0 +1,23 @@
+.TH KEEPASS 1 "Mar 19, 2011"
+.SH NAME
+keepass \- password manager
+.SH SYNOPSIS
+.B keepass
+.SH DESCRIPTION
+\fBKeePass\fP is a free/open-source password manager or safe which helps you to manage your passwords in a secure way. You can put all your passwords in one database, which is locked with one master key or a key file. So you only have to remember one single master password to unlock the whole database. The databases are encrypted using AES-256.
+.SH OPTIONS
+.TP
+\fB\-\-auto-type\fP
+invokes global auto-type
+.TP
+\fB\-\-lock-all\fP
+lock databases of all KeePass instances
+.TP
+\fB\-\-unlock-all\fP
+unlock databases of all KeePass instances
+.TP
+\fB\-\-exit-all\fP
+exit all KeePass instances
+.SH AUTHOR
+This manual page was written by Julian Taylor <jtaylor.debian@googlemail.com>,
+for the Debian project (but may be used by others).
diff --git a/keepass.desktop b/keepass.desktop
new file mode 100644
index 000000000000..2ba721579296
--- /dev/null
+++ b/keepass.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Type=Application
+Name=KeePass Password Safe
+GenericName=Cross-platform password manager
+Comment=The free, open source, light-weight and easy-to-use password manager
+Exec=keepass
+Icon=keepass
+MimeType=application/x-keepass2;
+Terminal=false
+StartupNotify=false
+Categories=Utility;
+StartupWMClass=KeePass2
diff --git a/keepass.xml b/keepass.xml
new file mode 100644
index 000000000000..9282115a6652
--- /dev/null
+++ b/keepass.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/x-keepass2">
+ <comment>KeePass database</comment>
+ <glob pattern="*.kdbx"/>
+ </mime-type>
+</mime-info>