summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Wolf2016-03-16 14:49:06 +0100
committerSebastian Wolf2016-03-16 14:49:06 +0100
commit828ec67f68694236c59b45322cf9e62d4e0c2ec4 (patch)
treedec011a9520ce9a7989e6f0fbf23bb98ec792338
downloadaur-keepassx-meonwax-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD49
-rw-r--r--keepassx-meonwax-git.install19
3 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..140f778aa15b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,35 @@
+# Generated by mksrcinfo v8
+# Wed Mar 16 13:45:09 UTC 2016
+pkgbase = keepassx-meonwax-git
+ pkgdesc = Cross platform port of the windows application 'Keepass Password Safe' - Git version with patches my @meonwax
+ pkgver = 2.0.2.r68.gec14b98
+ pkgrel = 1
+ url = https://github.com/meonwax/keepassx
+ install = keepassx-meonwax-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ makedepends = intltool
+ makedepends = cmake
+ makedepends = qt5-base
+ makedepends = qt5-tools
+ makedepends = zlib
+ makedepends = libgcrypt
+ depends = libxtst
+ depends = shared-mime-info
+ depends = qt5-x11extras
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ conflicts = keepassx-svn
+ conflicts = keepassx
+ conflicts = keepassx2-git
+ conflicts = keepassx2
+ conflicts = keepassx2-yubikey-git
+ conflicts = keepassx-git
+ options = !emptydirs
+ source = git+https://github.com/meonwax/keepassx.git
+ md5sums = SKIP
+
+pkgname = keepassx-meonwax-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e34080c6b137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Lev Lybin <lev.lybin@gmail.com>
+# Contributor: Jamie Macdonald <jamie.alban@gmail.com>
+# Contributor: Alucryd <alucryd at gmail dot com>
+# Contributor: Paolo Stivanin <admin at polslinux dot it>
+# Contributor: Sebastian Wolf <fatmike303 at gmail dot com>
+
+pkgname=keepassx-meonwax-git
+_gitname=keepassx
+pkgver=2.0.2.r68.gec14b98
+pkgrel=1
+pkgdesc="Cross platform port of the windows application 'Keepass Password Safe' - Git version with patches my @meonwax"
+arch=('i686' 'x86_64')
+url="https://github.com/meonwax/keepassx"
+license=('GPL2')
+depends=('libxtst' 'shared-mime-info' 'qt5-x11extras' 'hicolor-icon-theme' 'desktop-file-utils')
+install=keepassx-meonwax-git.install
+makedepends=('git' 'intltool' 'cmake' 'qt5-base' 'qt5-tools' 'zlib' 'libgcrypt')
+conflicts=('keepassx-svn' 'keepassx' 'keepassx2-git' 'keepassx2' 'keepassx2-yubikey-git' 'keepassx-git')
+options=(!emptydirs)
+source=(git+https://github.com/meonwax/keepassx.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long | sed 's/^FOO-//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd ${_gitname}
+ mkdir -p build
+}
+
+build() {
+ cd "${_gitname}/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_BINDIR=/usr/bin \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_VERBOSE_MAKEFILE=OFF \
+ -DWITH_GUI_TESTS=ON \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd "${_gitname}/build"
+ make DESTDIR="${pkgdir}" install
+}
+
+
diff --git a/keepassx-meonwax-git.install b/keepassx-meonwax-git.install
new file mode 100644
index 000000000000..716c0a0d4694
--- /dev/null
+++ b/keepassx-meonwax-git.install
@@ -0,0 +1,19 @@
+post_install() {
+ update-mime-database /usr/share/mime 1> /dev/null
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ /bin/true
+}
+
+post_remove() {
+ update-mime-database /usr/share/mime 1> /dev/null
+ update-desktop-database -q
+ xdg-icon-resource forceupdate --theme hicolor
+}