summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Polishchuck2018-02-25 00:18:25 +0200
committerMaxim Polishchuck2018-02-25 00:18:25 +0200
commit2e26f01591d6fb96424626090f1187b12743c7ea (patch)
tree8bcafaaccbb866c2da3ea620ef65ae4062db1508
downloadaur-keepassx-zero-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fedc876d444
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by makepkg 5.0.2
+# Sat Feb 24 22:16:47 UTC 2018
+pkgbase = keepassx-zero-git
+ pkgdesc = KeePassX 0.4.4, customised to provide some convenience
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = http://www.keepassx.org
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = optipng
+ depends = libxtst
+ depends = qt4
+ depends = shared-mime-info
+ source = keepassx-zero::git+https://github.com/mpolishchuck/keepassx-zero.git
+ sha256sums = SKIP
+
+pkgname = keepassx-zero-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5568c3e5625
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# $Id$
+# Maintainer: Maxim Polishchuck <mpolishchuck@gmail.com>
+
+pkgname=keepassx-zero-git
+pkgver=0.4.4
+pkgrel=1
+pkgdesc='KeePassX 0.4.4, customised to provide some convenience'
+arch=('i686' 'x86_64')
+url='http://www.keepassx.org'
+license=('GPL2')
+depends=('libxtst' 'qt4' 'shared-mime-info')
+makedepends=('optipng')
+source=("keepassx-zero::git+https://github.com/mpolishchuck/keepassx-zero.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd keepassx-zero
+ find -name '*.png' -exec optipng -quiet -force -fix {} \;
+}
+
+build() {
+ cd keepassx-zero
+ qmake-qt4
+ make
+}
+
+package() {
+ cd keepassx-zero
+ make INSTALL_ROOT="$pkgdir" install
+}