summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Burgey2021-11-05 18:41:33 +0100
committerLukas Burgey2021-11-05 18:41:33 +0100
commit5ff791e858e3f48107aade0ed72a5cbc7fd409b4 (patch)
treec8f17d5ae093a43c1aeb9954be66ce3dbd556a60
downloadaur-kerl-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e078a45a06ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = kerl-git
+ pkgdesc = Easy building and installing of Erlang/OTP instances
+ pkgver = 2.2.2.r0.077d16d
+ pkgrel = 1
+ url = https://github.com/kerl/kerl
+ arch = i686
+ arch = x86_64
+ license = MIT
+ provides = kerl
+ conflicts = kerl
+ source = git+https://github.com/kerl/kerl
+ md5sums = SKIP
+
+pkgname = kerl-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e095dfb2825
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Lukas Burgey <mail@lukasburgey.de>
+
+basepkgname=kerl
+pkgname="${basepkgname}-git"
+pkgver=2.2.2.r0.077d16d
+pkgrel=1
+pkgdesc="Easy building and installing of Erlang/OTP instances"
+url="https://github.com/kerl/kerl"
+arch=(i686 x86_64)
+license=('MIT')
+provides=($basepkgname)
+conflicts=($basepkgname)
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$basepkgname"
+ git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/$basepkgname"
+ install -Dm755 kerl "$pkgdir/usr/bin/kerl"
+}