summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12024-01-12 19:22:35 +0800
committerChocobo12024-01-12 19:25:17 +0800
commit54c2991b443eca22cb4444daecf65f0597bfde1e (patch)
treed184a75a9c45cde1e15af89d6c420b625a63e072
parente4cbc56306e09ab9a4b09c407b8d9349dfe33c1e (diff)
downloadaur-keyutils-git.tar.gz
upgpkg: keyutils-git 1.6.3.r6.gc076dff-1
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD73
-rw-r--r--reproducible.patch24
-rw-r--r--request-key.conf.patch21
4 files changed, 56 insertions, 85 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 88a4cf8f5387..f655d0452d1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,25 @@
pkgbase = keyutils-git
- pkgdesc = Linux Key Management Utilities
- pkgver = 1.6.3
+ pkgdesc = Key management utilities
+ pkgver = 1.6.3.r6.gc076dff
pkgrel = 1
- url = https://www.kernel.org/
+ url = https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git/
+ arch = i686
arch = x86_64
- license = GPL2
- license = LGPL2.1
+ license = GPL
+ license = LGPL
makedepends = git
depends = glibc
depends = sh
+ provides = keyutils=1.6.3.r6.gc076dff
provides = libkeyutils.so
- provides = keyutils
conflicts = keyutils
+ options = staticlibs
backup = etc/request-key.conf
source = git+https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git
- source = request-key.conf.patch
- source = reproducible.patch
+ source = reproducible.patch::https://gitlab.archlinux.org/archlinux/packaging/packages/keyutils/-/raw/main/reproducible.patch
+ source = request-key.conf.patch::https://gitlab.archlinux.org/archlinux/packaging/packages/keyutils/-/raw/main/request-key.conf.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 203c602c61ed94ccd423a0a453d74143d678c641a9a4486367576ee8af2cb8d6
- sha256sums = 7bb7400b2b8c8f0288c86ec9191f8964a1e682745a204013d5fc7c2e1a253d8e
pkgname = keyutils-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 60b93ce03595..4ade66abd979 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,54 +1,69 @@
-# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+# Previous maintainer: Vincent Grande <shoober420@gmail.com>
# Contributor: Stéphane Gaudreault <stephane@archlinux.org>
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
pkgname=keyutils-git
-pkgver=1.6.3
+pkgver=1.6.3.r6.gc076dff
pkgrel=1
-pkgdesc='Linux Key Management Utilities'
-arch=('x86_64')
-url='https://www.kernel.org/'
-license=('GPL2' 'LGPL2.1')
+pkgdesc="Key management utilities"
+arch=('i686' 'x86_64')
+url="https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git/"
+license=('GPL' 'LGPL')
depends=('glibc' 'sh')
makedepends=('git')
-provides=('libkeyutils.so' 'keyutils')
+provides=("keyutils=$pkgver" 'libkeyutils.so')
conflicts=('keyutils')
backup=('etc/request-key.conf')
-#validpgpkeys=('A86E54B0D5E1B4E0AB7C640FFBB7576BA7CB0B6B') # David Howells <dhowells@redhat.com>
+options=('staticlibs')
source=("git+https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git"
- 'request-key.conf.patch' 'reproducible.patch')
+ "reproducible.patch::https://gitlab.archlinux.org/archlinux/packaging/packages/keyutils/-/raw/main/reproducible.patch"
+ "request-key.conf.patch::https://gitlab.archlinux.org/archlinux/packaging/packages/keyutils/-/raw/main/request-key.conf.patch")
sha256sums=('SKIP'
- '203c602c61ed94ccd423a0a453d74143d678c641a9a4486367576ee8af2cb8d6'
- '7bb7400b2b8c8f0288c86ec9191f8964a1e682745a204013d5fc7c2e1a253d8e')
+ 'SKIP'
+ 'SKIP')
-_commit() {
- # Convert HEAD into a shortened commit id:
- git rev-parse --short HEAD
+
+prepare() {
+ cd "keyutils"
+
+ patch -Np1 -i "$srcdir/reproducible.patch"
+ patch -Np0 -i "$srcdir/request-key.conf.patch"
}
pkgver() {
- cd keyutils
+ cd "keyutils"
- # Suggestions for improvement welcome!
- printf '%s.r%s.%s' \
- "$(_commit)"
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
-prepare() {
- cd keyutils
- # fix paths of binaries in /etc/request-key.conf
- patch -Np0 -i ../request-key.conf.patch
+build() {
+ cd "keyutils"
- # make keyutils reproducible
- patch -Np1 -i ../reproducible.patch
+ make \
+ CFLAGS="$CFLAGS" \
+ LDFLAGS="$LDFLAGS" \
+ BINDIR="/usr/bin" \
+ SBINDIR="/usr/bin"
}
-build() {
- cd keyutils
- make CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" SBINDIR='/usr/bin' BINDIR='/usr/bin'
+check() {
+ cd "keyutils"
+
+ #make test
}
package() {
- cd keyutils
- make DESTDIR="${pkgdir}" SBINDIR='/usr/bin' BINDIR='/usr/bin' LIBDIR='/usr/lib' USRLIBDIR='/usr/lib' install
+ cd "keyutils"
+
+ make \
+ DESTDIR="$pkgdir" \
+ BINDIR="/usr/bin" \
+ SBINDIR="/usr/bin" \
+ LIBDIR="/usr/lib" \
+ USRLIBDIR="/usr/lib" \
+ install
}
diff --git a/reproducible.patch b/reproducible.patch
deleted file mode 100644
index db5cfe82c3b5..000000000000
--- a/reproducible.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Adhere to the SOURCE_DATE_EPOCH standard and use it's date when set
-otherwise fall back to the default behaviour.
-
-Signed-off-by: Jelle van der Waa <jelle@vdwaa.nl>
----
- Makefile | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 33a451e..9066d5d 100644
---- a/Makefile
-+++ b/Makefile
-@@ -108,7 +108,7 @@ all: keyctl request-key key.dns_resolver
- ###############################################################################
- #RPATH = -Wl,-rpath,$(LIBDIR)
-
--VCPPFLAGS := -DPKGBUILD="\"$(shell date -u +%F)\""
-+VCPPFLAGS := -DPKGBUILD="\"$(date --utc --date="@${SOURCE_DATE_EPOCH:-$(date +%s)}" +%F)\""
- VCPPFLAGS += -DPKGVERSION="\"keyutils-$(VERSION)\""
- VCPPFLAGS += -DAPIVERSION="\"libkeyutils-$(APIVERSION)\""
-
---
-2.21.0
-
diff --git a/request-key.conf.patch b/request-key.conf.patch
deleted file mode 100644
index 9ab479631f54..000000000000
--- a/request-key.conf.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- request-key.conf.old 2013-05-28 15:34:10.966001242 +0200
-+++ request-key.conf 2013-05-28 15:35:34.857969598 +0200
-@@ -31,11 +31,11 @@
-
- #OP TYPE DESCRIPTION CALLOUT INFO PROGRAM ARG1 ARG2 ARG3 ...
- #====== ======= =============== =============== ===============================
--create dns_resolver * * /sbin/key.dns_resolver %k
--create user debug:* negate /bin/keyctl negate %k 30 %S
--create user debug:* rejected /bin/keyctl reject %k 30 %c %S
--create user debug:* expired /bin/keyctl reject %k 30 %c %S
--create user debug:* revoked /bin/keyctl reject %k 30 %c %S
--create user debug:loop:* * |/bin/cat
-+create dns_resolver * * /usr/bin/key.dns_resolver %k
-+create user debug:* negate /usr/bin/keyctl negate %k 30 %S
-+create user debug:* rejected /usr/bin/keyctl reject %k 30 %c %S
-+create user debug:* expired /usr/bin/keyctl reject %k 30 %c %S
-+create user debug:* revoked /usr/bin/keyctl reject %k 30 %c %S
-+create user debug:loop:* * |/usr/bin/cat
- create user debug:* * /usr/share/keyutils/request-key-debug.sh %k %d %c %S
--negate * * * /bin/keyctl negate %k 30 %S
-+negate * * * /usr/bin/keyctl negate %k 30 %S