summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2023-12-18 07:52:12 -0700
committernot_anonymous2023-12-18 07:52:12 -0700
commit68d40fbad299a0240535debe95d8ad5dfa4e85c9 (patch)
tree5e2cf61c4d9c1123bb9f1697fea8c2f89bb7233f
downloadaur-kh1utility.tar.gz
Initial upload
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD36
-rw-r--r--kh1utility.15
-rw-r--r--kh1utility.desktop14
4 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1771fa0783db
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = kh1utility
+ pkgdesc = Elecraft Factory APP for use with the KH1 Ham Radio.
+ pkgver = 1_23_12_12
+ pkgrel = 1
+ url = https://elecraft.com/pages/kh1-hand-held-5-band-cw-transceiver-firmware-and-utility
+ arch = x86_64
+ license = custom:ELECRAFT
+ depends = gcc-libs
+ depends = gtk2
+ depends = curl
+ depends = hamradio-menus
+ options = !strip
+ source = https://ftp.elecraft.com/KH1/Utilities/KH1UtilityLINUX64BIT_1_23_12_12.tar.gz
+ source = kh1utility.1
+ source = kh1utility.desktop
+ md5sums = 5e70dc93751a8269b7459a44b619e3ad
+ md5sums = 30cc5c211138ce078c087cecaafdfafd
+ md5sums = 0afe198b2a69e1cb53209f8e5e2cf499
+ sha256sums = 950ab6aa626814c43d88c50b0c11e0a772c34324ef76956d0f07d024e688472f
+ sha256sums = a35c08dee98395eb599ebb43f38bc1bbf9d313878bcec2182609ebfa773067e3
+ sha256sums = ca6378b792d366b5d4f76add9da7be8bb20ca5fa2b068965ddf38ec9109ad086
+
+pkgname = kh1utility
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..299943f7b41f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+
+pkgname=kh1utility
+_pkgname=KH1UtilityLINUX64BIT
+pkgver=1_23_12_12
+pkgrel=1
+pkgdesc="Elecraft Factory APP for use with the KH1 Ham Radio."
+arch=('x86_64')
+url="https://elecraft.com/pages/kh1-hand-held-5-band-cw-transceiver-firmware-and-utility"
+license=('custom:ELECRAFT')
+depends=('gcc-libs' 'gtk2' 'curl' 'hamradio-menus')
+options=('!strip')
+source=(https://ftp.elecraft.com/KH1/Utilities/${_pkgname}_$pkgver.tar.gz
+ $pkgname.1
+ $pkgname.desktop)
+
+package() {
+ cd $srcdir/${_pkgname}_$pkgver
+
+ install -d $pkgdir/usr/share/$pkgname
+ cp -a * $pkgdir/usr/share/$pkgname
+
+ mkdir -p $pkgdir/usr/bin
+ install -D -m 755 ../$pkgname.1 $pkgdir/usr/bin/$pkgname
+
+ mkdir -p $pkgdir/usr/share/{applications,pixmaps,licenses/$pkgname}
+ install -D -m 644 Help/License.rtf $pkgdir/usr/share/licenses/$pkgname
+ install -D -m 644 Resources/icon-48.png $pkgdir/usr/share/pixmaps/kh1utility.png
+ install -D -m 644 ../$pkgname.desktop $pkgdir/usr/share/applications
+}
+md5sums=('5e70dc93751a8269b7459a44b619e3ad'
+ '30cc5c211138ce078c087cecaafdfafd'
+ '0afe198b2a69e1cb53209f8e5e2cf499')
+sha256sums=('950ab6aa626814c43d88c50b0c11e0a772c34324ef76956d0f07d024e688472f'
+ 'a35c08dee98395eb599ebb43f38bc1bbf9d313878bcec2182609ebfa773067e3'
+ 'ca6378b792d366b5d4f76add9da7be8bb20ca5fa2b068965ddf38ec9109ad086')
diff --git a/kh1utility.1 b/kh1utility.1
new file mode 100644
index 000000000000..38906a0ce555
--- /dev/null
+++ b/kh1utility.1
@@ -0,0 +1,5 @@
+#!/bin/sh
+mkdir -p $HOME/kh1utility
+cd $HOME/kh1utility
+cp -ua /usr/share/kh1utility/* .
+exec ./kh1util
diff --git a/kh1utility.desktop b/kh1utility.desktop
new file mode 100644
index 000000000000..8d16ab3a4d85
--- /dev/null
+++ b/kh1utility.desktop
@@ -0,0 +1,14 @@
+[Desktop Entry]
+Name=KH1-Utility
+Name[en_US]=KH1-Utility
+Comment=Elecraft KH1 Control Utility
+Comment[en_US]=Elecraft KH1 Control Utility
+Exec=kh1utility
+Icon=kh1utility
+MimeType=text/plain
+StartupNotify=false
+Terminal=false
+Type=Application
+Categories=Network;HamRadio;
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false